[PATCH 1/1] gnu: add ruby-text-table

  • Open
  • quality assurance status badge
Details
2 participants
  • Aaron Covrig
  • Quanrong
Owner
unassigned
Submitted by
Quanrong
Severity
normal
Q
Q
Quanrong wrote on 13 Nov 13:12 +0100
(address . guix-patches@gnu.org)
31005192-0db9-4e8c-9380-7f972337f59f@mailbox.org
* gnu/packages/ruby.scm (ruby-text-table): New variable.

Change-Id: If2a1990997333085f0ed5cc2895e47984a376722
---
gnu/packages/ruby.scm | 22 +++++++++++++++++++++-
1 file changed, 21 insertions(+), 1 deletion(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 13092bedf2..50d890b731 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2020 Holgr Peters <holger.peters@posteo.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 EuAndreh <eu@euandre.org>
-;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
+;;; Copyright © 2020, 2024 Tomás Ortín Fernández <quanrong@mailbox.org>
;;; Copyright © 2021 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022-2024 Remco van 't Veer <remco@remworks.net>
@@ -14872,6 +14872,26 @@ (define-public ruby-terminal-table
Unicode formatted tables.")
(license license:expat)))

+(define-public ruby-text-table
+ (package
+ (name "ruby-text-table")
+ (version "1.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "text-table" version))
+ (sha256
+ (base32 "06yhlnb49fn0fhkmi6lrziyv2hd42gcm2zi3sggm2qab48qxn94j"))))
+ (build-system ruby-build-system)
+ (synopsis
+ "Allows you to easily create and format plain text tables, useful
when working with the terminal or when you want to quickly print
formatted tables to a dot-matrix printer.")
+ (description
+ "Allows you to easily create and format plain text tables, useful
when working
+with the terminal or when you want to quickly print formatted tables to a
+dot-matrix printer.")
+ (home-page "https://github.com/aptinio/text-table")
+ (license license:expat)))
+
(define-public jekyll
(package
(name "jekyll")

base-commit: 1f057603ef59c7b9c32f610a897321fd75dc4dad
prerequisite-patch-id: 1b22355642355a77f0f59a2489da2e31e16c65da
prerequisite-patch-id: a508f4f08de1cfda59ad18891b5f066ed028dac8
--
2.46.0
A
A
Aaron Covrig wrote 2 days ago
[PATCH] gnu: add ruby-text-table
(address . 74342@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241126022800.40701-1-aaron.covrig.us@ieee.org
* gnu/packages/ruby.scm (ruby-text-table): New variable.
---
Thank you for the addition, I cleaned up some corruption and linting
guidelines in the commit, along with disabling tests as there seem to be
none defined (although I am not particularly familiar with Ruby).
Additionally, I split the Copyright change across two lines to preserve
the original name and email combination while also adding in the new name
and email combination (I'm not sure what Guix's official policy is to
resolve changing name and email relations from the Copyright header, so
someone more familiar with the project will need to finalize that).

Additionally, for reviewers I have only tested this via building and not
attempted to use the package to verify that it works.

v/r,

Aaron

gnu/packages/ruby.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f08d52dbc8..c7b66c0482 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 EuAndreh <eu@euandre.org>
;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
+;;; Copyright © 2024 Tomás Ortín Fernández <quanrong@mailbox.org>
;;; Copyright © 2021 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022-2024 Remco van 't Veer <remco@remworks.net>
@@ -15585,6 +15586,27 @@ (define-public ruby-sinatra
(home-page "https://sinatrarb.com/")
(license license:expat)))
+(define-public ruby-text-table
+ (package
+ (name "ruby-text-table")
+ (version "1.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "text-table" version))
+ (sha256
+ (base32 "06yhlnb49fn0fhkmi6lrziyv2hd42gcm2zi3sggm2qab48qxn94j"))))
+ (build-system ruby-build-system)
+ (arguments (list #:tests? #f))
+ (synopsis "Allows you to easily create and format plain text tables")
+ (description
+ "Allows you to easily create and format plain text tables, useful
+when working
+with the terminal or when you want to quickly print formatted tables to a
+dot-matrix printer.")
+ (home-page "https://github.com/aptinio/text-table")
+ (license license:expat)))
+
(define-public ruby-timeout
(package
(name "ruby-timeout")

base-commit: 9b1fb12978482ffb6d37c456343f05609b28b3e8
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74342@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74342
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch