[PATCH 1/1] gnu: add ruby-solargraph-rails

  • Open
  • quality assurance status badge
Details
One participant
  • Quanrong
Owner
unassigned
Submitted by
Quanrong
Severity
normal
Q
Q
Quanrong wrote 34 hours ago
(address . guix-patches@gnu.org)
14809b4e-c521-4364-83a1-c82586d2aaf9@mailbox.org
* gnu/packages/ruby.scm (ruby-solargraph-rails): New variable.

Change-Id: I55313a3abfe14300521b4c3db1247c333137c24c
---
gnu/packages/ruby.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 12c439b3a9..13092bedf2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -15926,6 +15926,27 @@ (define-public ruby-solargraph
(home-page "https://solargraph.org/")
(license license:expat)))

+(define-public ruby-solargraph-rails
+ (package
+ (name "ruby-solargraph-rails")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "solargraph-rails" version))
+ (sha256
+ (base32 "1xp39zxz43r7psp6j8xhdcpr7pmi8giw2jn34ykyhg9fixxw5by4"))))
+ (build-system ruby-build-system)
+ (propagated-inputs (list ruby-activesupport ruby-solargraph))
+ (arguments (list #:tests? #f))
+ (synopsis
+ "Solargraph plugin to add reflection on Rails ActiveModel dynamic
attributes")
+ (description
+ "Solargraph plugin to add reflection on @code{ActiveModel} dynamic
attributes that will be created at
+runtime.")
+ (home-page "https://github.com/iftheshoefritz/solargraph-rails")
+ (license license:expat)))
+
(define-public ruby-wayback-machine-downloader
(package
(name "ruby-wayback-machine-downloader")

base-commit: 1f057603ef59c7b9c32f610a897321fd75dc4dad
prerequisite-patch-id: 1b22355642355a77f0f59a2489da2e31e16c65da
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74341@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74341
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch