[PATCH 1/1] gnu: add ruby-solargraph-rails

  • Open
  • quality assurance status badge
Details
2 participants
  • Aaron Covrig
  • Quanrong
Owner
unassigned
Submitted by
Quanrong
Severity
normal

Debbugs page

Quanrong wrote 4 months ago
(address . guix-patches@gnu.org)
14809b4e-c521-4364-83a1-c82586d2aaf9@mailbox.org
* gnu/packages/ruby.scm (ruby-solargraph-rails): New variable.

Change-Id: I55313a3abfe14300521b4c3db1247c333137c24c
---
gnu/packages/ruby.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 12c439b3a9..13092bedf2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -15926,6 +15926,27 @@ (define-public ruby-solargraph
(home-page "https://solargraph.org/")
(license license:expat)))

+(define-public ruby-solargraph-rails
+ (package
+ (name "ruby-solargraph-rails")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "solargraph-rails" version))
+ (sha256
+ (base32 "1xp39zxz43r7psp6j8xhdcpr7pmi8giw2jn34ykyhg9fixxw5by4"))))
+ (build-system ruby-build-system)
+ (propagated-inputs (list ruby-activesupport ruby-solargraph))
+ (arguments (list #:tests? #f))
+ (synopsis
+ "Solargraph plugin to add reflection on Rails ActiveModel dynamic
attributes")
+ (description
+ "Solargraph plugin to add reflection on @code{ActiveModel} dynamic
attributes that will be created at
+runtime.")
+ (home-page "https://github.com/iftheshoefritz/solargraph-rails")
+ (license license:expat)))
+
(define-public ruby-wayback-machine-downloader
(package
(name "ruby-wayback-machine-downloader")

base-commit: 1f057603ef59c7b9c32f610a897321fd75dc4dad
prerequisite-patch-id: 1b22355642355a77f0f59a2489da2e31e16c65da
--
2.46.0
Aaron Covrig wrote 4 months ago
[PATCH] gnu: add ruby-solargraph-rails
(address . 74341@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241126021148.39367-1-aaron.covrig.us@ieee.org
* gnu/packages/ruby.scm (ruby-solargraph-rails): New variable.
---

Thank you Quanrong for your submission, I have cleaned up a few issues
in the patchfile. For reviewers, I have only verified that the build
succeeds and not conducted any testing beyond that.

gnu/packages/ruby.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f08d52dbc8..d7a8a043ba 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -15952,6 +15952,28 @@ (define-public ruby-solargraph
(home-page "https://solargraph.org/")
(license license:expat)))
+(define-public ruby-solargraph-rails
+ (package
+ (name "ruby-solargraph-rails")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "solargraph-rails" version))
+ (sha256
+ (base32 "1xp39zxz43r7psp6j8xhdcpr7pmi8giw2jn34ykyhg9fixxw5by4"))))
+ (build-system ruby-build-system)
+ (propagated-inputs (list ruby-activesupport ruby-solargraph))
+ (arguments (list #:tests? #f))
+ (synopsis
+ "Solargraph plugin to add reflection on Rails ActiveModel dynamic
+attributes")
+ (description
+ "Solargraph plugin to add reflection on @code{ActiveModel} dynamic
+attributes that will be created at runtime.")
+ (home-page "https://github.com/iftheshoefritz/solargraph-rails")
+ (license license:expat)))
+
(define-public ruby-wayback-machine-downloader
(package
(name "ruby-wayback-machine-downloader")

base-commit: 9b1fb12978482ffb6d37c456343f05609b28b3e8
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74341@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74341
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help