Subject: [PATCH 1/1] gnu: Add stdman

  • Open
  • quality assurance status badge
Details
2 participants
  • Noé Lopez
  • Quanrong
Owner
unassigned
Submitted by
Quanrong
Severity
normal
Q
Q
Quanrong wrote 34 hours ago
(address . guix-patches@gnu.org)
022e3f60-916c-4f89-b0cf-8647cc67d67c@mailbox.org
* gnu/packages/documentation.scm (stdman): New variable.

Change-Id: I4ed70b6ad4208bde4df13d45fd7241096f2469a1
---
gnu/packages/documentation.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index f0e37561f7..928e022239 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2022 Maxim Cournoyer <maxim.counoyer@gmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2024 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2024 Tomás Ortín Fernández <quanrong@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -566,3 +567,27 @@ (define-public stddoc
supported programming languages. Markdeep code comments are extracted
from stdin and
printed into stdout as a HTML file.")
(license license:unlicense))))
+
+(define-public stdman
+ (let ((commit "b7070fe10143411a8d69fe3a9f75e90008a8386d")
+ (revision "0")) ;; Last release is outdated
+ (package
+ (name "stdman")
+ (version (git-version "20240610" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit commit)
+ (url "https://github.com/jeaye/stdman")))
+ (sha256
+ (base32 "0h1gfw4sxic5gx073zmshg4qyz2g142ckgzyj30pk8j708mnl8pz"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;; There are no tests
+ #:phases #~(modify-phases %standard-phases
+ (delete 'build))))
+ (description "Formatted C++ @code{stdlib} man pages from
cppreference")
+ (synopsis "stdman is a tool that provides C++ @code{stdlib}
documentation archived from cppreference as groff-formated man pages,
accessible from the @code{man} command.")
+ (home-page "https://github.com/jeaye/stdman")
+ (license license:expat))))

base-commit: 1f057603ef59c7b9c32f610a897321fd75dc4dad
--
2.46.0
N
N
Noé Lopez wrote 6 hours ago
(address . 74340@debbugs.gnu.org)(name . Quanrong)(address . quanrong@mailbox.org)
878qtlvm00.fsf@xn--no-cja.eu
Hi,

Thank you for your patch, the package works well but there are a few
style errors:

Toggle quote (43 lines)
> * gnu/packages/documentation.scm (stdman): New variable.
>
> Change-Id: I4ed70b6ad4208bde4df13d45fd7241096f2469a1
> ---
> gnu/packages/documentation.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
> index f0e37561f7..928e022239 100644
> --- a/gnu/packages/documentation.scm
> +++ b/gnu/packages/documentation.scm
> @@ -14,6 +14,7 @@
> ;;; Copyright © 2022 Maxim Cournoyer <maxim.counoyer@gmail.com>
> ;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
> ;;; Copyright © 2024 Felix Gruber <felgru@posteo.net>
> +;;; Copyright © 2024 Tomás Ortín Fernández <quanrong@mailbox.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -566,3 +567,27 @@ (define-public stddoc
> supported programming languages. Markdeep code comments are extracted
> from stdin and
> printed into stdout as a HTML file.")
> (license license:unlicense))))
> +
> +(define-public stdman
> + (let ((commit "b7070fe10143411a8d69fe3a9f75e90008a8386d")
> + (revision "0")) ;; Last release is outdated
> + (package
> + (name "stdman")
> + (version (git-version "20240610" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (commit commit)
> + (url "https://github.com/jeaye/stdman")))
> + (sha256
> + (base32 "0h1gfw4sxic5gx073zmshg4qyz2g142ckgzyj30pk8j708mnl8pz"))))
> + (build-system gnu-build-system)
> + (arguments
> + (list
> + #:tests? #f ;; There are no tests

There should be a dot at the end of comments, and only one semicolon if
it’s a margin comment.

Toggle quote (8 lines)
> + #:phases #~(modify-phases %standard-phases
> + (delete 'build))))
> + (description "Formatted C++ @code{stdlib} man pages from
> cppreference")
> + (synopsis "stdman is a tool that provides C++ @code{stdlib}
> documentation archived from cppreference as groff-formated man pages,
> accessible from the @code{man} command.")

Description and synopsis are swapped (synopsis should be the small one).

Toggle quote (7 lines)
> + (license license:expat))))
>
> base-commit: 1f057603ef59c7b9c32f610a897321fd75dc4dad
> --
> 2.46.0

I’m sending an updated patch with these small modifications.

Have a good day,
Noé
N
N
Noé Lopez wrote 6 hours ago
[PATCH v2] gnu: Add stdman.
(address . 74340@debbugs.gnu.org)(name . Quanrong)(address . quanrong@mailbox.org)
8ac8ea557940d5dff1b53c801d3449c15faee46f.1731600497.git.noelopez@free.fr
From: Quanrong <quanrong@mailbox.org>

* gnu/packages/documentation.scm (stdman): New variable.

Change-Id: I4ed70b6ad4208bde4df13d45fd7241096f2469a1
---
gnu/packages/documentation.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index f0e37561f7..44ab571ff8 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2022 Maxim Cournoyer <maxim.counoyer@gmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2024 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2024 Tomás Ortín Fernández <quanrong@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -566,3 +567,29 @@ (define-public stddoc
supported programming languages. Markdeep code comments are extracted from stdin and
printed into stdout as a HTML file.")
(license license:unlicense))))
+
+(define-public stdman
+ (let ((commit "b7070fe10143411a8d69fe3a9f75e90008a8386d")
+ (revision "0")) ;; Last release is outdated
+ (package
+ (name "stdman")
+ (version (git-version "20240610" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit commit)
+ (url "https://github.com/jeaye/stdman")))
+ (sha256
+ (base32 "0h1gfw4sxic5gx073zmshg4qyz2g142ckgzyj30pk8j708mnl8pz"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; There are no tests.
+ #:phases #~(modify-phases %standard-phases
+ (delete 'build))))
+ (synopsis "Formatted C++ @code{stdlib} man pages from cppreference")
+ (description "stdman is a tool that provides C++ @code{stdlib} documentation
+archived from cppreference as groff-formated man pages, accessible from the
+@code{man} command.")
+ (home-page "https://github.com/jeaye/stdman")
+ (license license:expat))))

base-commit: b790db7589858fc77989b4d1f369c52bca6d6e7c
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74340@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74340
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch