[PATCH] gnu: postgresql-10: Replace deprecated dependency.

  • Done
  • quality assurance status badge
Details
2 participants
  • David Pflug
  • Ludovic Courtès
Owner
unassigned
Submitted by
David Pflug
Severity
normal

Debbugs page

David Pflug wrote 4 months ago
(address . guix-patches@gnu.org)(name . David Pflug)(address . david@pflug.io)
41a02b7521ad128895a1b76ce49b2c82df7ee6af.1731261253.git.david@pflug.io
* gnu/packages/databases.scm (postgresql-10): Inherit postgresql-13
instead of 11.

Using the deprecated postgresql-11 package was causing warnings to be
printed on `guix pull`.

Change-Id: I36225ff2a1889f94cd5aabe229ee638793594abf
---
gnu/packages/databases.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 06158f19e7..d1553d91b4 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1394,17 +1394,17 @@ (define-deprecated/public postgresql-11 #f
(define-deprecated/public postgresql-10 #f
(package
- (inherit postgresql-11)
+ (inherit postgresql-13)
(version "10.23")
(source (origin
- (inherit (package-source postgresql-11))
+ (inherit (package-source postgresql-13))
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
"1sgfssjc9lnzijhn108r6z26fri655k413f1c9b8wibjhd9b594l"))))
(native-inputs
- (modify-inputs (package-native-inputs postgresql-11)
+ (modify-inputs (package-native-inputs postgresql-13)
(append opensp docbook-sgml-4.2)
(delete "docbook-xml")))))

base-commit: f5ca62fcadf7a1a61cb13dc89edcfd3e9884e9e0
--
2.46.0
Ludovic Courtès wrote 4 months ago
(name . David Pflug)(address . david@pflug.io)
87msi1oowz.fsf@gnu.org
David Pflug <david@pflug.io> skribis:

Toggle quote (8 lines)
> * gnu/packages/databases.scm (postgresql-10): Inherit postgresql-13
> instead of 11.
>
> Using the deprecated postgresql-11 package was causing warnings to be
> printed on `guix pull`.
>
> Change-Id: I36225ff2a1889f94cd5aabe229ee638793594abf

Applied, thanks! Those warnings were annoying, indeed.

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74297@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74297
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help