[PATCH gnome-team 0/3] Add lock

  • Open
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 9 Nov 11:25 +0100
(address . guix-patches@gnu.org)
cover.1731147955.git.liliana.prikler@gmail.com
Hi Guix,

departing a little from my usual big gnome-team things, this series
adds lock, a small graphical frontend for GPG.

Cheers

Liliana Marie Prikler (3):
gnu: blueprint-compiler: Fix build.
gnu: blueprint-compiler: Update to 0.14.0.
gnu: Add lock.

gnu/packages/gnome.scm | 51 ++++++++++++++++++++++++++++++++++++++++--
1 file changed, 49 insertions(+), 2 deletions(-)


base-commit: f7687540f6168f5cc2730d7525e699b0deaf4ac1
--
2.46.0
L
L
Liliana Marie Prikler wrote on 29 Oct 10:36 +0100
[PATCH gnome-team 2/3] gnu: blueprint-compiler: Update to 0.14.0.
(address . 74278@debbugs.gnu.org)
fc1a26e105e7ed3e9d72471ea9f586e5eec174ff.1731147955.git.liliana.prikler@gmail.com
* gnu/packages/gnome.scm (blueprint-compiler): Update to 0.14.0.
[#:phases]<fix-tests>: Adjust accordingly.
---
gnu/packages/gnome.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fc60721fb5..7ae4e570fe 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3334,7 +3334,7 @@ (define-public glade3
(define-public blueprint-compiler
(package
(name "blueprint-compiler")
- (version "0.12.0")
+ (version "0.14.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3344,7 +3344,7 @@ (define-public blueprint-compiler
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "15cm2bksmygf8sifryrawxxblvvw27p4w3m42gvp3jlq50a15xm6"))))
+ "0day3ayf6nji86jxcimf1qgim3c7li08jsgbdh4ahbbv4g2d6im6"))))
(build-system meson-build-system)
(arguments
(list
@@ -3367,7 +3367,7 @@ (define-public blueprint-compiler
(dump-port in out)
(newline out)
(display
- "9,3,12,signal Gtk.Window::keys-changed () is deprecated\n"
+ "8,3,12,signal Gtk.Window::keys-changed () is deprecated\n"
out)))))
(add-before 'check 'pre-check
(lambda _
--
2.46.0
L
L
Liliana Marie Prikler wrote on 29 Oct 10:22 +0100
[PATCH gnome-team 1/3] gnu: blueprint-compiler: Fix build.
(address . 74278@debbugs.gnu.org)
6ee8825aa50944d148c106b000405b36ef316dae.1731147955.git.liliana.prikler@gmail.com
* gnu/packages/gnome.scm (blueprint-compiler)[#:phases]: Add ‘fix-tests’.
---
gnu/packages/gnome.scm | 10 ++++++++++
1 file changed, 10 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 733fd2720d..fc60721fb5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3359,6 +3359,16 @@ (define-public blueprint-compiler
#~(modify-phases %standard-phases
(add-after 'glib-or-gtk-wrap 'wrap-python
(assoc-ref python:%standard-phases 'wrap))
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (with-atomic-file-replacement
+ "tests/sample_errors/deprecations.err"
+ (lambda (in out)
+ (dump-port in out)
+ (newline out)
+ (display
+ "9,3,12,signal Gtk.Window::keys-changed () is deprecated\n"
+ out)))))
(add-before 'check 'pre-check
(lambda _
(system "Xvfb :1 &")
--
2.46.0
L
L
Liliana Marie Prikler wrote on 29 Oct 10:37 +0100
[PATCH gnome-team 3/3] gnu: Add lock.
(address . 74278@debbugs.gnu.org)
67d315dc50a8e8badaed7a272ffcdd2c58b6e436.1731147955.git.liliana.prikler@gmail.com
* gnu/packages/gnome.scm (lock): New variable.
---
gnu/packages/gnome.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7ae4e570fe..2d969443fc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -14267,3 +14267,40 @@ (define-public gnome-connections
real or virtual machines, using @acronym{VNC, Virtual Network Computing}
or @acronym{RDP, Remote Desktop Protocol}.")
(license license:gpl3+)))
+
+(define-public lock
+ (package
+ (name "lock")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/konstantintutsch/Lock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sq7mk4j3jzs1gzzql938d58gvrz6cp0ingzaxilffdpbpvj4fn3"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:meson meson-1.5
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("(gtk_update_icon_cache|update_desktop_database): true" _ key)
+ (string-append key ": false"))))))))
+ (inputs (list gpgme-1.23
+ glib
+ libadwaita))
+ (native-inputs (list blueprint-compiler
+ gettext-minimal
+ gobject-introspection
+ `(,glib "bin")
+ pkg-config))
+ (home-page "https://konstantintutsch.com/Lock")
+ (synopsis "Graphical front-end for GNU Privacy Guard")
+ (description "This package provides a graphical frontend for
+GNU Privacy Guard built with libadwaita.")
+ (license license:expat)))
--
2.46.0
M
M
Maxim Cournoyer wrote 7 days ago
Re: [bug#74278] [PATCH gnome-team 0/3] Add lock
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
875xovxxf7.fsf@gmail.com
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (13 lines)
> Hi Guix,
>
> departing a little from my usual big gnome-team things, this series
> adds lock, a small graphical frontend for GPG.
>
> Cheers
>
> Liliana Marie Prikler (3):
> gnu: blueprint-compiler: Fix build.
> gnu: blueprint-compiler: Update to 0.14.0.
> gnu: Add lock.
>

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74278@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74278
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch