* gnu/packages/gnome.scm (lock): New variable.
---
gnu/packages/gnome.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
Toggle diff (47 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7ae4e570fe..2d969443fc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -14267,3 +14267,40 @@ (define-public gnome-connections
real or virtual machines, using @acronym{VNC, Virtual Network Computing}
or @acronym{RDP, Remote Desktop Protocol}.")
(license license:gpl3+)))
+
+(define-public lock
+ (package
+ (name "lock")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/konstantintutsch/Lock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sq7mk4j3jzs1gzzql938d58gvrz6cp0ingzaxilffdpbpvj4fn3"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:meson meson-1.5
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("(gtk_update_icon_cache|update_desktop_database): true" _ key)
+ (string-append key ": false"))))))))
+ (inputs (list gpgme-1.23
+ glib
+ libadwaita))
+ (native-inputs (list blueprint-compiler
+ gettext-minimal
+ gobject-introspection
+ `(,glib "bin")
+ pkg-config))
+ (home-page "https://konstantintutsch.com/Lock")
+ (synopsis "Graphical front-end for GNU Privacy Guard")
+ (description "This package provides a graphical frontend for
+GNU Privacy Guard built with libadwaita.")
+ (license license:expat)))
--
2.46.0