(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
* gnu/packages/emacs-xyz.scm (emacs-mistty): New variable.
Change-Id: I13c67437d6cb7813d1d399626e52834019cb41f0
---
gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (47 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 88e1ab89a9..7c3400ef93 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4447,6 +4447,38 @@ (define-public emacs-coterm
-nw}.")
(license license:gpl3+)))
+(define-public emacs-mistty
+ (let ((revision "0")
+ (commit "6284c0f6529bcce57d183e20765052c603846115"))
+ (package
+ (name "emacs-mistty")
+ (version (git-version "1.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/szermatt/mistty")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1159dy63dq7kyh06q9kfvq6x4bx59w9g1slq2m3xvx2ngaiydf97"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'patch-el-files 'replace-bash-path
+ (lambda _
+ (substitute* "mistty-term.el"
+ (("/bin/bash")
+ "/path/to/bash")))))))
+ (home-page "https://github.com/szermatt/mistty")
+ (synopsis "Emacs terminal major mode based on @file{term.el}")
+ (description
+ "This package defines a major mode for Emacs 29.1 and up that runs a shell
+inside of a buffer, similarly to comint mode, started with @samp{M-x mistty} or
+@samp{M-x mistty-create}. It is built on top of @file{term.el}.")
+ (license license:gpl3+))))
+
(define-public emacs-counsel-bbdb
(package
(name "emacs-counsel-bbdb")
base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
--
2.46.0