[PATCH] gnu: entr: Update to 5.6.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ekaitz Zarraga
  • Ludovic Courtès
  • Javier Olaechea
Owner
unassigned
Submitted by
Javier Olaechea
Severity
normal
J
J
Javier Olaechea wrote on 9 Nov 00:02 +0100
(address . guix-patches@gnu.org)
CAFVS=zChJ-yCXnK5249udO1cVw2nKvZmi7uJko+BOVw1Wwq9fQ@mail.gmail.com
Hi, attached is a patch entr to its latest version, 5.6

Cheers,
Javier Olaechea

--
"I object to doing things that computers can do." — Olin Shivers
Attachment: file
From ae09a012f969a700292bdaf9556b515196a6ef38 Mon Sep 17 00:00:00 2001
Message-ID: <ae09a012f969a700292bdaf9556b515196a6ef38.1731106818.git.pirata@gmail.com>
From: Javier Olaechea <pirata@gmail.com>
Date: Fri, 8 Nov 2024 17:55:45 -0500
Subject: [PATCH] gnu: entr: Update to 5.6.

* gnu/packages/entr.scm (entr): Update to 5.6.

Change-Id: Idfa2fc88e526deccc7a9ff4d07ede6b0dc6daf72
---
gnu/packages/entr.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/entr.scm b/gnu/packages/entr.scm
index 5a8bbc8e4f..bb09acd6aa 100644
--- a/gnu/packages/entr.scm
+++ b/gnu/packages/entr.scm
@@ -36,14 +36,14 @@ (define-module (gnu packages entr)
(define-public entr
(package
(name "entr")
- (version "5.5")
+ (version "5.6")
(source (origin
(method url-fetch)
(uri (string-append "https://eradman.com/entrproject/code/entr-"
version ".tar.gz"))
(sha256
(base32
- "09p5aqbb95bysdx73n094v0b07hn3v9kqg6k7yyycnpaxzi0r30j"))))
+ "0kniklgnqv4j9carm78d3423wlwqw1ykxmlla4xmlfwdjbgvh8h2"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"

base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
--
2.46.0
J
J
Javier Olaechea wrote on 9 Nov 01:27 +0100
[PATCH] gnu: entr: Update to 5.6
CAFVS=zBpVxkrzKh3BdU7mPBrHvLjqnwxxc4fAhr1Wak_QJD02w@mail.gmail.com
Adding two more patches on top

The first one makes the package conform with guix style. The second one
follows a recommendation made by guix lint, to swap bash for bash-minimal.
I have verified that after doing the package not only builds but the entr
executable behaves as expected

Cheers,
Javier Olaechea

--
"I object to doing things that computers can do." — Olin Shivers
Attachment: file
From b1646199f4aefa9c40f4b0971dedaad3e167abdd Mon Sep 17 00:00:00 2001
Message-ID: <b1646199f4aefa9c40f4b0971dedaad3e167abdd.1731110707.git.pirata@gmail.com>
In-Reply-To: <ae09a012f969a700292bdaf9556b515196a6ef38.1731110707.git.pirata@gmail.com>
References: <ae09a012f969a700292bdaf9556b515196a6ef38.1731110707.git.pirata@gmail.com>
From: Javier Olaechea <pirata@gmail.com>
Date: Fri, 8 Nov 2024 18:51:09 -0500
Subject: [PATCH 2/3] gnu: entr: Improve package style.

* gnu/packages/entr.scm (entr): Improve package style. The changes are the
result of running ./pre-inst-env guix style entr.

Change-Id: I9579e326f88c6066078f2df78a12431f3f4badd4
---
gnu/packages/entr.scm | 57 ++++++++++++++++++++++---------------------
1 file changed, 29 insertions(+), 28 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/entr.scm b/gnu/packages/entr.scm
index bb09acd6aa..f84a217814 100644
--- a/gnu/packages/entr.scm
+++ b/gnu/packages/entr.scm
@@ -37,37 +37,38 @@ (define-public entr
(package
(name "entr")
(version "5.6")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://eradman.com/entrproject/code/entr-"
- version ".tar.gz"))
- (sha256
- (base32
- "0kniklgnqv4j9carm78d3423wlwqw1ykxmlla4xmlfwdjbgvh8h2"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://eradman.com/entrproject/code/entr-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0kniklgnqv4j9carm78d3423wlwqw1ykxmlla4xmlfwdjbgvh8h2"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (setenv "CC" ,(cc-for-target))
- (setenv "PREFIX" out)
- (setenv "MANPREFIX" (string-append out "/man"))
- (invoke "./configure"))))
- (add-before 'build 'remove-fhs-file-names
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "entr.c"
- (("/bin/sh" command)
- (search-input-file inputs command))
- (("/bin/cat" command)
- (search-input-file inputs command))
- (("/usr(/bin/clear)" _ command)
- (search-input-file inputs command))))))))
- (inputs
- (list bash coreutils ncurses))
+ #:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "CONFIG_SHELL"
+ (which "bash"))
+ (setenv "CC"
+ ,(cc-for-target))
+ (setenv "PREFIX" out)
+ (setenv "MANPREFIX"
+ (string-append out "/man"))
+ (invoke "./configure"))))
+ (add-before 'build 'remove-fhs-file-names
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "entr.c"
+ (("/bin/sh" command)
+ (search-input-file inputs command))
+ (("/bin/cat" command)
+ (search-input-file inputs command))
+ (("/usr(/bin/clear)" _ command)
+ (search-input-file inputs command))))))))
+ (inputs (list bash coreutils ncurses))
(home-page "https://eradman.com/entrproject/")
(synopsis "Run arbitrary commands when files change")
(description
--
2.46.0
From e68de6b81ec5a4f8de7273da4d8fd770bbc553ce Mon Sep 17 00:00:00 2001
Message-ID: <e68de6b81ec5a4f8de7273da4d8fd770bbc553ce.1731110707.git.pirata@gmail.com>
In-Reply-To: <ae09a012f969a700292bdaf9556b515196a6ef38.1731110707.git.pirata@gmail.com>
References: <ae09a012f969a700292bdaf9556b515196a6ef38.1731110707.git.pirata@gmail.com>
From: Javier Olaechea <pirata@gmail.com>
Date: Fri, 8 Nov 2024 19:03:38 -0500
Subject: [PATCH 3/3] gnu: entr: Switch input from bash to bash-minimal.

* gnu/packages/entr.scm (entr): Switch input from bash to bash-minimal. This
was recommended by guix style lint.

Change-Id: Iccd37c3bf04b95ed510900f9d6ffd9359a227948
---
gnu/packages/entr.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/entr.scm b/gnu/packages/entr.scm
index f84a217814..d60489d14e 100644
--- a/gnu/packages/entr.scm
+++ b/gnu/packages/entr.scm
@@ -68,7 +68,7 @@ (define-public entr
(search-input-file inputs command))
(("/usr(/bin/clear)" _ command)
(search-input-file inputs command))))))))
- (inputs (list bash coreutils ncurses))
+ (inputs (list bash-minimal coreutils ncurses))
(home-page "https://eradman.com/entrproject/")
(synopsis "Run arbitrary commands when files change")
(description
--
2.46.0
From ae09a012f969a700292bdaf9556b515196a6ef38 Mon Sep 17 00:00:00 2001
Message-ID: <ae09a012f969a700292bdaf9556b515196a6ef38.1731110707.git.pirata@gmail.com>
From: Javier Olaechea <pirata@gmail.com>
Date: Fri, 8 Nov 2024 17:55:45 -0500
Subject: [PATCH 1/3] gnu: entr: Update to 5.6.

* gnu/packages/entr.scm (entr): Update to 5.6.

Change-Id: Idfa2fc88e526deccc7a9ff4d07ede6b0dc6daf72
---
gnu/packages/entr.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/entr.scm b/gnu/packages/entr.scm
index 5a8bbc8e4f..bb09acd6aa 100644
--- a/gnu/packages/entr.scm
+++ b/gnu/packages/entr.scm
@@ -36,14 +36,14 @@ (define-module (gnu packages entr)
(define-public entr
(package
(name "entr")
- (version "5.5")
+ (version "5.6")
(source (origin
(method url-fetch)
(uri (string-append "https://eradman.com/entrproject/code/entr-"
version ".tar.gz"))
(sha256
(base32
- "09p5aqbb95bysdx73n094v0b07hn3v9kqg6k7yyycnpaxzi0r30j"))))
+ "0kniklgnqv4j9carm78d3423wlwqw1ykxmlla4xmlfwdjbgvh8h2"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"

base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
--
2.46.0
E
E
Ekaitz Zarraga wrote on 9 Nov 16:21 +0100
QA review for 74271
1e4e0158-e12b-410f-9a1b-82b41fd3bd83@elenq.tech
user guix
usertag 74271 + reviewed-looks-good
thanks

Guix QA review form submission:
It's a package update and some stylistic change on top of it. The
package doesn't have any dependency.

Items marked as checked: Lint warnings, Package builds, Commit messages,
New package licenses, New package tests, New package synopsis and
descriptions
L
L
Ludovic Courtès wrote on 12 Nov 23:51 +0100
Re: [bug#74271] [PATCH] gnu: entr: Update to 5.6
(name . Javier Olaechea)(address . pirata@gmail.com)
877c98rrq1.fsf@gnu.org
Hi,

Javier Olaechea <pirata@gmail.com> skribis:

Toggle quote (7 lines)
> Adding two more patches on top
>
> The first one makes the package conform with guix style. The second one
> follows a recommendation made by guix lint, to swap bash for bash-minimal.
> I have verified that after doing the package not only builds but the entr
> executable behaves as expected

Applied, thanks to the two of you!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74271@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74271
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch