[PATCH] guix: packages: Fix building development profiles.

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • pjals
Owner
unassigned
Submitted by
pjals
Severity
normal
P
P
pjals wrote on 8 Nov 2024 15:44
(address . guix-patches@gnu.org)(name . Daniel [REDACTED])(address . pjals@privacyrequired.com)
20241108144504.5263-2-pjals@privacyrequired.com
From: "Daniel [REDACTED]" <pjals@privacyrequired.com>

* guix/packages.scm (bag-transitive-inputs): Set %current-target-system while
finding bag transitive inputs.

Change-Id: If33a0fc2bf038e09819c87f535c27dfe5e873973
---
guix/packages.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (34 lines)
diff --git a/guix/packages.scm b/guix/packages.scm
index f373136d22..40d5e7b1d5 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -1443,12 +1443,6 @@ (define (bag-direct-inputs bag)
(bag-host-inputs bag)
(bag-target-inputs bag)))
-(define (bag-transitive-inputs bag)
- "Same as 'package-transitive-inputs', but applied to a bag."
- (parameterize ((%current-target-system #f)
- (%current-system (bag-system bag)))
- (transitive-inputs (bag-direct-inputs bag))))
-
(define (bag-transitive-build-inputs bag)
"Same as 'package-transitive-native-inputs', but applied to a bag."
(parameterize ((%current-target-system #f)
@@ -1467,6 +1461,12 @@ (define (bag-transitive-target-inputs bag)
(%current-system (bag-system bag)))
(transitive-inputs (bag-target-inputs bag))))
+(define (bag-transitive-inputs bag)
+ "Same as 'package-transitive-inputs', but applied to a bag."
+ (append (bag-transitive-build-inputs bag)
+ (bag-transitive-host-inputs bag)
+ (bag-transitive-target-inputs bag)))
+
(define* (package-development-inputs package
#:optional (system (%current-system))
#:key target)

base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
--
2.46.0
L
L
Ludovic Courtès wrote on 12 Nov 2024 23:44
(address . pjals@privacyrequired.com)(address . 74265@debbugs.gnu.org)
87frnwrs0v.fsf@gnu.org
Hi,

pjals@privacyrequired.com skribis:

Toggle quote (7 lines)
> From: "Daniel [REDACTED]" <pjals@privacyrequired.com>
>
> * guix/packages.scm (bag-transitive-inputs): Set %current-target-system while
> finding bag transitive inputs.
>
> Change-Id: If33a0fc2bf038e09819c87f535c27dfe5e873973

Could you add a test that illustrates what this change fixes?

From a cursory look, it’s not clear to me what the motivation is.

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 29 Dec 2024 11:32
control message for bug #74265
(address . control@debbugs.gnu.org)
87v7v2rd9b.fsf@gnu.org
tags 74265 + moreinfo
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74265@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74265
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch