[PATCH] add python-pyet

  • Done
  • quality assurance status badge
Details
2 participants
  • Rick Huijzer
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Rick Huijzer
Severity
normal
R
R
Rick Huijzer wrote on 8 Nov 18:17 +0100
(address . guix-patches@gnu.org)(name . Rick Huijzer)(address . ikbenrickhuyzer@gmail.com)
20241108171808.584587-1-ikbenrickhuyzer@gmail.com
Change-Id: Ia2be23aeb83911aa93869f82cf0667da8af509c4
---
gnu/packages/python-science.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index f38992a1c2..f55ec8cac5 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Marco Baggio <marco.baggio@mdc-berlin.de>
;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3576,6 +3577,34 @@ (define-public python-pynsee
compagnies.")
(license license:expat)))
+(define-public python-pyet
+ (package
+ (name "python-pyet")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyet" version))
+ (sha256
+ (base32 "1dblsx0bv1g453hcx5vwij1zgankwgwvhwllqkn47k578h038xvy"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "nosetests")))))))
+
+ (propagated-inputs (list python-pandas python-xarray))
+ (native-inputs (list python-mock python-nose))
+ (home-page "https://github.com/pyet-org/pyet")
+ (synopsis "Python package for evapotranspiration calculation")
+ (description
+ "This package provides a Python library for calculating Evapotranspiration
+ using various standard methods.")
+ (license license:expat)))
+
(define-public python-libneuroml
(package
(name "python-libneuroml")

base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
--
2.47.0
S
S
Sharlatan Hellseher wrote on 19 Nov 00:36 +0100
(address . 74264-done@debbugs.gnu.org)
87cyisjerg.fsf@gmail.com
Hi,

Pushed as ea195b286e to master with adjustments.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmc7z4MACgkQdtcnv/Ys
0rVU0g/+KxVkZ8PEAKi6h6AYiZJ6hiLJsbZM+bvGrCW8qoSgljRPoLrHW0vdTLGW
2+zTXpmLvqNc0DQg0dQzos296uAfwKtxyAbTw4fuoL2nKOpgx73eDLSlEhb1aoTV
apTkK1UGKibSZdPwb36p58NTC1rIjD10z2f8QVmhA6Z8gQ/K4jdT4ugV8K6fPHet
mO/HY85C+03H3MspofJNLu1LXH45h67qvPh/N+H0IgPMBUmii7ij0OtUktaAL2+l
0hVUVvHnH2ZkEFT+4KDSW3tL4WwNpKFJhy2OtXi9lzI4NQZGc1t3asUNdWtzqMoW
CzM3DlXeZViWVb/g9OoctpmI/HM2EPowL/S6Mzuq8PXFKtR77WKu6Mp9vqp3J4MJ
BzRUphWi4Fbrnzepu/Az22xMMoNwbNGNS8og4reAUnstR7x1/ZtbxRQqQ4cVSpK8
0JEg8MpKJd7e58NsS3H7TvKE+Xxgw1DmuNPEBxm7yoAdfa0vlk6vV8odZ0ErfXjn
nEOf71oEFLt85UxqAI7mPNRvPF6AV1nm1oW4DlmheKZxv/ci1Z5ZtVTXZpfhrW55
0AVcwUMNCkVb5FIVbmE4olIoxBfK7XTnYxoBdka1flC6U2lltRym1WfhYEG8ox0B
su5p+kPdhthnLVsQL0HUdTq2+OIkyal0GbNkH6fif2ASG7/oPRg=
=uWrO
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74264@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74264
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch