[PATCH] gnu: Add python-bs4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 4 months ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
0c965caea30072d37c2f8aa6877746bf03fbd18f.1731081542.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-bs4): New variable.

Change-Id: I69d0a0b6f39977db3419c23b645983da8cb02e7d
---
gnu/packages/bioinformatics.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 45c460599f..10c975297b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4557,6 +4557,25 @@ (define-public bwa-meth
off-target reads for a capture method that targets CpG-rich region.")
(license license:expat)))
+(define-public python-bs4
+ (package
+ (name "python-bs4")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bs4" version))
+ (sha256
+ (base32 "099rcncbfhzykzizfmabsl0gbbbbzs1swys149vi5zjhiz2qb1m4"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ;There are no tests
+ (propagated-inputs (list python-beautifulsoup4
+ python-hatchling))
+ (home-page "https://pypi.org/project/bs4")
+ (synopsis "Dummy package for Python Beautifulsoup4")
+ (description "This is a dummy package for Python Beautifulsoup4.")
+ (license license:expat)))
+
(define-public python-bx-python
(package
(name "python-bx-python")

base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
prerequisite-patch-id: 8f31c5ea3685b59fb6907a9582c0ca537c9c38bd
prerequisite-patch-id: e9f28e6ac20c9572b3cc53ab09c4083161bfdf8d
prerequisite-patch-id: dc854398543782a2f94811e4991533c4beec4e10
prerequisite-patch-id: 5461c1696000d75efb93f8415f974dd402577e6d
--
2.43.0
Ricardo Wurmus wrote 4 months ago
(address . 74262-done@debbugs.gnu.org)
87bjyleva8.fsf@elephly.net
Thank you.

I'm closing this because it is merely another name for
python-beautifulsoup4, which should be used instead of bs4.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74262@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74262
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help