[PATCH] gnu: Add python-rangehttpserver.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal
N
N
Navid Afkhami wrote on 8 Nov 16:26 +0100
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
8c3b3661f86f649f960f5cd344eefabbfca767ed.1731079577.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-rangehttpserver): New variable.

Change-Id: Ib37b29bedb468faf4da5ab5080106c54e50f52c7
---
gnu/packages/bioinformatics.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3b393acce2..45c460599f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3381,6 +3381,28 @@ (define-public python-pairtools
")
(license license:expat)))
+(define-public python-rangehttpserver
+ (package
+ (name "python-rangehttpserver")
+ (version "1.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danvk/RangeHTTPServer")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dx533fsbq1mbz3by7qkm5bh2c253nwvm8214pqbwbfq07kqkwf2"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-coverage python-coveralls))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/danvk/RangeHTTPServer")
+ (synopsis "SimpleHTTPServer with support for range requests")
+ (description
+ "This tool provides a simple HTTP server with support for Range requests.")
+ (license license:asl2.0)))
+
(define-public python-readpaf
(package
(name "python-readpaf")

base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
prerequisite-patch-id: 8f31c5ea3685b59fb6907a9582c0ca537c9c38bd
prerequisite-patch-id: e9f28e6ac20c9572b3cc53ab09c4083161bfdf8d
prerequisite-patch-id: dc854398543782a2f94811e4991533c4beec4e10
--
2.43.0
R
R
Ricardo Wurmus wrote on 11 Nov 14:47 +0100
(address . 74260-done@debbugs.gnu.org)
87frnxevc0.fsf@elephly.net
Applied and moved to python-web.scm. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74260@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74260
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch