[PATCH] gnu: liblouisutdml: Update to 2.12.0-0.00ca783.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote on 7 Nov 12:07 +0100
(address . guix-patches@gnu.org)
1e3cb639f5828c8caa34497da0ce313337a4b994.1730977666.git.zhengjunjie@iscas.ac.cn
* gnu/packages/language.scm (liblouisutdml): Update to 2.12.0-0.00ca783.
[arguments]: Use G-expressions.
[native-inputs]: Remove labels.
[propagated-inputs]: Remove labels.

Change-Id: Iedbcb5b3073f26a42805ae02550a28f6f1abee86
---
gnu/packages/language.scm | 76 ++++++++++++++++++++-------------------
1 file changed, 40 insertions(+), 36 deletions(-)

Toggle diff (101 lines)
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 71e9ae2511..e00e30b7dc 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Charles <charles@charje.net>
;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -386,45 +387,48 @@ (define-public liblouis
license:gpl3+)))) ; tools
(define-public liblouisutdml
- (package
- (name "liblouisutdml")
- (version "2.9.0")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/liblouis/liblouisutdml")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0c32cfcfp0lyfd655c9ihhh3p7lhrb9q3xbll7q5dw4km86gaq6w"))))
- (build-system gnu-build-system)
- (outputs '("out" "bin" "doc"))
- (arguments
- `(#:configure-flags
- (list "--disable-static")))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("help2man" ,help2man)
- ("jdk" ,icedtea "jdk")
- ("libtool" ,libtool)
- ("makeinfo" ,texinfo)
- ("pkg-config" ,pkg-config)))
- (inputs
- (list libxml2))
- (propagated-inputs
- `(("liblouis" ,liblouis)
- ("liblouis:bin" ,liblouis "bin")))
- (synopsis "Braille transcription services")
- (description "Liblouisutdml is a library providing complete braille
+ ;; The new version fixes the test, but not release.
+ (let ((commit "00ca7838e30ebd5ed6f635236aa235e2c8f089c1")
+ (revision "0"))
+ (package
+ (name "liblouisutdml")
+ (version (git-version "2.12.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/liblouis/liblouisutdml")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pr3wys48bzblr6kav24gr8slsp409f81iqxw19922k24y5y31l7"))))
+ (build-system gnu-build-system)
+ (outputs '("out" "bin" "doc"))
+ (arguments
+ (list #:configure-flags
+ #~(list "--disable-static")))
+ (native-inputs
+ (list autoconf
+ automake
+ help2man
+ `(,icedtea "jdk")
+ libtool
+ texinfo
+ pkg-config))
+ (inputs
+ (list libxml2))
+ (propagated-inputs
+ (list liblouis
+ `(,liblouis "bin")))
+ (synopsis "Braille transcription services")
+ (description "Liblouisutdml is a library providing complete braille
transcription services for xml, html and text documents. It translates into
appropriate braille codes and formats according to its style sheet and the
specifications in the document.")
- (home-page "http://liblouis.org/")
- (license (list license:lgpl3+ ; library
- license:gpl3+)))) ; tools
+ (home-page "http://liblouis.org/")
+ (license (list license:lgpl3+ ; library
+ license:gpl3+))))) ; tools
(define-public libstemmer
(package

base-commit: fea85206275f28108cc9cfbce7b2e0d1147abd1e
--
2.46.0
M
M
Maxim Cournoyer wrote 6 days ago
(name . Zheng Junjie)(address . zhengjunjie@iscas.ac.cn)(address . 74238@debbugs.gnu.org)
87v7wu9nal.fsf@gmail.com
Hello!

Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

Toggle quote (61 lines)
> * gnu/packages/language.scm (liblouisutdml): Update to 2.12.0-0.00ca783.
> [arguments]: Use G-expressions.
> [native-inputs]: Remove labels.
> [propagated-inputs]: Remove labels.
>
> Change-Id: Iedbcb5b3073f26a42805ae02550a28f6f1abee86
> ---
> gnu/packages/language.scm | 76 ++++++++++++++++++++-------------------
> 1 file changed, 40 insertions(+), 36 deletions(-)
>
> diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
> index 71e9ae2511..e00e30b7dc 100644
> --- a/gnu/packages/language.scm
> +++ b/gnu/packages/language.scm
> @@ -11,6 +11,7 @@
> ;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2024 Charles <charles@charje.net>
> ;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
> +;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -386,45 +387,48 @@ (define-public liblouis
> license:gpl3+)))) ; tools
>
> (define-public liblouisutdml
> - (package
> - (name "liblouisutdml")
> - (version "2.9.0")
> - (source
> - (origin
> - (method git-fetch)
> - (uri
> - (git-reference
> - (url "https://github.com/liblouis/liblouisutdml")
> - (commit (string-append "v" version))))
> - (file-name (git-file-name name version))
> - (sha256
> - (base32 "0c32cfcfp0lyfd655c9ihhh3p7lhrb9q3xbll7q5dw4km86gaq6w"))))
> - (build-system gnu-build-system)
> - (outputs '("out" "bin" "doc"))
> - (arguments
> - `(#:configure-flags
> - (list "--disable-static")))
> - (native-inputs
> - `(("autoconf" ,autoconf)
> - ("automake" ,automake)
> - ("help2man" ,help2man)
> - ("jdk" ,icedtea "jdk")
> - ("libtool" ,libtool)
> - ("makeinfo" ,texinfo)
> - ("pkg-config" ,pkg-config)))
> - (inputs
> - (list libxml2))
> - (propagated-inputs
> - `(("liblouis" ,liblouis)
> - ("liblouis:bin" ,liblouis "bin")))
> - (synopsis "Braille transcription services")
> - (description "Liblouisutdml is a library providing complete braille
> + ;; The new version fixes the test, but not release.

I'd instead word the above like: "Use the latest commit, which includes
test suite fixes not yet released."

Toggle quote (45 lines)
> + (let ((commit "00ca7838e30ebd5ed6f635236aa235e2c8f089c1")
> + (revision "0"))
> + (package
> + (name "liblouisutdml")
> + (version (git-version "2.12.0" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/liblouis/liblouisutdml")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1pr3wys48bzblr6kav24gr8slsp409f81iqxw19922k24y5y31l7"))))
> + (build-system gnu-build-system)
> + (outputs '("out" "bin" "doc"))
> + (arguments
> + (list #:configure-flags
> + #~(list "--disable-static")))
> + (native-inputs
> + (list autoconf
> + automake
> + help2man
> + `(,icedtea "jdk")
> + libtool
> + texinfo
> + pkg-config))
> + (inputs
> + (list libxml2))
> + (propagated-inputs
> + (list liblouis
> + `(,liblouis "bin")))
> + (synopsis "Braille transcription services")
> + (description "Liblouisutdml is a library providing complete braille
> transcription services for xml, html and text documents. It translates into
> appropriate braille codes and formats according to its style sheet and the
> specifications in the document.")
> - (home-page "http://liblouis.org/")
> - (license (list license:lgpl3+ ; library
> - license:gpl3+)))) ; tools
> + (home-page "http://liblouis.org/")
> + (license (list license:lgpl3+ ; library
> + license:gpl3+))))) ; tools

Otherwise, LGTM, thanks for the fix.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
Z
Z
Z572 wrote 5 days ago
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 74238-done@debbugs.gnu.org)
878qtpqdzf.fsf@iscas.ac.cn
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (116 lines)
> Hello!
>
> Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:
>
>> * gnu/packages/language.scm (liblouisutdml): Update to 2.12.0-0.00ca783.
>> [arguments]: Use G-expressions.
>> [native-inputs]: Remove labels.
>> [propagated-inputs]: Remove labels.
>>
>> Change-Id: Iedbcb5b3073f26a42805ae02550a28f6f1abee86
>> ---
>> gnu/packages/language.scm | 76 ++++++++++++++++++++-------------------
>> 1 file changed, 40 insertions(+), 36 deletions(-)
>>
>> diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
>> index 71e9ae2511..e00e30b7dc 100644
>> --- a/gnu/packages/language.scm
>> +++ b/gnu/packages/language.scm
>> @@ -11,6 +11,7 @@
>> ;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
>> ;;; Copyright © 2024 Charles <charles@charje.net>
>> ;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
>> +;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
>> ;;;
>> ;;; This file is part of GNU Guix.
>> ;;;
>> @@ -386,45 +387,48 @@ (define-public liblouis
>> license:gpl3+)))) ; tools
>>
>> (define-public liblouisutdml
>> - (package
>> - (name "liblouisutdml")
>> - (version "2.9.0")
>> - (source
>> - (origin
>> - (method git-fetch)
>> - (uri
>> - (git-reference
>> - (url "https://github.com/liblouis/liblouisutdml")
>> - (commit (string-append "v" version))))
>> - (file-name (git-file-name name version))
>> - (sha256
>> - (base32 "0c32cfcfp0lyfd655c9ihhh3p7lhrb9q3xbll7q5dw4km86gaq6w"))))
>> - (build-system gnu-build-system)
>> - (outputs '("out" "bin" "doc"))
>> - (arguments
>> - `(#:configure-flags
>> - (list "--disable-static")))
>> - (native-inputs
>> - `(("autoconf" ,autoconf)
>> - ("automake" ,automake)
>> - ("help2man" ,help2man)
>> - ("jdk" ,icedtea "jdk")
>> - ("libtool" ,libtool)
>> - ("makeinfo" ,texinfo)
>> - ("pkg-config" ,pkg-config)))
>> - (inputs
>> - (list libxml2))
>> - (propagated-inputs
>> - `(("liblouis" ,liblouis)
>> - ("liblouis:bin" ,liblouis "bin")))
>> - (synopsis "Braille transcription services")
>> - (description "Liblouisutdml is a library providing complete braille
>> + ;; The new version fixes the test, but not release.
>
> I'd instead word the above like: "Use the latest commit, which includes
> test suite fixes not yet released."
>
>> + (let ((commit "00ca7838e30ebd5ed6f635236aa235e2c8f089c1")
>> + (revision "0"))
>> + (package
>> + (name "liblouisutdml")
>> + (version (git-version "2.12.0" revision commit))
>> + (source
>> + (origin
>> + (method git-fetch)
>> + (uri
>> + (git-reference
>> + (url "https://github.com/liblouis/liblouisutdml")
>> + (commit commit)))
>> + (file-name (git-file-name name version))
>> + (sha256
>> + (base32 "1pr3wys48bzblr6kav24gr8slsp409f81iqxw19922k24y5y31l7"))))
>> + (build-system gnu-build-system)
>> + (outputs '("out" "bin" "doc"))
>> + (arguments
>> + (list #:configure-flags
>> + #~(list "--disable-static")))
>> + (native-inputs
>> + (list autoconf
>> + automake
>> + help2man
>> + `(,icedtea "jdk")
>> + libtool
>> + texinfo
>> + pkg-config))
>> + (inputs
>> + (list libxml2))
>> + (propagated-inputs
>> + (list liblouis
>> + `(,liblouis "bin")))
>> + (synopsis "Braille transcription services")
>> + (description "Liblouisutdml is a library providing complete braille
>> transcription services for xml, html and text documents. It translates into
>> appropriate braille codes and formats according to its style sheet and the
>> specifications in the document.")
>> - (home-page "http://liblouis.org/")
>> - (license (list license:lgpl3+ ; library
>> - license:gpl3+)))) ; tools
>> + (home-page "http://liblouis.org/")
>> + (license (list license:lgpl3+ ; library
>> + license:gpl3+))))) ; tools
>
> Otherwise, LGTM, thanks for the fix.
>
> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
thanks!

push, close.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmcy17QACgkQO1qpk+Gi
3/ByRRAAjx1RoKafMbSjDYXfDtZ/RroRfLI8NHxyc11g2Kbmcy4CdJo1nQR+D7cj
Qp0qtXf0IU/0iQYyYlv30xUM5Gz+6LtkMqkqyvxsu0KTdTiEzzPSsqdBabfemtOA
RLT2bftvRsNUucX3RTCqx+R5UhizMqRBIId9Brbk2Nxdn6rVgH82KDsK59N5uetO
cWcwjG+wEq9MKmGLN4hENtoDOCG6Rsxb+U5ORrEHr1bQMX1xXMhT81laxKhFKhyc
sKhE2m0cLJGQvB++PzejcbBHKeujmAEfUk+9WZlsPqkG7VWoDJSCV7brg93h77U1
yiErABD8+Xy3nXq2byGQuFg46OR4NKfd6rXx9R1oCCC6fpibcQy8+fBwk4VtN9zZ
0nyja4HXyYmiGFcQWwE0Fmev40BQpDzuv7b8UmIthqlIHTLx4gYzo9ubX+G10A2L
L6x8+cH2VH/Nk8p7ffdLtQqw34iljUkE/WbPqe/2zLWrpSzMriHKlF4Q+EdJLZGF
UbkkS5qffFgJaJLQ6bjp4gUhV4eytAhB8r79ItLITF+jDUN8WKxaGqObf3e99x9U
UFn4emR3039/5QY6iirXi7bMQYjuF3Kpvf07PYHJWVDE4kTuI/ngTX5b8JwJDapl
pgam1Sw97OEWivB/vxiYrZspLHf74Rk7AnPDN6MvFzHiCo1gkGI=
=wryI
-----END PGP SIGNATURE-----

Closed
M
M
Maxim Cournoyer wrote 4 days ago
(name . Z572)(address . zhengjunjie@iscas.ac.cn)(address . 74238-done@debbugs.gnu.org)
87msi43aio.fsf@gmail.com
Hi Zheng!

Z572 <zhengjunjie@iscas.ac.cn> writes:

[...]

Toggle quote (4 lines)
> thanks!
>
> push, close.

Excellent. English nitpick, if I may, for your 'merge' replies:

'Pushed, closing.'

Take it with a grain of salt as I'm no English native either :-).

Cheers!

--
Maxim
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74238@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74238
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch