emacs-guix: guix-command-popup not displaying argument improvers

  • Open
  • quality assurance status badge
Details
2 participants
  • Christopher Howard
  • Simon Tournier
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal
C
C
Christopher Howard wrote on 7 Nov 00:51 +0100
(address . bug-guix@gnu.org)
87pln7ncoa.fsf@librehacker.com
Note that to even display the guix-command-popup, you have to either set guix-repl-use-server to nil, or apply the patch from bug#73462.

The magit popup code for the guix-command-popup (M-x guix c) appears to be broken so that it skips the popup menu where you would construct your command line argument. Instead, it assumes an empty argument, and jumps to the popup where you select whether you want to run the command in the REPL or from a shell.

This code is in guix-command.el, and uses the old magit-popup interface (now superceded by transient). Presumably either something has changed in magit-popup since the code was written (2015-2020) or some Emacs change has broken guix-command.el. I hope to investigate this further. My hope is that some minor fix can be made to guix-command.el rather than having to rewrite everything for transient.

One part I am fuzzy on is how to debug it as it is apparently not possible to run edebug-instrument-function on guix-command-popup, as guix-command-popup is a function generated by other code. If anybody has any advice concerning this, that would be helpful.

Testing this on GNU Emacs 30.0.92 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.41, cairo version 1.18.0) of 2024-10-29.

--
? Christopher Howard
? gemini://gem.librehacker.com

?????? ??? ????? ?? ????? ??? ????
C
C
Christopher Howard wrote on 7 Nov 22:25 +0100
[bug#74236][PATCH] Tweaks command parsing regex to address debbugs bug#74236
(address . 74236@debbugs.gnu.org)
87o72q7n41.fsf@librehacker.com
From faa152608c418086af8e79d4bb578de4243d8fd2 Mon Sep 17 00:00:00 2001
From: Christopher Howard <christopher@librehacker.com>
Date: Thu, 7 Nov 2024 12:14:43 -0900
Subject: [PATCH] Tweaks command parsing regex to address debbugs bug#74236

---
elisp/guix-help-vars.el | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/elisp/guix-help-vars.el b/elisp/guix-help-vars.el
index 0dc0bc6..b30938a 100644
--- a/elisp/guix-help-vars.el
+++ b/elisp/guix-help-vars.el
@@ -1,6 +1,7 @@
;;; guix-help-vars.el --- Variables related to Guix --help output
;; Copyright © 2015, 2017, 2018 Alex Kost <alezost@gmail.com>
+;; Copyright © 2024 Christopher Howard <christopher@librehacker.com>
;; This file is part of Emacs-Guix.
@@ -42,7 +43,7 @@
"Common regexp used to find command options.")
(defvar guix-help-parse-command-regexp
- (rx bol " "
+ (rx bol " "
(group wordchar (one-or-more (or wordchar "-"))))
"Regexp used to find guix commands.
'Command' means any option not prefixed with '-'. For example,
--
2.46.0
See also bug#73462 for a patch which ideally would be applied first, but is not strictly speaking a prerequisite.

--
Christopher Howard
S
S
Simon Tournier wrote on 10 Dec 17:33 +0100
control message for bug #74236
(address . control@debbugs.gnu.org)
87h67bxzu1.fsf@gmail.com
tags 74236 + patch
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74236@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74236
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch