[PATCH] gnu: emacs-git-email: Update to 0.5.0.

  • Open
  • quality assurance status badge
Details
One participant
  • Suhail Singh
Owner
unassigned
Submitted by
Suhail Singh
Severity
normal
S
S
Suhail Singh wrote 7 hours ago
(address . guix-patches@gnu.org)
578f2ae3ba7cc4838ffdbc0929e6d3a5c8a6a9cc.1730918803.git.suhail@bayesians.ca
* gnu/packages/emacs-xyz.scm (emacs-git-email): Update to 0.5.0 on actively
maintained fork. Update homepage. Add emacs-piem as a build-time dependency.
Don't propagate mu, emacs-magit, and emacs-notmuch since they are optional.
* gnu/local.mk (dist_patch_DATA): Delete emacs-git-email-missing-parens.patch,
since it's no longer needed.
* gnu/packages/patches/emacs-git-email-missing-parens.patch: Delete
unnecessary patch.

Change-Id: I47f5aa12cfa676772e281a45cdc9ec3bb3eae544
---
gnu/local.mk | 1 -
gnu/packages/emacs-xyz.scm | 63 ++++++++-----------
.../emacs-git-email-missing-parens.patch | 27 --------
3 files changed, 25 insertions(+), 66 deletions(-)
delete mode 100644 gnu/packages/patches/emacs-git-email-missing-parens.patch

Toggle diff (121 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 945d89d550..90ef82204d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1186,7 +1186,6 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-disable-jit-compilation.patch \
%D%/packages/patches/emacs-exec-path.patch \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
- %D%/packages/patches/emacs-git-email-missing-parens.patch \
%D%/packages/patches/emacs-helpful-fix-tests.patch \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 59c804066a..57ae548a3b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22159,44 +22159,31 @@ (define-public emacs-gitpatch
(license license:gpl3+)))
(define-public emacs-git-email
- ;; Use latest commit since latest tagged release is missing important
- ;; changes.
- (let ((commit "b5ebade3a48dc0ce0c85699f25800808233c73be")
- (revision "0"))
- (package
- (name "emacs-git-email")
- (version (git-version "0.2.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~yoctocell/git-email")
- (commit commit)))
- (patches
- (search-patches "emacs-git-email-missing-parens.patch"))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1lk1yds7idgawnair8l3s72rgjmh80qmy4kl5wrnqvpmjrmdgvnx"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; piem is not yet packaged in Guix.
- (add-after 'unpack 'remove-piem
- (lambda _
- (delete-file "git-email-piem.el")))
- (add-before 'install 'makeinfo
- (lambda _
- (invoke "makeinfo" "doc/git-email.texi"))))))
- (native-inputs
- (list texinfo))
- (propagated-inputs
- (list mu emacs-magit emacs-notmuch))
- (license license:gpl3+)
- (home-page "https://sr.ht/~yoctocell/git-email")
- (synopsis "Format and send Git patches in Emacs")
- (description "This package provides utilities for formatting and
-sending Git patches via Email, without leaving Emacs."))))
+ (package
+ (name "emacs-git-email")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/suhail/git-email")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q70k0pn0dkbrcsah0hcwxa2c3f8aw89bbds5k2dslacn93ghws7"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'install 'makeinfo
+ (lambda _
+ (invoke "makeinfo" "doc/git-email.texi"))))))
+ (inputs (list mu emacs-magit emacs-notmuch emacs-piem))
+ (native-inputs (list texinfo))
+ (license license:gpl3+)
+ (home-page "https://suhail.codeberg.page/git-email")
+ (synopsis "Format and send Git patches in Emacs")
+ (description "This package provides utilities for formatting and
+sending Git patches via Email, without leaving Emacs.")))
(define-public emacs-erc-hl-nicks
(package
diff --git a/gnu/packages/patches/emacs-git-email-missing-parens.patch b/gnu/packages/patches/emacs-git-email-missing-parens.patch
deleted file mode 100644
index 051e2bf1eb..0000000000
--- a/gnu/packages/patches/emacs-git-email-missing-parens.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 820ad7eb2e919e3f880bec22bd4f737fa55c4d22 Mon Sep 17 00:00:00 2001
-From: Niklas Eklund <niklas.eklund@posteo.net>
-Date: Thu, 5 May 2022 12:43:49 +0200
-Subject: [PATCH] Fix missing parens in git-email-mu4e.el
-
-The incorrect number of parens in this file lead to Emacs failing to
-parse the file.
----
- git-email-mu4e.el | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/git-email-mu4e.el b/git-email-mu4e.el
-index d5b8770..9220bf9 100644
---- a/git-email-mu4e.el
-+++ b/git-email-mu4e.el
-@@ -51,7 +51,7 @@ from Lisp, enable the mode if ARG is omitted or nil."
- ;; built in context feature.
- (seq-filter (lambda (header)
- (not (eq (car header) 'from)))
-- headers)
-+ headers))))
- (setq git-email-compose-email-function 'message-mail)))
-
- (provide 'git-email-mu4e)
---
-2.34.0
-

base-commit: ba9466481d10992d35f09d010166d616fdb6a637
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74231@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74231
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch