(address . guix-patches@gnu.org)(name . Dariqq)(address . dariqq@posteo.net)
* guix/lint.scm (check-optional-tests): Also check for add-before and
add-after when adding custom 'check phases.
Change-Id: Idc959f90d7e9aa9d5001f34e00f88b41aa20fb2a
---
Hi,
Stumbled upon a test failure in u-boot-utils today which is not using #:tests? for its custom 'check phase but not being detected by the linter. Reason is that the 'check phase is added after 'install and not just replacing it.
This little patch makes it it possible to detect it and adds 38 more warnings.
guix/lint.scm | 4 ++++
1 file changed, 4 insertions(+)
Toggle diff (19 lines)
diff --git a/guix/lint.scm b/guix/lint.scm
index 8c6c20c723..4ba728da33 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -1433,6 +1433,10 @@ (define (check-optional-tests package)
(match delta
(`(replace 'check ,expression)
(check-check-procedure expression))
+ (`(add-after ,_ 'check ,expression)
+ (check-check-procedure expression))
+ (`(add-before ,_ 'check ,expression)
+ (check-check-procedure expression))
(_ '())))
(define (check-phases-deltas deltas)
(append-map check-phases-delta deltas))
base-commit: 0c1a6db8094dc6b20762eceae369daae545fc5e4
--
2.46.0