[PATCH] gnu: Add ruby-hanna.

  • Open
  • quality assurance status badge
Details
2 participants
  • gemmaro
  • Nicolas Graves
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote 2 days ago
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
5bcd565cfd2075a422fd631e942c48ed9ec61d99.1730597698.git.gemmaro.dev@gmail.com
* gnu/packages/ruby.scm (ruby-hanna): New variable.

Change-Id: I4a496a583357f820b39e9081ed4c4b73e134ffe5
---
gnu/packages/ruby.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5af1bb1cef..f715087d58 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -13552,6 +13552,30 @@ (define-public ruby-rdoc
documentation from the command-line.")
(license license:gpl2+)))
+(define-public ruby-hanna
+ (package
+ (name "ruby-hanna")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeremyevans/hanna")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wnk13ahvrqc0viw5sx4fka6apksh7b87wlmv6ja4wj4j3dyjrhf"))))
+ (build-system ruby-build-system)
+ (native-inputs (list ruby-minitest-hooks ruby-minitest-global-expectations))
+ (propagated-inputs (list ruby-rdoc))
+ (synopsis "Simple, beautiful, and easy to browse RDoc generator")
+ (description
+ "Hanna is a RDoc generator designed with simplicity, beauty and ease of
+browsing in mind. This generator can also be configured to integrate
+with RubyGems and Rake tasks.")
+ (home-page "https://github.com/jeremyevans/hanna")
+ (license license:expat)))
+
(define-public ruby-sass-listen
(package
(name "ruby-sass-listen")

base-commit: 639f79952e51a58b7fbca2a826dcc3df162300c1
--
2.46.0
N
N
Nicolas Graves wrote 37 hours ago
tag 74181 easy
(address . control@debbugs.gnu.org)
87ikt4ozy8.fsf@ngraves.fr
tags 74181 + easy
quit

--
Best regards,
Nicolas Graves
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74181@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74181
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch