(address . guix-patches@gnu.org)
Hi,
attached is patch to add the cargo.el package. It is a minor mode to
interact with rust's cargo package manager from Emacs.
Cheers
--
"I object to doing things that computers can do." — Olin Shivers
From 1a3df5f98b1f785379c5b38661dc815bea9266c1 Mon Sep 17 00:00:00 2001
Message-ID: <1a3df5f98b1f785379c5b38661dc815bea9266c1.1730526066.git.pirata@gmail.com>
From: Javier Olaechea <pirata@gmail.com>
Date: Sat, 2 Nov 2024 00:36:57 -0500
Subject: [PATCH] gnu: Add emacs-cargo-el
* gnu/packages/emacs-xyz.scm (emacs-cargo-el): New variable.
Change-Id: I73a99eeb818fb1c7ab87cc15c5953beba818cb94
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 488b4cb5d7..5b9c7437f2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29667,6 +29667,29 @@ (define-public emacs-rustic
(license (list license:expat
license:asl2.0))))
+(define-public emacs-cargo-el
+ (let ((commit "7f8466063381eed05d4e222ce822b1dd44e3bf17")
+ (revision "1"))
+ (package
+ (name "emacs-cargo-el")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kwrooijen/cargo.el")
+ (commit commit)))
+ (sha256
+ (base32 "1hvxdmyppvx04jyn07dnynlgbwyasv22k8dd4qa68mrj8i9mz484"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-markdown-mode))
+ (home-page "https://github.com/kwrooijen/cargo.el")
+ (synopsis "Emacs Minor Mode for Cargo, Rust's Package Manager")
+ (description
+ "Cargo mode for Emacs. This package gives you a set of key combinations to
+perform Cargo tasks within your Rust projects.")
+ (license license:gpl3+))))
+
(define-public emacs-ztree
;; Upstream provides no tag, but the commit below matches latest release.
(let ((commit "c9ad9136d52ca5a81475693864e255d29448f43f"))
base-commit: ea11d3608566174c4bae70faa4f9d0c67748d2db
--
2.46.0