(address . guix-patches@gnu.org)
Hi,
Attached is a patch to add the eslint-flymake package. It is a flymake
backend for ESLint.
Cheers
--
"I object to doing things that computers can do." — Olin Shivers
From 4217d5cf15193d90584dc63a9fe859df56ff8b5f Mon Sep 17 00:00:00 2001
Message-ID: <4217d5cf15193d90584dc63a9fe859df56ff8b5f.1730525463.git.pirata@gmail.com>
From: Javier Olaechea <pirata@gmail.com>
Date: Sat, 2 Nov 2024 00:26:22 -0500
Subject: [PATCH] gnu: Add emacs-eslint-flymake.
* gnu/packages/emacs-xyz.scm (emacs-eslint-flymake): New variable.
Change-Id: I0c5bb1279473d25ce16f7cf125620e819539bbfd
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 488b4cb5d7..a994e4ab33 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1484,6 +1484,28 @@ (define-public emacs-flymake
called backends, and visually annotates the relevant portions in the buffer.")
(license license:gpl3+)))
+(define-public emacs-eslint-flymake
+ (let ((commit "c78246330ee3ac1e0e07a709473d98a113d268e5")
+ (revision "1"))
+ (package
+ (name "emacs-eslint-flymake")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-pe/eslint-flymake")
+ (commit commit)))
+ (sha256
+ (base32 "19h95k57hrsysmvqzillzfn6wcinvcidv14fvbaqxgigwfwj0jnw"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-flymake))
+ (home-page "https://github.com/emacs-pe/eslint-flymake")
+ (synopsis "An ESLint backend for Flymake")
+ (description
+ "This package lets flymake run ESLint on the current buffer.")
+ (license license:gpl3+))))
+
;; Package has no release. Version is extracted from "Version:" keyword in
;; main file.
(define-public emacs-project-mode-line-tag
base-commit: bb5ccbfc70e833dadb0e6445422c6254a9de3002
--
2.46.0