[PATCH] daemon: Fix --with-libgcrypt-* args of the configure script

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Do?an Çeçen
Owner
unassigned
Submitted by
Do?an Çeçen
Severity
normal
D
D
Do?an Çeçen wrote on 30 Oct 21:41 +0100
(address . guix-patches@gnu.org)(name . Do?an Çeçen)(address . sepeth@fastmail.com)
79c05ec09291c176760e480e0f3e2f496d098777.1730320866.git.sepeth@fastmail.com
This change fixes the LDFLAGS pointing to a previously nonexistent
var (LIBGCRYPT_LDFLAGS). The name for this var was LIBGCRYPT_LIBS.

Also, CFLAGS was not the correct destination since the checks were done
with g++ and the env var for it is CXXFLAGS.

Another issue was with the save_CFLAGS and save_LDFLAGS trick. While
this is thoughtful, LDFLAGS and CXXFLAGS still need to be modified for
`make` to find the correct lib.

* config-daemon.ac: Fix LDFLAGS and CXXFLAGS for --with-libgcrypt-*
args of the configure script.

Change-Id: I0f3867491e46608e71b1ea0b3214674bca64b31d
---
config-daemon.ac | 19 +++++++------------
1 file changed, 7 insertions(+), 12 deletions(-)

Toggle diff (54 lines)
diff --git a/config-daemon.ac b/config-daemon.ac
index 9854f1d694..1ac204ceed 100644
--- a/config-daemon.ac
+++ b/config-daemon.ac
@@ -39,28 +39,26 @@ if test "x$guix_build_daemon" = "xyes"; then
case "$LIBGCRYPT_PREFIX" in
no)
- LIBGCRYPT_CFLAGS=""
+ LIBGCRYPT_CXXFLAGS=""
;;
*)
- LIBGCRYPT_CFLAGS="-I$LIBGCRYPT_PREFIX/include"
+ LIBGCRYPT_CXXFLAGS="-I$LIBGCRYPT_PREFIX/include"
;;
esac
case "$LIBGCRYPT_LIBDIR" in
no | "")
- LIBGCRYPT_LIBS="-lgcrypt"
+ LIBGCRYPT_LDFLAGS="-lgcrypt"
;;
*)
- LIBGCRYPT_LIBS="-L$LIBGCRYPT_LIBDIR -lgcrypt"
+ LIBGCRYPT_LDFLAGS="-L$LIBGCRYPT_LIBDIR -lgcrypt"
;;
esac
- AC_SUBST([LIBGCRYPT_CFLAGS])
- AC_SUBST([LIBGCRYPT_LIBS])
+ AC_SUBST([LIBGCRYPT_CXXFLAGS])
+ AC_SUBST([LIBGCRYPT_LDFLAGS])
- save_CFLAGS="$CFLAGS"
- save_LDFLAGS="$LDFLAGS"
- CFLAGS="$CFLAGS $LIBGCRYPT_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $LIBGCRYPT_CXXFLAGS"
LDFLAGS="$LDFLAGS $LIBGCRYPT_LDFLAGS"
have_gcrypt=yes
@@ -70,9 +68,6 @@ if test "x$guix_build_daemon" = "xyes"; then
AC_MSG_ERROR([GNU libgcrypt not found; please install it.])
fi
- CFLAGS="$save_CFLAGS"
- LDFLAGS="$save_LDFLAGS"
-
dnl Chroot support.
AC_CHECK_FUNCS([chroot unshare])
AC_CHECK_HEADERS([sched.h sys/param.h sys/mount.h sys/syscall.h])

base-commit: 6e50b0c56a8cc767bd3acb26638f78c450bde718
--
2.46.0
A
A
Andreas Enge wrote on 22 Nov 20:16 +0100
Close
(address . 74141-done@debbugs.gnu.org)
Z0DYq79HKnauNVmb@jurong
Applied, thanks a lot for the patch!

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74141@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74141
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch