(address . guix-patches@gnu.org)(name . Rostislav Svoboda)(address . Rostislav.Svoboda@gmail.com)
* gnu/packages/emacs-xyz.scm (emacs-vi-tilde-fringe): New variable.
Change-Id: Ia7306c69c1c9a8b967ce11f5e8ba70c5fe40ff1d
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 488b4cb5d7..b03fd56585 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7072,6 +7072,28 @@ (define-public emacs-fringe-helper
representation.")
(license license:gpl2+))))
+(define-public emacs-vi-tilde-fringe
+ (let ((commit "f1597a8d54535bb1d84b442577b2024e6f910308")
+ (revision "0"))
+ (package
+ (name "emacs-vi-tilde-fringe")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/syl20bnr/vi-tilde-fringe")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wdm8k49zl6i6wnh7vjkswdh5m9lix56jv37xvc90inipwgs402z"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/syl20bnr/vi-tilde-fringe")
+ (synopsis "Display tildes on empty lines in the Emacs fringe a la Vi")
+ (description
+ "Display tildes on empty lines in the Emacs fringe a la Vi.")
+ (license license:gpl3+))))
+
(define-public emacs-git-gutter
(package
(name "emacs-git-gutter")
base-commit: 6e50b0c56a8cc767bd3acb26638f78c450bde718
--
2.46.0