(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
* gnu/packages/ruby.scm (ruby-rfc): New variable.
Change-Id: Ib5b2e1cc3673212142e7e3e387f065ea728e9036
---
gnu/packages/ruby.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Toggle diff (41 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5af1bb1cef..8a26282d84 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3808,6 +3808,32 @@ (define-public ruby-fuubar
(home-page "https://github.com/thekompanee/fuubar")
(license license:expat)))
+(define-public ruby-rfc
+ (package
+ (name "ruby-rfc")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/p-mongodb/rfc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b9y63wmvypwrv5sdfwnxrzwzf59dwdb0lv9pzdj9gl0k4j21i7g"))))
+ (build-system ruby-build-system)
+ (arguments (list #:tests? #f)) ;no tests
+ (propagated-inputs (list ruby-rspec-core))
+ (synopsis
+ "RSpec formatter collection")
+ (description
+ "@samp{rfc} gem stands for RSpec Formatter Collection. This includes a
+concise insta-failing formatter, which was originally developed for
+running large test suites in a continuous integration environment.")
+ (home-page "https://github.com/p-mongo/rfc")
+ (license license:expat)))
+
(define-public ruby-haml
(package
(name "ruby-haml")
base-commit: 6e50b0c56a8cc767bd3acb26638f78c450bde718
--
2.46.0