[PATCH] gnu: Add r-raceid.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal
N
N
Navid Afkhami wrote on 30 Oct 2024 20:08
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
ad9beaa27782d99569b568cf4001f2d111955c37.1730315311.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-raceid): New variable.

Change-Id: I337463c66040179f5a4a1622fb759a87ebd2344a
---
gnu/packages/cran.scm | 47 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6c0861509d..1c2efc6b4c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13107,6 +13107,53 @@ (define-public r-shinyace
environment within Shiny.")
(license license:expat)))
+(define-public r-raceid
+ (package
+ (name "r-raceid")
+ (version "0.3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RaceID" version))
+ (sha256
+ (base32 "0zqas0dfsvcbjzv2b83zy13pxyzfhh81xrfbzxq8a7ykk0nyrx26"))))
+ (properties `((upstream-name . "RaceID")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-cluster
+ r-coop
+ r-fateid
+ r-fnn
+ r-fpc
+ r-ggplot2
+ r-harmony
+ r-ica
+ r-igraph
+ r-irlba
+ r-leiden
+ r-locfit
+ r-mass
+ r-matrix
+ r-matrixstats
+ r-pheatmap
+ r-princurve
+ r-quadprog
+ r-randomforest
+ r-rcolorbrewer
+ r-rcpp
+ r-rtsne
+ r-runner
+ r-umap
+ r-vegan))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=RaceID")
+ (synopsis
+ "Algorithm for inferring cell types from single-cell RNA-seq data")
+ (description
+ "This tool provides an algorithm to identify rare cell types in single-cell data.
+It also identifies abundant cell types. The method is based on transcript
+counts obtained with unique molecular identifies.")
+ (license license:gpl3)))
+
(define-public r-rafalib
(package
(name "r-rafalib")

base-commit: d6f775c30c6f47e174f6110d1089edc6315600e4
prerequisite-patch-id: 54292fa0b75533f02730e2da44993ad685d4a432
prerequisite-patch-id: 360575ef7e49c4e4e6b52644964df061856aee57
prerequisite-patch-id: 3904682af2961b8cb06ced06ab62c60604114dad
prerequisite-patch-id: 0e861c88ccc360c3a1bcd0ce92d90a9aeb1455c0
--
2.43.0
R
R
Ricardo Wurmus wrote on 1 Nov 2024 12:28
(address . 74118-done@debbugs.gnu.org)
87bjyzjiqf.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74118@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74118
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch