[PATCH] gnu: Add r-coop.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 4 months ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
58075da869ada7621043c39799da6b795ac1dc1c.1730314915.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-coop): New variable.

Change-Id: Idb79f51b518a16bf6410cc4239a69ee654c6c95d
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index aa57134166..6c0861509d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -40805,6 +40805,29 @@ (define-public r-contfrac
"Various utilities for evaluating continued fractions.")
(license license:gpl2)))
+(define-public r-coop
+ (package
+ (name "r-coop")
+ (version "0.6-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "coop" version))
+ (sha256
+ (base32 "0ww99ssgawsgn6rqy838wbx6iirzdrzyxirvz084ih8j50blx420"))))
+ (properties `((upstream-name . "coop")))
+ (build-system r-build-system)
+ (home-page "https://github.com/wrathematics/coop")
+ (synopsis
+ "Co-Operation: fast covariance, correlation, and cosine similarity computations")
+ (description
+ "R-coop offers implementations of covariance, correlation and cosine similarity.
+The implementations are fast and memory-efficient and their use is resolved
+automatically based on the input data, handled by R's S3 methods. Full
+descriptions of the algorithms and benchmarks are available in the package
+vignettes.")
+ (license license:bsd-2)))
+
(define-public r-elliptic
(package
(name "r-elliptic")

base-commit: d6f775c30c6f47e174f6110d1089edc6315600e4
prerequisite-patch-id: 54292fa0b75533f02730e2da44993ad685d4a432
prerequisite-patch-id: 360575ef7e49c4e4e6b52644964df061856aee57
prerequisite-patch-id: 3904682af2961b8cb06ced06ab62c60604114dad
--
2.43.0
Ricardo Wurmus wrote 4 months ago
(address . 74117-done@debbugs.gnu.org)
87frobjire.fsf@elephly.net
Thanks for the patch! Applied.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74117@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74117
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help