[PATCH] gnu: Add r-fateid.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 4 months ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
f24860f4f4504812ecf5d44c3ac945a22d06b136.1730313253.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-fateid): New variable.

Change-Id: If8d8dc20a0d377173a7428ebbfa238695a5d8002
---
gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 212f305ba1..aa57134166 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1038,6 +1038,35 @@ (define-public r-emdist
Distance (EMD).")
(license license:expat)))
+(define-public r-fateid
+ (package
+ (name "r-fateid")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "FateID" version))
+ (sha256
+ (base32 "0sgvaqhqkmmkcsl53bm1jlfpzrvzfb5cz8k513nizfsi638vydlm"))))
+ (properties `((upstream-name . "FateID")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-locfit
+ r-matrixstats
+ r-pheatmap
+ r-princurve
+ r-randomforest
+ r-rcolorbrewer
+ r-rtsne
+ r-som
+ r-umap))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=FateID")
+ (synopsis "Quantification of fate bias in multipotent progenitors")
+ (description
+ "This package computes cell fate bias for multi-lineage single-cell data.
+It also provides visualization tools for analyzing these biases.")
+ (license license:gpl3)))
+
(define-public r-fuzzyjoin
(package
(name "r-fuzzyjoin")

base-commit: d6f775c30c6f47e174f6110d1089edc6315600e4
prerequisite-patch-id: 54292fa0b75533f02730e2da44993ad685d4a432
prerequisite-patch-id: 360575ef7e49c4e4e6b52644964df061856aee57
--
2.43.0
Ricardo Wurmus wrote 4 months ago
(address . 74115-done@debbugs.gnu.org)
87jzdnjisd.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74115@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74115
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help