[PATCH] gnu: Add emacs-jack.

  • Open
  • quality assurance status badge
Details
One participant
  • Suhail Singh
Owner
unassigned
Submitted by
Suhail Singh
Severity
normal
S
S
Suhail Singh wrote 19 hours ago
(name . Guix-patches mailing list)(address . guix-patches@gnu.org)
40f7c1735edc6142c49a2308da59da00c92fdc67.1730234245.git.suhail@bayesians.ca
* gnu/packages/emacs-xyz.scm (emacs-jack): New variable.

Change-Id: I92790c493016a312501e926bbfc4b274d954e26f
---
gnu/packages/emacs-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 488b4cb5d7..885dab4683 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11336,6 +11336,39 @@ (define-public emacs-anaconda-mode
documentation, enhancing the Python development experience within Emacs.")
(license license:gpl3+))))
+(define-public emacs-jack
+ (let ((commit "3b4ea97fcc107d0ffd201ea695129af52f390113")
+ (revision "0"))
+ (package
+ (name "emacs-jack")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tonyaldon/jack")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cizszj62ic41zc97glf2mdvm1kd95vdfg2dip3n2p2g0nlk2hjf"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command #~(list "emacs"
+ "--batch"
+ "-l"
+ "jack-tests.el"
+ "-f"
+ "ert-run-tests-batch-and-exit")))
+ (home-page "https://jack.tonyaldon.com")
+ (synopsis "HTML generator library")
+ (description
+ "@code{jack} provides the function @code{jack-html} that takes a data
+structure as input representing the HTML tree you want to generate and
+generates it as a string. Please see the homepage for usage examples.")
+ (license license:gpl3+))))
+
(define-public emacs-jedi
(package
(name "emacs-jedi")

base-commit: a9c33e9f688fce88aed610ab04c650efb71b4ce6
--
2.47.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74101@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74101
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch