[PATCH] gnu: ruby-ethon: Fix libcurl detection at runtime.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Graves
  • Z572
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 29 Oct 10:00 +0100
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241029090005.15609-1-ngraves@ngraves.fr
* gnu/packages/ruby.scm (ruby-ethon)[arguments]<#:phases>: Add phase
'libcurl-use-absolute-reference.
---
gnu/packages/ruby.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5af1bb1cef..12c439b3a9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3089,7 +3089,15 @@ (define-public ruby-ethon
"0gggrgkcq839mamx7a8jbnp2h7x2ykfn34ixwskwb0lzx2ak17g9"))))
(build-system ruby-build-system)
(arguments
- `(#:tests? #f)) ; no included tests
+ (list
+ #:tests? #f ; no included tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'libcurl-use-absolute-reference
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "lib/ethon/curls/settings.rb"
+ (("libcurl', 'libcurl\\.so\\.4")
+ (search-input-file inputs "/lib/libcurl.so"))))))))
(inputs
(list curl))
(propagated-inputs
--
2.46.0
Z
(name . Nicolas Graves via Guix-patches via)(address . guix-patches@gnu.org)
878qu0jzef.fsf@iscas.ac.cn
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (28 lines)
> * gnu/packages/ruby.scm (ruby-ethon)[arguments]<#:phases>: Add phase
> 'libcurl-use-absolute-reference.
> ---
> gnu/packages/ruby.scm | 10 +++++++++-
> 1 file changed, 9 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
> index 5af1bb1cef..12c439b3a9 100644
> --- a/gnu/packages/ruby.scm
> +++ b/gnu/packages/ruby.scm
> @@ -3089,7 +3089,15 @@ (define-public ruby-ethon
> "0gggrgkcq839mamx7a8jbnp2h7x2ykfn34ixwskwb0lzx2ak17g9"))))
> (build-system ruby-build-system)
> (arguments
> - `(#:tests? #f)) ; no included tests
> + (list
> + #:tests? #f ; no included tests
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'unpack 'libcurl-use-absolute-reference
> + (lambda* (#:key inputs #:allow-other-keys)
> + (substitute* "lib/ethon/curls/settings.rb"
> + (("libcurl', 'libcurl\\.so\\.4")
> + (search-input-file inputs "/lib/libcurl.so"))))))))
> (inputs
> (list curl))
> (propagated-inputs

push, close.
-----BEGIN PGP SIGNATURE-----

iQIyBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmcnZwgACgkQO1qpk+Gi
3/Dx+Q/2K1Z4stcgPxiHod26Do5KI/+szwWkoMLIyPIGBJie255zJ+WkpAHC3kpt
2acQ9xANQORdpTDPzpeA5ps0l6m9bXuvP5MsH/nQTYX9p/CONBoOGCopO+1UXPZ2
2JFLrRg7mkV7xHSkY3DH0Mgzl28Z2sMEgP2vXBOPr5TxSkTwyiM04y6bppB557a9
QvKFs+p+8tifTpy7+FqM90K9WpcoYptIi9NiSvb8itR+SsGwhzXi2JN8roz973n9
UkPVMF/cpuTEzJgFyhSJ4iHPVCYZh3K0Ldp5yxxVzHoP0JZwl6zfoVxdSZY2LX5i
Jpy9FUo/gXrJ8OXIGotQ5mpzp+c38rb82CQ28lANuJiipn6oynSHDZITD0xWB5lS
tGsSsfGzsWuwVd0bg584CcoN2+4hYPu6sj/ogn3fQO4umYUNH3E5yPR10KS1LLku
UyB6GIQfri5vDzCD4PGmvZT5jciHW7d9Y7+L7VQf5BsIOs4gC0vwTTQyIxpgFZ/k
kVqrhKVJRy3AIg7ejN+vFjCxkPi2XfxcMEweRCipWK1ZfjBc3tvTHqDDNuDd09v0
6nUXoU7PKYXCpVDZbV62UQL4X5w1Qff1l+hUkOzm/sRZNry+jFlNFgEF47P9SnUr
CIuCBXiTmdnl3xF2JRoXvXC9fCqmFtF9h50dK9Q+AZsH2NpGQQ==
=P5aX
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74081@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74081
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch