gnu: kommit: Use Qt6.

  • Open
  • quality assurance status badge
Details
One participant
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote 2 days ago
[PATCH] gnu: commit: Use Qt6.
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
70bae7e5b1afe3c445b3da090377c3fc5ae80ed8.1730120096.git.sughosha@disroot.org
* gnu/packages/kde.scm (kommit): Use Qt6.
[arguments]<qtbase>: New argument.
<configure-flags>: New argument.
[native-inputs]: Replace kdoctools-5 with kdoctools.
[inputs]: Replace kconfigwidgets-5 with kconfigwidgets, kcoreaddons-5 with
kcoreaddons, kcrash-5 with kcrash, kdbusaddons-5 with kdbusaddons, ki18n-5 with
ki18n, kxmlgui-5 with kxmlgui, kio-5 with kio, ktextwidgets-5 with
ktextwidgets, ktexteditor-5 with ktexteditor, ksyntaxhighlighting-5 with
ksyntaxhighlighting. Add dolphin.

Change-Id: I04ad9f42a74b3a21625f85ae8e47df4f5553b6f2
---
gnu/packages/kde.scm | 34 ++++++++++++++++++++++------------
1 file changed, 22 insertions(+), 12 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 2226230aab..95b44d80d3 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -83,6 +83,8 @@ (define-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages kde-pim)
#:use-module (gnu packages kde-plasma)
+ ;; Including this module breaks the build.
+ ;#:use-module ((gnu packages kde-systemtools) #:select (dolphin))
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
@@ -1065,7 +1067,10 @@ (define-public kommit
"09ahnizl5mqdrg583lxkwwnsq8ci95fk49wx9733ah4c39gync5c"))))
(build-system qt-build-system)
(arguments
- (list #:phases
+ (list #:qtbase qtbase
+ #:configure-flags
+ #~(list "-DQT_MAJOR_VERSION=6")
+ #:phases
#~(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
@@ -1076,18 +1081,23 @@ (define-public kommit
branchestest|configtest|stashtest|filetest|overlaytest|remotetest|clonetest|\
submoduletest)")))))))
(native-inputs
- (list extra-cmake-modules kdoctools-5 pkg-config))
+ (list extra-cmake-modules kdoctools pkg-config))
(inputs
- (list kconfigwidgets-5
- kcoreaddons-5
- kcrash-5
- kdbusaddons-5
- ki18n-5
- kxmlgui-5
- kio-5
- ktextwidgets-5
- ktexteditor-5
- ksyntaxhighlighting-5
+ (list ;; module cyclic referencing
+ (module-ref
+ (resolve-interface
+ '(gnu packages kde-systemtools))
+ 'dolphin) ;for dolphin plugin
+ kconfigwidgets
+ kcoreaddons
+ kcrash
+ kdbusaddons
+ ki18n
+ kxmlgui
+ kio
+ ktextwidgets
+ ktexteditor
+ ksyntaxhighlighting
libgit2-1.8))
(home-page "https://apps.kde.org/kommit/")
(synopsis "Git client for KDE")

base-commit: f5449685143be0805a8a9b54ddecee94e368c6e9
--
2.46.0
S
S
Sughosha wrote 40 hours ago
Retitle #74061
(address . control@debbugs.gnu.org)
5827987.DvuYhMxLoT@localhost.localdomain
retitle 74061 gnu: kommit: Use Qt6.
quit

--
Sughosha
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74061@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74061
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch