[PATCH 0/2] Update LibreSSL to 4.0.0, and OpenSMTPD to 7.6.0p1

  • Open
  • quality assurance status badge
Details
One participant
  • ashish.is
Owner
unassigned
Submitted by
ashish.is
Severity
normal
A
A
ashish.is wrote 6 days ago
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
cover.1730025836.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

Hi,

Attached patch series updates LibreSSL to 4.0.0, and OpenSMTPD to
7.6.0p1. Since OpenSMTPD depends on API introduced in LibreSSL, hence
LibreSSL also needs updating in conjunction.

Ashish SHUKLA (2):
gnu: libressl: Update to 4.0.0.
gnu: opensmtpd: Update to 7.6.0p1

gnu/packages/mail.scm | 5 +++--
gnu/packages/tls.scm | 19 ++++---------------
2 files changed, 7 insertions(+), 17 deletions(-)


base-commit: 091131af64fd4e4e925fff829fa19097cfcdfcc5
--
2.47.0
A
A
ashish.is wrote 6 days ago
[PATCH 1/2] gnu: libressl: Update to 4.0.0.
(address . 74045@debbugs.gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
81b4257e2061a6102ff192cf342c9509581cc883.1730025836.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

Test certificate is updated upstream, so no need for a hack anymore.

* gnu/packages/tls.scm (libressl): Update to 4.0.0.
[native-inputs]: Remove. [arguments]<phases>: Remove.

Change-Id: Ib22aae8e48af4b4f9b5039283e563b419e629cf0
---
gnu/packages/tls.scm | 19 ++++---------------
1 file changed, 4 insertions(+), 15 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 1a1ce0d215..0f1c88f507 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -653,14 +654,14 @@ (define-public bearssl
(define-public libressl
(package
(name "libressl")
- (version "3.7.3")
+ (version "4.0.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://openbsd/LibreSSL/"
"libressl-" version ".tar.gz"))
(sha256
(base32
- "1csx6gfgiqr43dw23qj2mr5jbkcd99kqavwb4vbmp0hcm5bchj3r"))))
+ "1r518q11qwx9zr1niqjh4ci63x1s51gx6g8f3p3xzhxcy1aik12d"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -675,19 +676,7 @@ (define-public libressl
"/share/libressl-"
,(package-version this-package))
;; Provide a TLS-enabled netcat.
- "--enable-nc")
-
- #:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; 'tests/tlstest.sh' started failing in 2024 due to
- ;; an expired test certificate.
- (invoke "datefudge" "2020-01-01"
- "make" "check"
- "-j" (number->string
- (parallel-job-count)))))))))
- (native-inputs (list datefudge))
+ "--enable-nc")))
(properties
`((release-monitoring-url . "https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/")))
(home-page "https://www.libressl.org/")
--
2.47.0
A
A
ashish.is wrote 6 days ago
[PATCH 2/2] gnu: opensmtpd: Update to 7.6.0p1
(address . 74045@debbugs.gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
561338c452b74eb9e0fce8da340addc1768a4755.1730025836.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/mail.scm (opensmtpd): Update to 7.6.0p1

Change-Id: I1749cecc8c9b05ce8c9c46be5ba5f5fb961647d2
---
gnu/packages/mail.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index ead8740627..abf35c609f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2024 Benjamin Slade <slade@lambda-y.net>
;;; Copyright © 2024 Jean Simard <woshilapin@tuziwo.info>
+;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3293,14 +3294,14 @@ (define-public sieve-connect
(define-public opensmtpd
(package
(name "opensmtpd")
- (version "7.5.0p0")
+ (version "7.6.0p1")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.opensmtpd.org/archives/"
"opensmtpd-" version ".tar.gz"))
(sha256
- (base32 "1763w26zvvc3kf8giqg4lwn5n1ypmgh73agf5k3yq6qc7hww3xc4"))))
+ (base32 "15sa1vzh6rbl0c8fwl4kz5zrlarp8mxaw47q6wk3lrd6h9lq0z5j"))))
(build-system gnu-build-system)
(inputs
;; OpenSMTPd bundled (a subset of) libasr and libtls, which we use. See
--
2.47.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74045@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74045
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch