[PATCH] gnu: Add gnome-shell-extension-quick-close-in-overview

  • Open
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Qwel
Owner
unassigned
Submitted by
Qwel
Severity
normal
Q
(address . guix-patches@gnu.org)(name . Qwel)(address . qwel@e.email)
fce13b0827d6476cd541d237846b8b256993e361.1729889919.git.qwel@e.email
---
gnu/packages/gnome-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index a09c0befb0..63eaa85ff9 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1277,6 +1277,41 @@ (define-public gnome-shell-extension-vitals
bar of the GNOME Shell.")
(license license:gpl2+)))
+(define-public gnome-shell-extension-quick-close-in-overview
+ (package
+ (name "gnome-shell-extension-quick-close-in-overview")
+ (version "1.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/p91paul/middleclickclose")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "11jsagvcmpnakp1s4hh84anl23hprmkwlyb9ykbpqc64glpwp7ff"))
+ (file-name (git-file-name name version))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ #~'(("." "share/gnome-shell/extensions/"
+ #:include-regexp ("\\.compiled$" "\\.js(on)?$" "\\.mo$")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'compile-schemas
+ (lambda _
+ (with-directory-excursion
+ "middleclickclose@paolo.tranquilli.gmail.com/schemas"
+ (invoke "glib-compile-schemas" ".")))))))
+ (native-inputs (list `(,glib "bin")))
+ (synopsis
+ "Gnome shell extension for closing apps in overview with a middle click")
+ (description
+ "Close windows with a button click (the middle one by default) when in
+ overview mode.")
+ (home-page "https://github.com/p91paul/middleclickclose")
+ (license license:gpl2)))
+
(define-public arc-theme
(package
(name "arc-theme")

base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
--
2.46.0
L
L
Liliana Marie Prikler wrote on 27 Oct 12:08 +0100
d74a6db0fef5f05b16fd1631dc30a8785f159d2a.camel@gmail.com
Am Freitag, dem 25.10.2024 um 22:58 +0200 schrieb Qwel:
Toggle quote (1 lines)
> ---
Missing ChangeLog.

Toggle quote (47 lines)
>  gnu/packages/gnome-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
>  1 file changed, 35 insertions(+)
>
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index a09c0befb0..63eaa85ff9 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -1277,6 +1277,41 @@ (define-public gnome-shell-extension-vitals
>  bar of the GNOME Shell.")
>      (license license:gpl2+)))
>  
> +(define-public gnome-shell-extension-quick-close-in-overview
> +  (package
> +    (name "gnome-shell-extension-quick-close-in-overview")
> +    (version "1.9.1")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/p91paul/middleclickclose")
> +             (commit (string-append "v" version))))
> +       (sha256
> +        (base32
> "11jsagvcmpnakp1s4hh84anl23hprmkwlyb9ykbpqc64glpwp7ff"))
> +       (file-name (git-file-name name version))))
> +    (build-system copy-build-system)
> +    (arguments
> +     (list
> +      #:install-plan
> +      #~'(("." "share/gnome-shell/extensions/"
> +           #:include-regexp ("\\.compiled$" "\\.js(on)?$"
> "\\.mo$")))
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-before 'install 'compile-schemas
> +            (lambda _
> +              (with-directory-excursion
> +               "middleclickclose@paolo.tranquilli.gmail.com/schemas"
> +               (invoke "glib-compile-schemas" ".")))))))
> +    (native-inputs (list `(,glib "bin")))
> +    (synopsis
> +     "Gnome shell extension for closing apps in overview with a
> middle click")
> +    (description
> +     "Close windows with a button click (the middle one by default)
> when in
> + overview mode.")
The synopsis should be shorter, the description could be a bit longer
and better structured.
Toggle quote (2 lines)
> +    (license license:gpl2)))
Should be gpl2+.

Cheers
Q
[PATCH v3dee2d6] gnu: Add gnome-shell-extension-quick-close-in-overview
(address . 74024@debbugs.gnu.org)(name . Qwel)(address . qwel@e.email)
3dee2d6f34efdd2031fac057eaa1364b935759c5.1730813816.git.qwel@e.email
* gnu/packages/gnome-xyz (gnome-shell-extension-quick-close-in-overview): New variable.
---
gnu/packages/gnome-xyz.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 63eaa85ff9..24c5d38f9b 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1304,13 +1304,13 @@ (define-public gnome-shell-extension-quick-close-in-overview
"middleclickclose@paolo.tranquilli.gmail.com/schemas"
(invoke "glib-compile-schemas" ".")))))))
(native-inputs (list `(,glib "bin")))
- (synopsis
- "Gnome shell extension for closing apps in overview with a middle click")
+ (synopsis "Extension for closing apps in overview with a mouse click")
(description
- "Close windows with a button click (the middle one by default) when in
- overview mode.")
+ "Close windows by clicking them in overview, by default with the middle button.
+The button can be configured to any mouse button, including the 4 to 9 buttons for
+non-standard mices.")
(home-page "https://github.com/p91paul/middleclickclose")
- (license license:gpl2)))
+ (license license:gpl2+)))
(define-public arc-theme
(package

base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
prerequisite-patch-id: f7c033ee710d4061cf1580d039076032da034c07
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74024@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74024
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch