(address . guix-patches@gnu.org)(name . Qwel)(address . qwel@e.email)
---
gnu/packages/gnome-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Toggle diff (50 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index a09c0befb0..63eaa85ff9 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1277,6 +1277,41 @@ (define-public gnome-shell-extension-vitals
bar of the GNOME Shell.")
(license license:gpl2+)))
+(define-public gnome-shell-extension-quick-close-in-overview
+ (package
+ (name "gnome-shell-extension-quick-close-in-overview")
+ (version "1.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/p91paul/middleclickclose")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "11jsagvcmpnakp1s4hh84anl23hprmkwlyb9ykbpqc64glpwp7ff"))
+ (file-name (git-file-name name version))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ #~'(("." "share/gnome-shell/extensions/"
+ #:include-regexp ("\\.compiled$" "\\.js(on)?$" "\\.mo$")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'compile-schemas
+ (lambda _
+ (with-directory-excursion
+ "middleclickclose@paolo.tranquilli.gmail.com/schemas"
+ (invoke "glib-compile-schemas" ".")))))))
+ (native-inputs (list `(,glib "bin")))
+ (synopsis
+ "Gnome shell extension for closing apps in overview with a middle click")
+ (description
+ "Close windows with a button click (the middle one by default) when in
+ overview mode.")
+ (home-page "https://github.com/p91paul/middleclickclose")
+ (license license:gpl2)))
+
(define-public arc-theme
(package
(name "arc-theme")
base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
--
2.46.0