(address . guix-patches@gnu.org)(name . Noé Lopez)(address . noelopez@free.fr)
* gnu/packages/distributed.scm (distcc): New package.
Change-Id: Ibf486fbb5661e31769d8f987fc787ddfb514e57c
---
Hi,
This patch adds the « distcc » package. I’ve enabled the optional
configure flags to build the gui and enable all the features.
Good evening,
Noé
gnu/packages/distributed.scm | 44 +++++++++++++++++++++++++++++++++++-
1 file changed, 43 insertions(+), 1 deletion(-)
Toggle diff (70 lines)
diff --git a/gnu/packages/distributed.scm b/gnu/packages/distributed.scm
index b07acfd863..cdbc785027 100644
--- a/gnu/packages/distributed.scm
+++ b/gnu/packages/distributed.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2023 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2024 Vitalii Koshura <lestat.de.lionkur@gmail.com>
+;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,7 +43,13 @@ (define-module (gnu packages distributed)
#:use-module (gnu packages perl)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages python)
- #:use-module (gnu packages python-xyz))
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages avahi)
+ #:use-module (gnu packages kerberos)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages gcc)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages popt))
(define-public boinc-client
(package
@@ -97,3 +104,38 @@ (define-public boinc-server
#:parallel-build? #f))
(inputs (list curl `(,mariadb "dev") openssl zlib))
(propagated-inputs (list perl python-wrapper))))
+
+(define-public distcc
+ (package
+ (name "distcc")
+ (version "3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/distcc/distcc/releases/download/v"
+ version "/distcc-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0zdx6z6yal6952ks9njhavz26x6ywsn2x81k74lbz7ddkpdfv69b"))
+ (modules '((guix build utils)))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ; Tests use a hardcoded PATH called RESTRICTED_PATH
+ #:configure-flags #~(list "--enable-rfc2553"
+ "--with-gtk"
+ "--with-auth")))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list avahi
+ gtk+
+ libiberty
+ mit-krb5 ; for gss
+ popt
+ python-3))
+ (home-page "https://www.distcc.org/")
+ (synopsis "Distributed builds for C, C++ and Objective C")
+ (description "distcc is a program to distribute compilation of C or C++ code across
+several machines on a network. distcc should always generate the same
+results as a local compile, is simple to install and use, and is often
+two or more times faster than a local compile.")
+ (license license:gpl2+)))
base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
--
2.46.0