[PATCH] gnu: distcc: New package.

  • Done
  • quality assurance status badge
Details
3 participants
  • Noé Lopez
  • Noé Lopez
  • Z572
Owner
unassigned
Submitted by
Noé Lopez
Severity
normal
N
N
Noé Lopez wrote on 24 Oct 23:59 +0200
(address . guix-patches@gnu.org)(name . Noé Lopez)(address . noelopez@free.fr)
959a04437b696a740702cfc38afb34f4bcba2b69.1729807169.git.noelopez@free.fr
* gnu/packages/distributed.scm (distcc): New package.

Change-Id: Ibf486fbb5661e31769d8f987fc787ddfb514e57c
---
Hi,

This patch adds the « distcc » package. I’ve enabled the optional
configure flags to build the gui and enable all the features.

Good evening,
Noé

gnu/packages/distributed.scm | 44 +++++++++++++++++++++++++++++++++++-
1 file changed, 43 insertions(+), 1 deletion(-)

Toggle diff (70 lines)
diff --git a/gnu/packages/distributed.scm b/gnu/packages/distributed.scm
index b07acfd863..cdbc785027 100644
--- a/gnu/packages/distributed.scm
+++ b/gnu/packages/distributed.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2023 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2024 Vitalii Koshura <lestat.de.lionkur@gmail.com>
+;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,7 +43,13 @@ (define-module (gnu packages distributed)
#:use-module (gnu packages perl)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages python)
- #:use-module (gnu packages python-xyz))
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages avahi)
+ #:use-module (gnu packages kerberos)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages gcc)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages popt))
(define-public boinc-client
(package
@@ -97,3 +104,38 @@ (define-public boinc-server
#:parallel-build? #f))
(inputs (list curl `(,mariadb "dev") openssl zlib))
(propagated-inputs (list perl python-wrapper))))
+
+(define-public distcc
+ (package
+ (name "distcc")
+ (version "3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/distcc/distcc/releases/download/v"
+ version "/distcc-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0zdx6z6yal6952ks9njhavz26x6ywsn2x81k74lbz7ddkpdfv69b"))
+ (modules '((guix build utils)))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ; Tests use a hardcoded PATH called RESTRICTED_PATH
+ #:configure-flags #~(list "--enable-rfc2553"
+ "--with-gtk"
+ "--with-auth")))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list avahi
+ gtk+
+ libiberty
+ mit-krb5 ; for gss
+ popt
+ python-3))
+ (home-page "https://www.distcc.org/")
+ (synopsis "Distributed builds for C, C++ and Objective C")
+ (description "distcc is a program to distribute compilation of C or C++ code across
+several machines on a network. distcc should always generate the same
+results as a local compile, is simple to install and use, and is often
+two or more times faster than a local compile.")
+ (license license:gpl2+)))

base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
--
2.46.0
Z
(name . Noé Lopez)(address . noelopez@free.fr)(address . 73999@debbugs.gnu.org)
875xp7l3lr.fsf@iscas.ac.cn
Noé Lopez <noelopez@free.fr> writes:

Toggle quote (56 lines)
> * gnu/packages/distributed.scm (distcc): New package.
>
> Change-Id: Ibf486fbb5661e31769d8f987fc787ddfb514e57c
> ---
> Hi,
>
> This patch adds the « distcc » package. I’ve enabled the optional
> configure flags to build the gui and enable all the features.
>
> Good evening,
> Noé
>
> gnu/packages/distributed.scm | 44 +++++++++++++++++++++++++++++++++++-
> 1 file changed, 43 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/distributed.scm b/gnu/packages/distributed.scm
> index b07acfd863..cdbc785027 100644
> --- a/gnu/packages/distributed.scm
> +++ b/gnu/packages/distributed.scm
> @@ -4,6 +4,7 @@
> ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2023 Eric Bavier <bavier@posteo.net>
> ;;; Copyright © 2024 Vitalii Koshura <lestat.de.lionkur@gmail.com>
> +;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -42,7 +43,13 @@ (define-module (gnu packages distributed)
> #:use-module (gnu packages perl)
> #:use-module (gnu packages sqlite)
> #:use-module (gnu packages python)
> - #:use-module (gnu packages python-xyz))
> + #:use-module (gnu packages python-xyz)
> + #:use-module (gnu packages avahi)
> + #:use-module (gnu packages kerberos)
> + #:use-module (gnu packages pkg-config)
> + #:use-module (gnu packages gcc)
> + #:use-module (gnu packages gtk)
> + #:use-module (gnu packages popt))
>
> (define-public boinc-client
> (package
> @@ -97,3 +104,38 @@ (define-public boinc-server
> #:parallel-build? #f))
> (inputs (list curl `(,mariadb "dev") openssl zlib))
> (propagated-inputs (list perl python-wrapper))))
> +
> +(define-public distcc
> + (package
> + (name "distcc")
> + (version "3.4")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/distcc/distcc/releases/download/v"
> + version "/distcc-" version ".tar.gz"))

please use git-fetch. it's Better choice.

Toggle quote (5 lines)
> + (sha256
> + (base32
> + "0zdx6z6yal6952ks9njhavz26x6ywsn2x81k74lbz7ddkpdfv69b"))
> + (modules '((guix build utils)))))

if no snippet, no need add modules.

Toggle quote (4 lines)
> + (build-system gnu-build-system)
> + (arguments
> + (list #:tests? #f ; Tests use a hardcoded PATH called RESTRICTED_PATH

please add a TODO: or XXX:

Toggle quote (13 lines)
> + #:configure-flags #~(list "--enable-rfc2553"
> + "--with-gtk"
> + "--with-auth")))
> + (native-inputs
> + (list pkg-config))
> + (inputs
> + (list avahi
> + gtk+
> + libiberty
> + mit-krb5 ; for gss
> + popt
> + python-3))

if we can, please use python-minimal.

Toggle quote (9 lines)
> + (synopsis "Distributed builds for C, C++ and Objective C")
> + (description "distcc is a program to distribute compilation of C or C++ code across
> +several machines on a network. distcc should always generate the same
> +results as a local compile, is simple to install and use, and is often
> +two or more times faster than a local compile.")
> + (license license:gpl2+)))
>
> base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmckm4AACgkQO1qpk+Gi
3/B88g//fzFu0TBgoBl2CMRlDh1dip997WTDM1fEB7zKdPhamrKrwf6x0YFti8OH
l6F9f+8jOyt2w+Nu66s4qgHUVkNgsbiwThfW/3Vm0AmaVS1azI5HrvNDlf+R7Co6
XUkUHYRuOCTOOoHcIExrCUAfs26fUu6m1xWt7nhi4XcWQ1eCvGVKAM+i9NcUSGsj
6xjKCzV37FVHR6on7HVDQcGvJw2KaicdbEup8C/7fO4cIIi8re58PKiwv0zuRAAX
kDyPBNOxefJ2GhiV7gjnK8QR43ZWQdE6z1hfJtLpESYKG17X1y0mo9RMMa71bnzt
jCcTm6NddBW5FZ4WeyrI8rda4K68sjWdPBDtzoVIEAfYROHNzh5jOvShdGDpv2bB
Jhb8oVtNQQLGX4eBIE3NUscZK/kXnx8njL9DjVUpT87BvA4psafI2PkUUIpykTNG
cXBP8lRC3+/CDPWfWSOGLWlkXJk7TDaHwKTobuGsdMEoPEzsTMEBmmUlz1e70u+h
j8kG8oPDhyfojUpyEd3FpoKsB2YBfQwQDE9KkkqOL6GBHY2CzvhKyVadomGES1mo
nkS62yoKn0nS2IDCrZUxVuG1z5VcO7HNbgGeDBjJMuMTPuob0XoNU1LSqzW/NiYu
Fj+xkJqwzFsqgsoWHaxJwx8HbHkDKqnf4CU88PU6QZ4m3rqpVNA=
=zrVP
-----END PGP SIGNATURE-----

N
N
Noé Lopez wrote on 1 Nov 15:06 +0100
[PATCH v2] gnu: distcc: New package.
(address . 73999@debbugs.gnu.org)(name . Noé Lopez)(address . noelopez@free.fr)
09f7f532a47b5a2b4e4f204931b0d9fac8fbabb2.1730469659.git.noelopez@free.fr
* gnu/packages/distributed.scm (distcc): New package.

Change-Id: Ibf486fbb5661e31769d8f987fc787ddfb514e57c
---
gnu/packages/distributed.scm | 47 ++++++++++++++++++++++++++++++++++--
1 file changed, 45 insertions(+), 2 deletions(-)

Toggle diff (85 lines)
diff --git a/gnu/packages/distributed.scm b/gnu/packages/distributed.scm
index b07acfd863..7243ef4a4b 100644
--- a/gnu/packages/distributed.scm
+++ b/gnu/packages/distributed.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2023 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2024 Vitalii Koshura <lestat.de.lionkur@gmail.com>
+;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,12 +25,12 @@ (define-module (gnu packages distributed)
#:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix utils)
- #:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages autogen)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
@@ -42,7 +43,13 @@ (define-module (gnu packages distributed)
#:use-module (gnu packages perl)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages python)
- #:use-module (gnu packages python-xyz))
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages avahi)
+ #:use-module (gnu packages kerberos)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages gcc)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages popt))
(define-public boinc-client
(package
@@ -97,3 +104,39 @@ (define-public boinc-server
#:parallel-build? #f))
(inputs (list curl `(,mariadb "dev") openssl zlib))
(propagated-inputs (list perl python-wrapper))))
+
+(define-public distcc
+ (package
+ (name "distcc")
+ (version "3.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/distcc/distcc.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nn0wzrmm88268vay855hr8bw9im5f8kzjp7k20qav9yrckhfwab"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ; TODO: Tests use a hardcoded PATH called RESTRICTED_PATH
+ #:configure-flags #~(list "--enable-rfc2553"
+ "--with-gtk"
+ "--with-auth")))
+ (native-inputs
+ (list pkg-config autoconf automake which))
+ (inputs
+ (list avahi
+ gtk+
+ libiberty
+ mit-krb5 ; for gss
+ popt
+ python-minimal))
+ (home-page "https://www.distcc.org/")
+ (synopsis "Distributed builds for C, C++ and Objective C")
+ (description "distcc is a program to distribute compilation of C or C++ code across
+several machines on a network. distcc should always generate the same
+results as a local compile, is simple to install and use, and is often
+two or more times faster than a local compile.")
+ (license license:gpl2+)))

base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
--
2.46.0
N
N
Noé Lopez wrote on 1 Nov 15:08 +0100
Re: [PATCH] gnu: distcc: New package.
(address . 73999@debbugs.gnu.org)(name . Z572)(address . zhengjunjie@iscas.ac.cn)
871pzvdp2c.fsf@xn--no-cja.eu
Thanks for the review, I’ve sent an updated patch.

Have a good day,
Noé
Z
Re: [bug#73999] [PATCH v2] gnu: distcc: New package.
(name . Noé Lopez)(address . noelopez@free.fr)(address . 73999-done@debbugs.gnu.org)
87ldy1k55n.fsf@iscas.ac.cn
Noé Lopez <noelopez@free.fr> writes:

Toggle quote (91 lines)
> * gnu/packages/distributed.scm (distcc): New package.
>
> Change-Id: Ibf486fbb5661e31769d8f987fc787ddfb514e57c
> ---
> gnu/packages/distributed.scm | 47 ++++++++++++++++++++++++++++++++++--
> 1 file changed, 45 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/distributed.scm b/gnu/packages/distributed.scm
> index b07acfd863..7243ef4a4b 100644
> --- a/gnu/packages/distributed.scm
> +++ b/gnu/packages/distributed.scm
> @@ -4,6 +4,7 @@
> ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2023 Eric Bavier <bavier@posteo.net>
> ;;; Copyright © 2024 Vitalii Koshura <lestat.de.lionkur@gmail.com>
> +;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -24,12 +25,12 @@ (define-module (gnu packages distributed)
> #:use-module (guix gexp)
> #:use-module (guix packages)
> #:use-module (guix utils)
> - #:use-module (guix download)
> #:use-module (guix git-download)
> #:use-module (guix build-system gnu)
> #:use-module ((guix licenses) #:prefix license:)
> #:use-module (gnu packages)
> #:use-module (gnu packages autotools)
> + #:use-module (gnu packages autogen)
> #:use-module (gnu packages base)
> #:use-module (gnu packages compression)
> #:use-module (gnu packages databases)
> @@ -42,7 +43,13 @@ (define-module (gnu packages distributed)
> #:use-module (gnu packages perl)
> #:use-module (gnu packages sqlite)
> #:use-module (gnu packages python)
> - #:use-module (gnu packages python-xyz))
> + #:use-module (gnu packages python-xyz)
> + #:use-module (gnu packages avahi)
> + #:use-module (gnu packages kerberos)
> + #:use-module (gnu packages pkg-config)
> + #:use-module (gnu packages gcc)
> + #:use-module (gnu packages gtk)
> + #:use-module (gnu packages popt))
>
> (define-public boinc-client
> (package
> @@ -97,3 +104,39 @@ (define-public boinc-server
> #:parallel-build? #f))
> (inputs (list curl `(,mariadb "dev") openssl zlib))
> (propagated-inputs (list perl python-wrapper))))
> +
> +(define-public distcc
> + (package
> + (name "distcc")
> + (version "3.4")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/distcc/distcc.git")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0nn0wzrmm88268vay855hr8bw9im5f8kzjp7k20qav9yrckhfwab"))))
> + (build-system gnu-build-system)
> + (arguments
> + (list #:tests? #f ; TODO: Tests use a hardcoded PATH called RESTRICTED_PATH
> + #:configure-flags #~(list "--enable-rfc2553"
> + "--with-gtk"
> + "--with-auth")))
> + (native-inputs
> + (list pkg-config autoconf automake which))
> + (inputs
> + (list avahi
> + gtk+
> + libiberty
> + mit-krb5 ; for gss
> + popt
> + python-minimal))
> + (home-page "https://www.distcc.org/")
> + (synopsis "Distributed builds for C, C++ and Objective C")
> + (description "distcc is a program to distribute compilation of C or C++ code across
> +several machines on a network. distcc should always generate the same
> +results as a local compile, is simple to install and use, and is often
> +two or more times faster than a local compile.")
> + (license license:gpl2+)))
>
> base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b

adjust header and push. close.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmcmSeQACgkQO1qpk+Gi
3/BnDRAAnvMvJanndK8qbyjNErDd3tbkGFid+M/UTF9uWwvSts7efD7dpPW+/C3B
l0gJ9xVpmqeRY4NuUA0qZQnl8rj6OJ8MOO9ijPsfYTTEj1PGlHal4uij+bd4a0Op
ua1AVuJIZVOqR0U7Xd/TwMPDzfAh9HGdtytWNdcg08KYGguLQe2MJ/diUcB5yXHS
bWG/rQ9pM1R0A8JzNgRCLn/1KTulGAiH7vC1ZE8cq/MtsW46/TDtQ5100lKE0eiY
0sMmwoEGT/wncUGAKTrNBZll+cYlCs+GMLYfRfZMMAS6gc/YymAroNXgDQI0XmY6
8K7feUi0gbyH4Yggfipeul6ai3+0hUgeBAJXviyQjf+TVUo92Rh259yQpAp2K+m1
uLWYqPd7uox+K2Rts00dEY3bTu8WWnU4kQor0pg3SzIUXbr5d9rrDyXbYZmkW73i
IvI2MheOW47t8H8N77TNBq9B0xPhf+cSSAOY85cUVc4e10F9VQLoJZqyjx8d9/cD
5zSkg3+HCN1Tt/Gi2aa+gbZpwv2qCwYS0hmZ0bHDnuDFxpfCbulqjIt036PIacJP
bTpofszhWPpCwz7GGKbDE+sPYfzCd5S5YgPxU/Z8Fs7D4PdxQMXKg9gWjQ4guZcP
84/XNZWCNZ//0dABDG+T+sspL677uDIoxcDBsqKvaL2j2FM0lJs=
=yzOQ
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73999@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73999
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch