Hi,
Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:
Toggle quote (32 lines)
> * gnu/packages/freedesktop.scm (modem-manager): Update to 1.22.0.
> [source]: Switch to git-fetch.
> [build-system]: Switch to meson-build-system.
> [arguments]<#:configure-flags>: Adjust udevdir. Set -Dsystemdsystemunitdir=no.
> [inputs]: Add libqrtr-glib and elogind.
> [native-inputs]: Remove python; add python-minimal, libxslt, and
> bash-completion.
>
> Change-Id: Ife0560eb48f3cceaf22ccc6bb54010074028cddf
> ---
> gnu/packages/freedesktop.scm | 30 +++++++++++++++++-------------
> 1 file changed, 17 insertions(+), 13 deletions(-)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index ccba510303d..6eec91a907f 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -2000,34 +2000,38 @@ (define-public libqmi
> (define-public modem-manager
> (package
> (name "modem-manager")
> - (version "1.18.12")
> + (version "1.22.0")
> (source (origin
> - (method url-fetch)
> - (uri (string-append
> - "https://www.freedesktop.org/software/ModemManager/"
> - "ModemManager-" version ".tar.xz"))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.freedesktop.org/mobile-broadband/ModemManager")
Long line; please indent origin under source to help cope with that.
Toggle quote (14 lines)
> + (commit version)))
> + (file-name (git-file-name name version))
> (sha256
> (base32
> - "0c74n5jl1qvq2qlbwzfkgxny8smjcgkid1nhdnl6qnlmbn9f8r5l"))))
> - (build-system gnu-build-system)
> + "0fj4ibjfsxal3xfk3hrj4l9vg7zbj42k9lj7151illl2n3d5ngzw"))))
> + (build-system meson-build-system)
> (arguments
> (list
> #:configure-flags
> - #~(list (string-append "--with-udev-base-dir=" #$output "/lib/udev"))))
> + #~(list (string-append "-Dudevdir=" #$output "/lib/udev")
Is it /lib/udev or /lib/udev/rules.d ? I had used the later. It seems
you are correct, after checking the file hierarchy of my package:
Toggle snippet (5 lines)
gnu/store/s9jad478d7ks5cybygiibgyrgywi7dhn-modem-manager-1.22.0/lib/udev/rules.d
/gnu/store/s9jad478d7ks5cybygiibgyrgywi7dhn-modem-manager-1.22.0/lib/udev/rules.d/rules.d
/gnu/store/s9jad478d7ks5cybygiibgyrgywi7dhn-modem-manager-1.22.0/lib/udev/rules.d/rules.d/77-mm-broadmobi-port-types.rules
Toggle quote (10 lines)
> + "-Dsystemdsystemunitdir=no")))
> (native-inputs
> - (list dbus
> + (list bash-completion
> + dbus
> gettext-minimal
> gobject-introspection
> `(,glib "bin") ;for glib-mkenums
> + libxslt ; for xsltproc
nitpick: No space between ';' and the text for inline comments.
Toggle quote (8 lines)
> pkg-config
> - python
> - python-dbus
> - python-pygobject
> + python-minimal
> + python-dbus ; for test
> + python-pygobject ; for test
Please keep inputs sorted, and ditto about the space in inline comment.
Toggle quote (2 lines)
> vala))
vala bindingsn are no longer generated by default, so you'll want to add
-Dvapi=true to the configure flags.
Toggle quote (6 lines)
> (propagated-inputs
> (list glib)) ;required by mm-glib.pc
> (inputs
> - (list libgudev libmbim libqmi polkit))
> + (list elogind libgudev libmbim libqmi libqrtr-glib polkit))
I didn't list libqrtr-glib here since it should be propagated by libqmi.
Otherwise, LGTM. Feel free to update your series with my suggestions
and I'll rebase my branch after merging it. Sorry about the duplicated
work; at least it made reviewing it trivial :-).
--
Thanks,
Maxim