[PATCH] gnu: Add tuner.

  • Open
  • quality assurance status badge
Details
One participant
  • ashish.is
Owner
unassigned
Submitted by
ashish.is
Severity
normal
A
A
ashish.is wrote on 21 Oct 19:54 +0200
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
50be96afc2eac44f6c1ec910efe41a4b90000af6.1729533244.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/music.scm (tuner): New variable.

Change-Id: I4ceb4b06069c460785b477cc017dc249f786dfa1
---
Hi,

This patch adds a package for the internet radio station player "tuner"[0].

References:

Thanks!

gnu/packages/music.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (86 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9c1a617ca1..c70870bbb2 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2024 Parnikkapore <poomklao@yahoo.com>
;;; Copyright © 2024 hapster <o.rojon@posteo.net>
;;; Copyright © 2024 Nikita Domnitskii <nikita@domnitskii.me>
+;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -168,6 +169,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages netpbm)
#:use-module (gnu packages networking)
+ #:use-module (gnu packages pantheon)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
@@ -2924,6 +2926,61 @@ (define-public bristol
is subjective.")
(license license:gpl3+)))
+(define-public tuner
+ (package
+ (name "tuner")
+ (version "1.5.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/louis77/tuner")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "0svzngqhsdbmw6s07adilicdgs2v8yamzh7p7krj0z0552qsdnf6"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ; update-desktop-database
+ ("gettext-minimal" ,gettext-minimal)
+ ("glib:bin" ,glib "bin") ; glib-compile-schemas
+ ; for org.gnome.system.proxy schema
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk:bin" ,gtk "bin") ; gtk-update-icon-cache
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (inputs
+ (list bash-minimal
+ glib
+ granite-6
+ gtk+
+ libgee
+ gstreamer
+ gst-plugins-base ; for gstreamer 'playbin'
+ gst-plugins-good ; for gstreamer 'scaletempo'
+ gst-plugins-bad
+ libsoup
+ json-glib-minimal))
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson/post_install.py"
+ (("gtk-update-icon-cache") (which "true"))
+ (("update-desktop-database") (which "true")))))
+ (add-after 'install 'wrap-tuner
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/com.github.louis77.tuner")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))))))))
+ (home-page "https://github.com/louis77/tuner")
+ (synopsis "Application to discover and play internet radio stations")
+ (description "A minimalist radio station player to discover and
+listen to your favourite internet radio stations")
+ (license license:gpl3+)))
+
(define-public tuxguitar
(package
(name "tuxguitar")

base-commit: 59b2a60d0041882d732e1766e28f0df5a1ef1ac1
--
2.47.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73936@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73936
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch