[PATCH] gnu: yosys: Update to 0.46.

  • Done
  • quality assurance status badge
Details
4 participants
  • Denis 'GNUtoo' Carikli
  • Cayetano Santos
  • Jakob Kirsch
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Jakob Kirsch
Severity
normal
J
J
Jakob Kirsch wrote on 20 Oct 23:39 +0200
[PATCH v1 1/2] gnu: iverilog: Fix yosys tests
(address . guix-patches@gnu.org)(name . Jakob Kirsch)(address . jakob.kirsch@web.de)
4da104f41f60809288973a250f258ddb724616c3.1729460353.git.jakob.kirsch@web.de
* gnu/packages/fpga.scm (iverilog): [inputs]: Add zlib.

Change-Id: I961bf73b17f96a5891232a8646bc04581dfb8bfc
---
gnu/packages/fpga.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 545ec3482d..153d17d1f3 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -125,6 +125,7 @@ (define-public iverilog
#:make-flags #~(list (string-append "PREFIX="
#$output))
#:bootstrap-scripts #~(list "autoconf.sh")))
+ (inputs (list zlib))
(native-inputs (list autoconf bison flex gperf))
(home-page "https://steveicarus.github.io/iverilog")
(synopsis "FPGA Verilog simulation and synthesis tool")

base-commit: 5703914e93d81ac6037240582abe899282e78f15
--
2.46.0
J
J
Jakob Kirsch wrote on 20 Oct 23:47 +0200
[PATCH v2 1/2] gnu: iverilog: Fix yosys tests
(address . 73918@debbugs.gnu.org)(name . Jakob Kirsch)(address . jakob.kirsch@web.de)
4da104f41f60809288973a250f258ddb724616c3.1729460875.git.jakob.kirsch@web.de
* gnu/packages/fpga.scm (iverilog): [inputs]: Add zlib.

Change-Id: I961bf73b17f96a5891232a8646bc04581dfb8bfc
---
gnu/packages/fpga.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 545ec3482d..153d17d1f3 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -125,6 +125,7 @@ (define-public iverilog
#:make-flags #~(list (string-append "PREFIX="
#$output))
#:bootstrap-scripts #~(list "autoconf.sh")))
+ (inputs (list zlib))
(native-inputs (list autoconf bison flex gperf))
(home-page "https://steveicarus.github.io/iverilog")
(synopsis "FPGA Verilog simulation and synthesis tool")

base-commit: 5703914e93d81ac6037240582abe899282e78f15
--
2.46.0
J
J
Jakob Kirsch wrote on 20 Oct 23:48 +0200
[PATCH v2 2/2] gnu: yosys: Update to 0.46.
(address . 73918@debbugs.gnu.org)(name . Jakob Kirsch)(address . jakob.kirsch@web.de)
a1484d93aafb20c8ef889327b04fcc7c99497fe2.1729460875.git.jakob.kirsch@web.de
* gnu/packages/fpga.scm (yosys): Update to 0.46.

Change-Id: Ibdd4c02155ace62bf50ff9b7bb605edc21698c2a
---
gnu/packages/fpga.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 153d17d1f3..83e81bfc50 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2022 Christian Gelinek <cgelinek@radlogic.com.au>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -149,15 +150,15 @@ (define-public iverilog
(define-public yosys
(package
(name "yosys")
- (version "0.26")
+ (version "0.46")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/YosysHQ/yosys")
- (commit (string-append "yosys-" version))))
+ (commit version)))
(sha256
(base32
- "0s79ljgbcfkm7l9km7dcvlz4mnx38nbyxppscvh5il5lw07n45gx"))
+ "1zj7vbpy6v1wn4p5cjs4hdjd467a1j1aj2qhs148bl2s6mzq3p86"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
--
2.46.0
J
J
Jakob Kirsch wrote on 21 Oct 00:12 +0200
(no subject)
(address . control@debbugs.gnu.org)
ZxWATbebTuZsCPfB@kernelpanicroom
retitle 73918 [PATCH] gnu: yosys: Update to 0.46.
quit
D
D
Denis 'GNUtoo' Carikli wrote on 26 Oct 18:56 +0200
Re: [PATCH] gnu: yosys: Update to 0.46.
(address . 73918@debbugs.gnu.org)
20241026185653.45f761ee@primarylaptop.localdomain
Hi,

Thanks a lot for the patches.

Note that I'm not a Guix committer nor maintainer.

Also I'm not familiar with best practice for commit messages within the
Guix projects but other projects that care a lot about code quality
tend to indicate the commit that broke something in the commit message.

For instance in Linux we have commits like that:
Toggle quote (4 lines)
> This was broken by commit 16aac5ad1fa9 ("ovl: support encoding
> non-decodable file handles"), which didn't take the lower-only
> configuration into account.

That would simplify the review as here a reviewer will probably need to
look into what broke yosys to verify if your fix is the best possible
fix (it probably is).

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmcdH1UACgkQX138wUF3
4mM94RAAlEZqPD8NmZjlT5cVtbukbmHp5/cbS+LWcC+MfNc80ySz87QLQUGR79df
czxKKrJxZlVSmqE+9LjFGbjRevIjSV53OxvTK7WdSiLp2JE6qz3qyK927lnqYzRM
5lr4sbnboQYy9FyYmJw7sX6SGZ9Vejsfz8xWtU3IwzgetvkxSSEQkGFFwiBCNL2d
WBOciiMsCLZmM2LUIPhR1/TiJlQCOLDVaIpKTw5z/fn8DXPt1TfG6OYdkiMGI9Os
U1GYwGUaj0MPUDQfinVGD5nmU2i1HvU/TStv3Scp4slw5HXJn+cyJyhLFub78yeW
CvwlXvzETC/60kzl/J3NSODgy3dTTq8YsMG5Sz5YBLSq8ePKaHGV8unE4LTj7M92
fCRlTIWBzavYrogqJtym2l+vOHBoML60sh4TXvqZHM8a55YZ2BKScbWLTlNXp6sW
aOCLWTkGnESlCSjnXfDQRy/uQIVXq7U+wKWiEcm/TcDM/KZzIDTeVeIDG4MZZCSa
dk5FsZKsJdBzt4FxCTY0m6DNoa1cpfgZHRL7sVqFSeTrfW/fv70smtuylKfUaki9
uKSHJj2iqHbFHETw1Dt6lKTf9wAdcgm88WVnryK4PAqxhGwgyZwuPE2x7FwO02xZ
qG4qx/3Y8p4UYrgC6Nkmm7w92e6ec3M6hNxJXmfaeVFwYkD3Kto=
=zhbT
-----END PGP SIGNATURE-----


J
J
Jakob Kirsch wrote on 31 Oct 17:38 +0100
(address . 73918@debbugs.gnu.org)
ZyOycrDc9h2xaESM@kernelpanicroom
Thank you for the feedback, the commit that broke yosys was b32f8bc9da74158330cebdbcb481d41e1be6d1ce when iverilog was updated to 12.0

iverilog needs zlib as an input for a feature that yosys requires.

I fixed that with the one patch and also updated yosys in the process because it's kinda outdated.
C
C
Cayetano Santos wrote on 1 Nov 08:27 +0100
(no subject)
(address . 73918@debbugs.gnu.org)
871pzve7m1.fsf@inventati.org
As the author of the faulty commit, blindly removing zlib, I can
confirm: this patch fixes the test issues with yosys and builds yosys
0.46. Thanks !
C
C
Cayetano Santos wrote on 2 Nov 09:42 +0100
QA review for 73918
87jzdm9gdb.fsf@inventati.org
user guix
usertag 73918 + waiting-on-contributor
thanks

Guix QA review form submission:

- There is a missing dot at the end of commit message in v2 1/2

- If you send a v3, it’s better to include a link to the commit
introducing the error you’re fixing in the body of the commit message


- [linter yosys] : "bash-minimal" should be in 'inputs' when
'wrap-program' is used, you’ll need also

#:use-module (gnu packages bash)

Other than this, it builds and executes with no issue

Thanks for fixing the error !

Items marked as checked: Commit messages, Package builds, Lint warnings
D
D
Denis 'GNUtoo' Carikli wrote on 3 Nov 17:27 +0100
Re: [PATCH] gnu: yosys: Update to 0.46.
(address . 73918@debbugs.gnu.org)
20241103172732.46c2948e@primary_laptop
Hi,

Toggle quote (3 lines)
> Thank you for the feedback, the commit that broke yosys was
> b32f8bc9da74158330cebdbcb481d41e1be6d1ce when iverilog was updated to
> 12.0
Thanks a lot for the information. I also have yosys that fails because
of the missing zlib but it wasn't clear why it became needed out of the
blue. I've not build-tested the patch yet though.

The commit b32f8bc9da74158330cebdbcb481d41e1be6d1ce ("gnu: iverilog:
Update to 12.0."), also brings more questions. In it we have:
- (native-inputs
- (list flex bison ghostscript zlib)) ; ps2pdf
+ (native-inputs (list autoconf bison flex gperf))

So do we also need Ghostscript ? Though if it builds and run fine
without Ghostscript maybe ghostscript got removed because it wasn't
useful?

Also would it help if I package some functional test(s) for the FPGA
toolchain? Personally I found that it made it easier to test the
packages when I maintained them for Parabola.

Though the "functional test" I have is just the FOMU workshop code that
I modified to blink blue instead of other colors:

The downside is that tests like that are specific to an FPGA model so
I'm unsure if this is a good idea or not.

Also note that I don't know FPGAs well. I just got one to maintain some
Parabola packages.

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmcnpHQACgkQX138wUF3
4mNG3BAAsBCuHt70indrLEbKDUJJhfcVh2CToKb+uAe24WrGrJlyytSPC4YWTdQZ
7n5tJk4OAd6lp5OeGHfaXjFQat5q7lY67mUqqlvTFpXHZ/nsEVIuMwwOFT/WcVzu
9noMN0v8VjEUKG03FRB6eldVd+vOpfaJb/fXKuujMEYVRpgde7lGBijkMQ2fmxb+
IzwbAhiADbImvr9/+5J2fjdz8shSrUhFLx2RqUe8bGqegqSKyWIKP39SkEDU2Zxj
7iFcwo/wlGYmKa/F7yKibhHUTcmIYCOOchXEtUuNkIeo1jeIqvRCZu685I5ZAOWD
7YKIx19/PDqdGsk2ZzM2G+NautbWqmdFSdcBG/ukfP88/sDXxmWfPVYhJkXracUe
Czj8PSBMs0dYGuHDO3MM2bP1o70dpiommIy5cMy4J4GlR/KLgwIWSsKIl46ZqL09
U1oomSjYMNp7ZsMIFePzQcc7sAXTzYvhIVmkslVh2g8j6j7cVAMgh5L4ELOQtEfq
mHu8LesG/VsHpz/InbMDB/14tJJtAIHHP829r5XEr2voYeNjVhQuy0+XaOgptDeW
JhEMLj5q3/n00Cju1awF11OphL3X0DBaOqThXHzqF6rgW5/TUuvcEsLWU81ar2Vi
kOtpj5pmvxRmSxz9sffFuRyX/faqOxDL+u5LdmCyvsQhzMYIw1w=
=//gi
-----END PGP SIGNATURE-----


C
C
Cayetano Santos wrote on 4 Nov 11:56 +0100
Re: [bug#73918] [PATCH] gnu: yosys: Update to 0.46.
(address . gnutoo@cyberdimension.org)(address . 73918@debbugs.gnu.org)
87plnbtgh0.fsf@inventati.org
Toggle quote (2 lines)
> I've not build-tested the patch yet though.

I have, It works like a charm.

Toggle quote (4 lines)
> So do we also need Ghostscript ? Though if it builds and run fine
> without Ghostscript maybe ghostscript got removed because it wasn't
> useful?

I got removed (by me) because there is no mention to in the instructions
for installing iverilog (see readme), same as zlib. It turns out that
the later is important, though.

To that purpose, the command (that I just discovered)

guix refresh --list-dependent iverilog

outputs a list of packages (yosys here) which depends on iverilog, and
need to be rebuild upon every new modification in iverilog. If I had run
it, I would have discovered the issue on time. My bad.

In addition, having a look at the history of latest iverilog related
commits is not a bad idea.


C.
C
C
Cayetano Santos wrote on 9 Nov 20:08 +0100
[PATCH v3 1/2] gnu: iverilog: Fix yosys tests.
(address . 73918@debbugs.gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
69b9ec88a7702cad71742e45d3e8070da903d726.1731179305.git.csantosb@inventati.org
Change-Id: I262db5db43527a3a2a1753163f7b9a4104f7e895

Fixes issue introduced in


which removes zlib. This produces errors when building yosys.

Change-Id: I5b817d176430a0e717597482883d7e806c4552ab
---

See explanation in commit message.

gnu/packages/fpga.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (12 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index c812ed3b7e..ea08aed04c 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -125,7 +125,7 @@ (define-public iverilog
#:make-flags #~(list (string-append "PREFIX="
#$output))
#:bootstrap-scripts #~(list "autoconf.sh")))
+ (inputs (list zlib))
(native-inputs (list autoconf bison flex gperf))
(home-page "https://steveicarus.github.io/iverilog")
(synopsis "FPGA Verilog simulation and synthesis tool")
--
2.46.0
C
C
Cayetano Santos wrote on 9 Nov 20:08 +0100
[PATCH v3 2/2] gnu: yosys: Update to 0.46.
(address . 73918@debbugs.gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
a0a4c7a7bc05c7e7689168f6b262d6d2a803d227.1731179305.git.csantosb@inventati.org
* gnu/packages/fpga.scm (yosys): Update to 0.46.

Change-Id: Id980679e6576b27429611f8399eff2185e57d684
---
gnu/packages/fpga.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index ea08aed04c..be3e57ffb4 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2022 Christian Gelinek <cgelinek@radlogic.com.au>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@ (define-module (gnu packages fpga)
#:use-module (gnu packages autotools)
#:use-module (gnu packages algebra)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -149,15 +151,15 @@ (define-public iverilog
(define-public yosys
(package
(name "yosys")
- (version "0.26")
+ (version "0.46")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/YosysHQ/yosys")
- (commit (string-append "yosys-" version))))
+ (commit version)))
(sha256
(base32
- "0s79ljgbcfkm7l9km7dcvlz4mnx38nbyxppscvh5il5lw07n45gx"))
+ "1zj7vbpy6v1wn4p5cjs4hdjd467a1j1aj2qhs148bl2s6mzq3p86"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -216,6 +218,7 @@ (define-public yosys
tcl)) ; tclsh for the tests
(inputs
(list abc
+ bash-minimal
graphviz
gtkwave
libffi
--
2.46.0
C
C
Cayetano Santos wrote on 9 Nov 20:08 +0100
[PATCH v3 0/2] Minor corrections to v2
(address . 73918@debbugs.gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
cover.1731179305.git.csantosb@inventati.org
Add modifications neeeded as for previous QA review:

. missing dot at the end of commit message in v2 1/2
. include a link in the commit message to the commit introducing the error this patch fixes


. "bash-minimal" should be in 'inputs' when 'wrap-program' is used

Cayetano Santos (2):
gnu: iverilog: Fix yosys tests.
gnu: yosys: Update to 0.46.

gnu/packages/fpga.scm | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)

--
2.46.0
C
C
Cayetano Santos wrote on 9 Nov 20:22 +0100
QA review for 73918
87ikswcivv.fsf@inventati.org
user guix
usertag 73918 + reviewed-looks-good
thanks

Guix QA review form submission:

Items marked as checked:

- Commit messages
- Package builds
- Lint warnings
- Package tests
- Package style
- List dependent packages build
M
M
Maxim Cournoyer wrote on 12 Nov 12:40 +0100
Re: [bug#73918] [PATCH v3 2/2] gnu: yosys: Update to 0.46.
(name . Cayetano Santos)(address . csantosb@inventati.org)
871pzg65pm.fsf@gmail.com
Hello,

Cayetano Santos <csantosb@inventati.org> writes:

Toggle quote (4 lines)
> * gnu/packages/fpga.scm (yosys): Update to 0.46.
>
> Change-Id: Id980679e6576b27429611f8399eff2185e57d684

Merged this as 4bfe5fc584 and followed with an update to 0.47.

Closing!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73918@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73918
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch