QT_PLUGIN_PATH is set by guix home and causes flameshot error (Ubuntu 22.04.5 LTS)

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Rodrigo Morales
Owner
unassigned
Submitted by
Rodrigo Morales
Severity
normal
R
R
Rodrigo Morales wrote on 20 Oct 04:07 +0200
(address . bug-guix@gnu.org)
875xpn7ci3.fsf@morales.pe
I am using "guix home" for managing my dotfiles in Ubuntu 22.04.5 LTS.

I noticed that the environment variable =QT_PLUGIN_PATH= is set to paths contained within ~/.guix-home and ~/.guix-profile (see first code block below.) This created an error when trying to run the binary flameshot which was installed through =sudo apt install flameshot= (see second code block below.)

#+BEGIN_SRC text
$ env | grep -i qt
QT_ACCESSIBILITY=1
QT_IM_MODULE=ibus
QMAKEPATH=/home/rodrigo/.guix-home/profile/lib/qt5:/home/rodrigo/.guix-profile/lib/qt5
QT_PLUGIN_PATH=/home/rodrigo/.guix-home/profile/lib/qt5/plugins:/home/rodrigo/.guix-profile/lib/qt5/plugins
#+END_SRC

#+BEGIN_SRC text
$ flameshot gui ; echo Exit code: $?
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx.

zsh: IOT instruction (core dumped) flameshot gui
Exit code: 134
#+END_SRC

Let me explain how I found out that the problem was =QT_PLUGIN_PATH=: I printed debugging information when executing =flameshot= and I noticed that =flameshot= was trying to read some paths from =/gnu/store= which looked suspicious to me because =flameshot= had been installed through =sudo apt install flameshot=.

#+HEADER: :prologue "exec 2>&1"
#+HEADER: :epilogue ":"
#+BEGIN_SRC sh
which flameshot
QT_DEBUG_PLUGINS=1 flameshot
#+END_SRC

#+RESULTS:
#+begin_example
/usr/bin/flameshot
QFactoryLoader::QFactoryLoader() checking directory path "/gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms" ...
QFactoryLoader::QFactoryLoader() looking at "/gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqeglfs.so"
Found metadata in lib /gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqeglfs.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"eglfs"
]
},
"archreq": 0,
"className": "QEglFSIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("eglfs")
QFactoryLoader::QFactoryLoader() looking at "/gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqlinuxfb.so"
Found metadata in lib /gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqlinuxfb.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"linuxfb"
]
},
"archreq": 0,
"className": "QLinuxFbIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("linuxfb")
QFactoryLoader::QFactoryLoader() looking at "/gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqminimal.so"
Found metadata in lib /gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqminimal.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"minimal"
]
},
"archreq": 0,
"className": "QMinimalIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("minimal")
QFactoryLoader::QFactoryLoader() looking at "/gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqminimalegl.so"
Found metadata in lib /gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqminimalegl.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"minimalegl"
]
},
"archreq": 0,
"className": "QMinimalEglIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("minimalegl")
QFactoryLoader::QFactoryLoader() looking at "/gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqoffscreen.so"
Found metadata in lib /gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqoffscreen.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"offscreen"
]
},
"archreq": 0,
"className": "QOffscreenIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("offscreen")
QFactoryLoader::QFactoryLoader() looking at "/gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqvnc.so"
Found metadata in lib /gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqvnc.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"vnc"
]
},
"archreq": 0,
"className": "QVncIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("vnc")
QFactoryLoader::QFactoryLoader() looking at "/gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqxcb.so"
Found metadata in lib /gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqxcb.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"xcb"
]
},
"archreq": 0,
"className": "QXcbIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("xcb")
QFactoryLoader::QFactoryLoader() checking directory path "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms" ...
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqeglfs.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqeglfs.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"eglfs"
]
},
"archreq": 0,
"className": "QEglFSIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("eglfs")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqlinuxfb.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqlinuxfb.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"linuxfb"
]
},
"archreq": 0,
"className": "QLinuxFbIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("linuxfb")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqminimal.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqminimal.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"minimal"
]
},
"archreq": 0,
"className": "QMinimalIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("minimal")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqminimalegl.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqminimalegl.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"minimalegl"
]
},
"archreq": 0,
"className": "QMinimalEglIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("minimalegl")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqoffscreen.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqoffscreen.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"offscreen"
]
},
"archreq": 0,
"className": "QOffscreenIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("offscreen")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqvnc.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqvnc.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"vnc"
]
},
"archreq": 0,
"className": "QVncIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("vnc")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-egl.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-egl.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"wayland-egl"
]
},
"archreq": 0,
"className": "QWaylandEglPlatformIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("wayland-egl")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-generic.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-generic.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"wayland"
]
},
"archreq": 0,
"className": "QWaylandIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("wayland")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-xcomposite-egl.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-xcomposite-egl.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"wayland-xcomposite-egl"
]
},
"archreq": 0,
"className": "QWaylandXCompositeEglPlatformIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("wayland-xcomposite-egl")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-xcomposite-glx.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-xcomposite-glx.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"wayland-xcomposite-glx"
]
},
"archreq": 0,
"className": "QWaylandXCompositeGlxPlatformIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("wayland-xcomposite-glx")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"xcb"
]
},
"archreq": 0,
"className": "QXcbIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("xcb")
QFactoryLoader::QFactoryLoader() checking directory path "/usr/bin/platforms" ...
Cannot load library /gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqxcb.so: (/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.38' not found (required by /gnu/store/5jvnagv0pnqmiw6cfbq0qz3gvf9jq6y3-fontconfig-minimal-2.14.0/lib/libfontconfig.so.1))
QLibraryPrivate::loadPlugin failed on "/gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqxcb.so" : "Cannot load library /gnu/store/gk4wzkfnav7g5bq4j55cqfw41298raqp-qtbase-5.15.10/lib/qt5/plugins/platforms/libqxcb.so: (/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.38' not found (required by /gnu/store/5jvnagv0pnqmiw6cfbq0qz3gvf9jq6y3-fontconfig-minimal-2.14.0/lib/libfontconfig.so.1))"
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx.

Aborted (core dumped)
#+end_example

I then proceeded to print all environment variables which contained the word =qt=

#+BEGIN_SRC sh
env | grep -i qt
#+END_SRC

#+RESULTS:
#+begin_example
QMAKEPATH=/home/rodrigo/.guix-home/profile/lib/qt5:/home/rodrigo/.guix-profile/lib/qt5
QT_ACCESSIBILITY=1
QT_IM_MODULE=ibus
QT_PLUGIN_PATH=/home/rodrigo/.guix-home/profile/lib/qt5/plugins:/home/rodrigo/.guix-profile/lib/qt5/plugins
#+end_example

I then set the environment variable =QT_PLUGIN_PATH= to an empty value and I tried to execute =flameshot gui=. =flameshot= run without issues.

#+BEGIN_SRC sh
$ QT_PLUGIN_PATH= flameshot gui ; echo Exit code: $?
flameshot: info: Capture saved as /home/rodrigo/Downloads/2024-10-19_21-06.png
Exit code: 0
#+END_SRC

For those interested in looking into this bug report, here's the output when setting =QT_PLUGIN_PATH= to an empty value and enabling debugging. Note that no path under =/gnu/store= is reported.

#+BEGIN_SRC sh
QT_PLUGIN_PATH= QT_DEBUG_PLUGINS=1 flameshot gui 2>&1 | tee /tmp/a.txt
#+END_SRC

#+BEGIN_SRC sh
cat /tmp/a.txt
#+END_SRC

#+RESULTS:
#+begin_example
QFactoryLoader::QFactoryLoader() checking directory path "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms" ...
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqeglfs.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqeglfs.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"eglfs"
]
},
"archreq": 0,
"className": "QEglFSIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("eglfs")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqlinuxfb.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqlinuxfb.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"linuxfb"
]
},
"archreq": 0,
"className": "QLinuxFbIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("linuxfb")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqminimal.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqminimal.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"minimal"
]
},
"archreq": 0,
"className": "QMinimalIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("minimal")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqminimalegl.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqminimalegl.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"minimalegl"
]
},
"archreq": 0,
"className": "QMinimalEglIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("minimalegl")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqoffscreen.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqoffscreen.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"offscreen"
]
},
"archreq": 0,
"className": "QOffscreenIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("offscreen")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqvnc.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqvnc.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"vnc"
]
},
"archreq": 0,
"className": "QVncIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("vnc")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-egl.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-egl.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"wayland-egl"
]
},
"archreq": 0,
"className": "QWaylandEglPlatformIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("wayland-egl")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-generic.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-generic.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"wayland"
]
},
"archreq": 0,
"className": "QWaylandIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("wayland")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-xcomposite-egl.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-xcomposite-egl.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"wayland-xcomposite-egl"
]
},
"archreq": 0,
"className": "QWaylandXCompositeEglPlatformIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("wayland-xcomposite-egl")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-xcomposite-glx.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqwayland-xcomposite-glx.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"wayland-xcomposite-glx"
]
},
"archreq": 0,
"className": "QWaylandXCompositeGlxPlatformIntegrationPlugin",
"debug": false,
"version": 331520
}


Got keys from plugin meta data ("wayland-xcomposite-glx")
QFactoryLoader::QFactoryLoader() looking at "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so"
Found metadata in lib /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so, metadata=
{
"IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
"MetaData": {
"Keys": [
"xcb"
]
},
"archreq": 0,
"className": "QXcbIntegrationPlugin",
"debug": false,
"version": 331520
}


G
This message was truncated. Download the full message here.
M
M
Maxim Cournoyer wrote on 23 Oct 15:01 +0200
(name . Rodrigo Morales)(address . rodrigo-mailing-lists@morales.pe)(address . 73897@debbugs.gnu.org)
87plnrynw2.fsf@gmail.com
Hi Rodrigo,

Rodrigo Morales <rodrigo-mailing-lists@morales.pe> writes:

Toggle quote (23 lines)
> I am using "guix home" for managing my dotfiles in Ubuntu 22.04.5 LTS.
>
> I noticed that the environment variable =QT_PLUGIN_PATH= is set to
> paths contained within ~/.guix-home and ~/.guix-profile (see first
> code block below.) This created an error when trying to run the binary
> flameshot which was installed through =sudo apt install flameshot=
> (see second code block below.)
>
> #+BEGIN_SRC text
> $ env | grep -i qt
> QT_ACCESSIBILITY=1
> QT_IM_MODULE=ibus
> QMAKEPATH=/home/rodrigo/.guix-home/profile/lib/qt5:/home/rodrigo/.guix-profile/lib/qt5
> QT_PLUGIN_PATH=/home/rodrigo/.guix-home/profile/lib/qt5/plugins:/home/rodrigo/.guix-profile/lib/qt5/plugins
> #+END_SRC
>
> #+BEGIN_SRC text
> $ flameshot gui ; echo Exit code: $?
> qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
> This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
>
> Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx.

This reminds me of bug#54129, and also that Guix used to cobble up
PYTHONPATH for its own use, which would interfere with a foreign
distribution's Python installation.

Perhaps Qt could be patched to, on top of the usual environment
variable, accept GUIX_ prefixed ones that would be used by the Guix
search paths. This way Qt from Guix would be able to discover its installed
Qt modules without interfering with the host Qt.

Meamwhile, you also use flameshot from Guix instead, to resolve your
immediate issue.

--
Thanks,
Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73897@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73897
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch