[PATCH] gnu: faust-2: Update to 2.75.7.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal

Debbugs page

Nicolas Graves wrote 5 months ago
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20241019225801.26934-1-ngraves@ngraves.fr
* gnu/packages/audio.scm (faust-2): Update to 2.75.7, update comments
and switch to gexps.
[arguments]<#:configure-flags>: Use it here...
<#:phases>: ...and here in phase 'configure.
[native-inputs]: Remove emacs-minimal and xxd. Update llvm to
llvm-18. Improve style.
---
gnu/packages/audio.scm | 51 +++++++++++++++++++++---------------------
1 file changed, 26 insertions(+), 25 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 4fde88d454..0bff16e73b 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2268,7 +2268,7 @@ (define-public faust-0.9.67
(define-public faust-2
(package
(inherit faust)
- (version "2.41.1")
+ (version "2.75.7")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/grame-cncm/faust/"
@@ -2276,33 +2276,34 @@ (define-public faust-2
"/faust-" version ".tar.gz"))
(sha256
(base32
- "0gk8ifxrbykq7ay0nvjns8fjryhp0wfhv5npgrl8xpgw9wfmw53j"))))
+ "11ww02zmj3vnva1w52hs9wkxvhwwf53agklyzm2c7gysw0jfvkw9"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- ;; The upstream package uses make to run cmake during the build stage.
- ;; Here we ignore the Makefile and call cmake directly.
- (replace 'configure
- (lambda _
- (chdir "build")
- (invoke "cmake" "-C" "backends/all.cmake"
- (string-append "-DCMAKE_INSTALL_PREFIX="
- (assoc-ref %outputs "out")))))
- ;; The sound2faust tool would be built in the Makefile's "world" target
- (add-after 'install 'sound2faust
- (lambda _
- (chdir "../tools/sound2faust")
- (setenv "PREFIX" (assoc-ref %outputs "out"))
- (invoke "make")
- (invoke "make" "install"))))))
+ (list
+ ;; There are tests, but they are unit/regression tests scattered in 17
+ ;; different test directories, and little information indicating whether
+ ;; they are worth running for Guix. Ignore tests for now.
+ #:tests? #f
+ #:configure-flags
+ #~(list "-C" "backends/all.cmake"
+ (string-append "-DCMAKE_INSTALL_PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; The upstream package uses make to run cmake during the build stage.
+ ;; Here we ignore the Makefile and call cmake directly.
+ (replace 'configure
+ (lambda* (#:key configure-flags #:allow-other-keys)
+ (chdir "build")
+ (apply invoke "cmake" configure-flags)))
+ ;; The sound2faust tool would be built in the Makefile's "world" target
+ (add-after 'install 'sound2faust
+ (lambda _
+ (chdir "../tools/sound2faust")
+ (setenv "PREFIX" #$output)
+ (invoke "make")
+ (invoke "make" "install"))))))
(native-inputs
- `(("llvm" ,llvm)
- ("which" ,which)
- ("xxd" ,xxd)
- ("ctags" ,emacs-minimal) ; for ctags
- ("pkg-config" ,pkg-config)))
+ (list llvm-18 pkg-config which))
(inputs
(list libsndfile libmicrohttpd ncurses openssl zlib))))
--
2.46.0
Ludovic Courtès wrote 5 months ago
(name . Nicolas Graves)(address . ngraves@ngraves.fr)(address . 73893-done@debbugs.gnu.org)
87fron83z0.fsf@gnu.org
Nicolas Graves <ngraves@ngraves.fr> skribis:

Toggle quote (7 lines)
> * gnu/packages/audio.scm (faust-2): Update to 2.75.7, update comments
> and switch to gexps.
> [arguments]<#:configure-flags>: Use it here...
> <#:phases>: ...and here in phase 'configure.
> [native-inputs]: Remove emacs-minimal and xxd. Update llvm to
> llvm-18. Improve style.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73893@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73893
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help