[PATCH] gnu: Add wike.

  • Open
  • quality assurance status badge
Details
2 participants
  • Ashish SHUKLA
  • Jaft
Owner
unassigned
Submitted by
Jaft
Severity
normal
J
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
PH0PR84MB1360A7A292DB8F7FC230A15D99412@PH0PR84MB1360.NAMPRD84.PROD.OUTLOOK.COM
* gnu/packages/gnome-xyz.scm (wike): New variable.
---
 gnu/packages/gnome-xyz.scm | 53 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 53 insertions(+)

Toggle diff (84 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index a09c0befb0..1aa0926383 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -20,6 +20,7 @@
 ;;; Copyright © 2022 Sughosha <sughosha@proton.me>
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2023 Eidvilas Markevi?ius <markeviciuseidvilas@gmail.com>
+;;; Copyright © 2024 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -56,6 +57,7 @@ (define-module (gnu packages gnome-xyz)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages cmake)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
@@ -72,6 +74,7 @@ (define-module (gnu packages gnome-xyz)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages web)
+  #:use-module (gnu packages webkit)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
@@ -1759,3 +1762,53 @@ (define-public tiramisu
 notifications to STDOUT in order to allow the user to process notifications any
 way they prefer.")
     (license license:expat)))
+
+(define-public wike
+  (package
+    (name "wike")
+    (version "3.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url (string-append "https://github.com/hugolabe/" name "/"))
+                     (commit version)))
+              (sha256 (base32
+                        "1m8d9v06y4hg9dww5blg5wpg7lv6nkphfd45rjvavn2sxwq267av"))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config
+                         desktop-file-utils  ; for 'desktop-file-validate'
+                         `(,glib "bin")      ; for 'glib-compile-resources'
+                         gettext-minimal     ; for 'msgfmt'
+                         `(,gtk  "bin")      ; for gtk4-update-icon-cache
+                         cmake))
+    (inputs (list glib              ; for gio-2.0
+                  libadwaita
+                  python
+                  python-pygobject
+                  webkitgtk))
+    (arguments
+     (list #:glib-or-gtk? #t
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (wrap-program (string-append #$output "/bin/wike")
+                              `("GUIX_PYTHONPATH" =
+                                ,(search-path-as-list
+                                  `(,(string-append "/lib/python"
+                                                    #$(version-major+minor
+                                                       (package-version python))
+                                                    "/site-packages"))
+                                  (map cdr
+                                       (filter (lambda (input)
+                                                 (string-prefix? "python"
+                                                                 (car input)))
+                                               inputs))))
+                              `("GI_TYPELIB_PATH" =
+                                (,(getenv "GI_TYPELIB_PATH")))))))))
+    (synopsis "Native application to browse Wikipedia")
+    (description "Wike is a GTK application that displays Wikipedia pages.
+
+Features include bookmarking with multiple lists, article table of contents,
+browsing history, and text searches.")
+    (home-page "https://hugolabe.github.io/Wike/")
+    (license license:gpl3+)))
-- 
2.46.0
A
A
Ashish SHUKLA wrote on 19 Oct 20:53 +0200
(name . Jaft)(address . jaft.r@outlook.com)(address . 73890@debbugs.gnu.org)
D500DKDM7U2J.TG13YKN9D72Y@lostca.se
Hi,

The patch seems corrupted.

Applying: gnu: Add wike.
error: corrupt patch at line 10
Patch failed at 0001 gnu: Add wike.

Please send it again.

Thanks!
--
Ashish SHUKLA | GPG: F682 CDCC 39DC 0FEA E116 20B6 C746 CFA9 E74F A4B0

"If I destroy you, what business is it of yours ?" (Dark Forest, Liu Cixin)
-----BEGIN PGP SIGNATURE-----

iQKoBAABCgCSFiEE9oLNzDncD+rhFiC2x0bPqedPpLAFAmcUAClfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldEY2
ODJDRENDMzlEQzBGRUFFMTE2MjBCNkM3NDZDRkE5RTc0RkE0QjAUHGFzaGlzaC5p
c0Bsb3N0Y2Euc2UACgkQx0bPqedPpLDpog/+N5/DgHyxGD9bBQb+6czqtYBclPbk
9RIECMhQx2LTZGQanf/WwiZksPE813PnHCcWcKrOg5EKC33OOUAdu3qUEUkl0hjX
5A0spMKnu5JqQGyARlFywMwxvfhXNP7/aEhcbKTsMnGW/OeLzmXmTInDI5JND2Pf
uBbaOPvE9oGW2BxqTAIu04BgbudbLB2al+ZPlGJPMR+Gc+whOOssgzPQHstlUGCK
VExtJSAfIJcTvKKyCOsBUEoBjVSDZSBO+x4wh8OFhFq7sdq40LRsiqBW99Bq2XSA
0JYxWarJgP0vzirxoIwVQP39pqMrLT+Ol5lAboYkOIDOL0V3F55/dybgeIAdYMrN
C/o70EHLHou8Q5FsTddoHRlEPmSoZQUVDCTiDUaQeVM71KoMwKLLSi+WBrz/ap0W
g40NZvwWnjmMkS77vc554n1cPJ/TqqxA/qKQiZPVWTyVKzN3MdQjPQMQJhrSKnjD
KdTv64YwmhRagAee8aYgPN4TJFc58uB7/G9lfZTsg5/xaVe1J1LYPgXnJraiHEHL
s+fEkrWsATt6PL6rzG2/SkeQu55tWGqyPRiFUbaEABO5eGhW7IAOvrf4rnJWMREr
lx5mC4gDduyHG1OdttOe60RTxouVHkPTtJdIoXEi0EiEcP5nmOAaxf9eoO+RHBg2
iVqai2fJzkLGVoY=
=/5TK
-----END PGP SIGNATURE-----


J
(name . Ashish SHUKLA)(address . ashish.is@lostca.se)(name . 73890@debbugs.gnu.org)(address . 73890@debbugs.gnu.org)
PH0PR84MB136081B201355CD3DC8A44E299422@PH0PR84MB1360.NAMPRD84.PROD.OUTLOOK.COM
I'm not sure what's corrupted about it.

Unfortunately, Outlook recently revoked basic auth. so I can't (easily) use "git send-email", like I normally would.

I've attached the patch as a file; it seems to work, without error, when I use it with "git apply". Perhaps that may be more fruitful?
* gnu/packages/gnome-xyz.scm (wike): New variable.
---
gnu/packages/gnome-xyz.scm | 53 ++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (84 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index a09c0befb0..1aa0926383 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2022 Sughosha <sughosha@proton.me>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2023 Eidvilas Markevi?ius <markeviciuseidvilas@gmail.com>
+;;; Copyright © 2024 Wamm K. D. <jaft.r@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -56,6 +57,7 @@ (define-module (gnu packages gnome-xyz)
#:use-module (gnu packages bash)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
@@ -72,6 +74,7 @@ (define-module (gnu packages gnome-xyz)
#:use-module (gnu packages tls)
#:use-module (gnu packages ruby)
#:use-module (gnu packages web)
+ #:use-module (gnu packages webkit)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
@@ -1759,3 +1762,53 @@ (define-public tiramisu
notifications to STDOUT in order to allow the user to process notifications any
way they prefer.")
(license license:expat)))
+
+(define-public wike
+ (package
+ (name "wike")
+ (version "3.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/hugolabe/" name "/"))
+ (commit version)))
+ (sha256 (base32
+ "1m8d9v06y4hg9dww5blg5wpg7lv6nkphfd45rjvavn2sxwq267av"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config
+ desktop-file-utils ; for 'desktop-file-validate'
+ `(,glib "bin") ; for 'glib-compile-resources'
+ gettext-minimal ; for 'msgfmt'
+ `(,gtk "bin") ; for gtk4-update-icon-cache
+ cmake))
+ (inputs (list glib ; for gio-2.0
+ libadwaita
+ python
+ python-pygobject
+ webkitgtk))
+ (arguments
+ (list #:glib-or-gtk? #t
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs #:allow-other-keys)
+ (wrap-program (string-append #$output "/bin/wike")
+ `("GUIX_PYTHONPATH" =
+ ,(search-path-as-list
+ `(,(string-append "/lib/python"
+ #$(version-major+minor
+ (package-version python))
+ "/site-packages"))
+ (map cdr
+ (filter (lambda (input)
+ (string-prefix? "python"
+ (car input)))
+ inputs))))
+ `("GI_TYPELIB_PATH" =
+ (,(getenv "GI_TYPELIB_PATH")))))))))
+ (synopsis "Native application to browse Wikipedia")
+ (description "Wike is a GTK application that displays Wikipedia pages.
+
+Features include bookmarking with multiple lists, article table of contents,
+browsing history, and text searches.")
+ (home-page "https://hugolabe.github.io/Wike/")
+ (license license:gpl3+)))
--
2.46.0
A
A
Ashish SHUKLA wrote on 20 Oct 11:21 +0200
(name . Jaft)(address . jaft.r@outlook.com)(name . 73890@debbugs.gnu.org)(address . 73890@debbugs.gnu.org)
D50IUK1E1L67.2C3SP3KWBT315@lostca.se
On Sun Oct 20, 2024 at 5:47 AM CEST, Jaft wrote:
Toggle quote (6 lines)
> I'm not sure what's corrupted about it.
>
> Unfortunately, Outlook recently revoked basic auth. so I can't (easily) use "git send-email", like I normally would.
>
> I've attached the patch as a file; it seems to work, without error, when I use it with "git apply". Perhaps that may be more fruitful?

That worked.

Thanks!
--
Ashish SHUKLA | GPG: F682 CDCC 39DC 0FEA E116 20B6 C746 CFA9 E74F A4B0

"If I destroy you, what business is it of yours ?" (Dark Forest, Liu Cixin)
-----BEGIN PGP SIGNATURE-----

iQKoBAABCgCSFiEE9oLNzDncD+rhFiC2x0bPqedPpLAFAmcUy7VfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldEY2
ODJDRENDMzlEQzBGRUFFMTE2MjBCNkM3NDZDRkE5RTc0RkE0QjAUHGFzaGlzaC5p
c0Bsb3N0Y2Euc2UACgkQx0bPqedPpLBdAxAAlLFpvpLruD16iSQkWLAv0iMlKEeb
wVnVUVVQzq7tuZ5irt7b4oIp9EtrH+IFG+uj1iXsezPdOkvbpq3vFotqtR3bhAGN
JTdL+OCMYzLEDWft82MaB9wNOTSYT6J3lv0HrEFXc2hE5+WOF5AwkRWl39YUpMJQ
0JLcSNmAaoui3TQjK84pQOpbF+FREIV4ZyRv1A2fyvF7nFZYQG1lZDkKzPKQAOLr
IYsZqSDhS0WWPBWwqNBmEw9buzdyMTPnKpyvFvlzsur9R0XKIFiMK+umoiYb1Pq5
lHiX9HSEQTo9iTPeTd7PME6MSPqBKnNpLwdHqRH/TpNkNYTMdO/914SYS68jZQDp
uuG94+IBKKdupIF1JF9o4pXx8tpkVOacISMPG1aFl1yIKwsfJil+b1BvE8LQvpyV
sIR6aNTnqxw50LakoNacMxRyLfTGpa8wrPiouaTGzf/r4/lHrlEQGR/qNpapsKpI
Q/dCtjRqWDZA9MNtxu9Na04UOGCcK8C3Mump23I91jCClC00rIk2+NtHsBokt/xX
fHn5fSm4iemW3l3yow8u23N4xNY3MsD+MuDZAZeNZi5/LcSZysKVAifX2PqT/Cd2
3jH3HYixbKXLseZFFWAbGxdy+7dC2fnCfViCloR0UdrP1YD0NzshVVChTAn3u95M
YLmik4zcja/kOf4=
=0uDD
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73890@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73890
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch