Fabio Natali wrote 5 months ago
(address . guix-patches@gnu.org)
* gnu/services/upnp.scm: Add missing '/n' end-of-line character.
Change-Id: Ib2e584f22526f1969098b843c4be6ee386ed809c
---
Hi,
This is to fix 'readymedia-configuration->config-file'.
In its current version, the procedure may generate a corrupt configuration file.
This patch fixes things by adding a new line character at the end of every
'media_dir=' line.
I hope this looks ok.
Thanks, best wishes, Fabio.
gnu/services/upnp.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (17 lines)
diff --git a/gnu/services/upnp.scm b/gnu/services/upnp.scm
index 09121326fe..e5d05add28 100644
--- a/gnu/services/upnp.scm
+++ b/gnu/services/upnp.scm
@@ -115,7 +115,7 @@ (define (readymedia-configuration->config-file config)
(match types
(() (list))
(_ (list ",")))
- (list path))))
+ (list path "\n"))))
media-directories)
(map (match-lambda
((key . value)
base-commit: 48097f511929053468ce6f09e0a24644c90fe670
--
2.46.0