[PATCH] gnu: services: Fix readymedia service.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Fabio Natali
Owner
unassigned
Submitted by
Fabio Natali
Severity
normal

Debbugs page

Fabio Natali wrote 5 months ago
(address . guix-patches@gnu.org)
9c20a761e4a4812bd04e1112ab0cdfe8f2372f65.1729339847.git.me@fabionatali.com
* gnu/services/upnp.scm: Add missing '/n' end-of-line character.

Change-Id: Ib2e584f22526f1969098b843c4be6ee386ed809c
---
Hi,

This is to fix 'readymedia-configuration->config-file'.

In its current version, the procedure may generate a corrupt configuration file.
This patch fixes things by adding a new line character at the end of every
'media_dir=' line.

I hope this looks ok.

Thanks, best wishes, Fabio.

gnu/services/upnp.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/services/upnp.scm b/gnu/services/upnp.scm
index 09121326fe..e5d05add28 100644
--- a/gnu/services/upnp.scm
+++ b/gnu/services/upnp.scm
@@ -115,7 +115,7 @@ (define (readymedia-configuration->config-file config)
(match types
(() (list))
(_ (list ",")))
- (list path))))
+ (list path "\n"))))
media-directories)
(map (match-lambda
((key . value)

base-commit: 48097f511929053468ce6f09e0a24644c90fe670
--
2.46.0
Arun Isaac wrote 5 months ago
(address . 73878@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
87h697bnnf.fsf@systemreboot.net
Hi Fabio,

Thanks for the patch. I'll push this shortly. My laptop is just busy
building something else at the moment.

Regards,
Arun
Arun Isaac wrote 5 months ago
(address . 73878-done@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
87ed4bau8p.fsf@systemreboot.net
Pushed, thanks! I also fixed a couple of minor errors in cf33081e18 and
9b835aae10
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73878@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73878
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help