ntpd segfaults at boot (caused by use of IPv6?)

  • Done
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 19 Oct 06:00 +0200
(name . bug-guix)(address . bug-guix@gnu.org)
871q0coi6i.fsf@gmail.com
Hi,

After adjusting my system time in UEFI, I've had the ntpd daemon
terminate with exit status 11, with the following message in
/var/log/messages:

Toggle snippet (13 lines)
Oct 19 08:44:17 localhost ntpd[1658]: Soliciting pool server 160.16.113.133
Oct 19 08:44:17 localhost ntpd[1658]: 160.16.113.133 local addr <null> -> 192.168.10.119
Oct 19 08:44:18 localhost ntpd[1658]: Soliciting pool server 133.243.238.163
Oct 19 08:44:18 localhost ntpd[1658]: bind(25) AF_INET6 [2405:MASKED:af2b]:123 flags 0x11 failed: Cannot assign requested address
Oct 19 08:44:18 localhost vmunix: [ 44.506604] ntpd[1658]: segfault at 24 ip 000055d88235029b sp 00007fffdeb60e50 error 4 in ntpd[7f29b,55d8822e3000+86000] likely on CPU 0 (core 0, socket 0)
Oct 19 08:44:18 localhost vmunix: [ 44.506614] Code: 8b 04 25 28 00 00 00 48 89 44 24 08 31 c0 e8 3c 2e f9 ff 44 8b 28 48 89 c5 e8 61 9e ff ff 49 89 c4 48 85 db 0f 84 e5 00 00 00 <44> 0f b7 0b 66 41 83 f9 02 0f 84 f6 00 00 00 66 41 83 f
9 0a 74 57
Oct 19 08:44:18 localhost ntpd[1658]: unable to create socket on eno1 (6) for [2405:MASKED:af2b]:123
Oct 19 08:44:18 localhost shepherd[1]: Service ntpd (PID 1658) terminated with signal 11.
Oct 19 08:44:18 localhost shepherd[1]: Service ntpd has been disabled.
Oct 19 08:44:18 localhost shepherd[1]: (Respawning too fast.)

I've had to do:

# herd enable ntpd
# herd start ntpd

To have it run again after the boot was completed.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 19 Oct 10:07 +0200
(address . 73873@debbugs.gnu.org)
87sessms7c.fsf@gmail.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (25 lines)
> Hi,
>
> After adjusting my system time in UEFI, I've had the ntpd daemon
> terminate with exit status 11, with the following message in
> /var/log/messages:
>
> Oct 19 08:44:17 localhost ntpd[1658]: Soliciting pool server 160.16.113.133
> Oct 19 08:44:17 localhost ntpd[1658]: 160.16.113.133 local addr <null> -> 192.168.10.119
> Oct 19 08:44:18 localhost ntpd[1658]: Soliciting pool server 133.243.238.163
> Oct 19 08:44:18 localhost ntpd[1658]: bind(25) AF_INET6 [2405:MASKED:af2b]:123 flags 0x11 failed: Cannot assign requested address
> Oct 19 08:44:18 localhost vmunix: [ 44.506604] ntpd[1658]: segfault at 24 ip 000055d88235029b sp 00007fffdeb60e50 error 4 in ntpd[7f29b,55d8822e3000+86000] likely on CPU 0 (core 0, socket 0)
> Oct 19 08:44:18 localhost vmunix: [ 44.506614] Code: 8b 04 25 28 00 00 00 48 89 44 24 08 31 c0 e8 3c 2e f9 ff 44 8b 28 48 89 c5 e8 61 9e ff ff 49 89 c4 48 85 db 0f 84 e5 00 00 00 <44> 0f b7 0b 66 41 83 f9 02 0f 84 f6 00 00 00 66 41 83 f
> 9 0a 74 57
> Oct 19 08:44:18 localhost ntpd[1658]: unable to create socket on eno1 (6) for [2405:MASKED:af2b]:123
> Oct 19 08:44:18 localhost shepherd[1]: Service ntpd (PID 1658) terminated with signal 11.
> Oct 19 08:44:18 localhost shepherd[1]: Service ntpd has been disabled.
> Oct 19 08:44:18 localhost shepherd[1]: (Respawning too fast.)
>
> I've had to do:
>
> # herd enable ntpd
> # herd start ntpd
>
> To have it run again after the boot was completed.

It wasn't too longed before it crashed the same again, this time causing
Shepherd to use 100% CPU (1 core) doing almost only epoll_wait calls,
e.g.:

Toggle snippet (20 lines)
[...]
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
1 epoll_wait(8, [], 8, 0) = 0
[...]

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 19 Oct 14:55 +0200
(address . 73873-done@debbugs.gnu.org)
87r08cckvt.fsf@gmail.com
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (18 lines)
> Hi,
>
> After adjusting my system time in UEFI, I've had the ntpd daemon
> terminate with exit status 11, with the following message in
> /var/log/messages:
>
> Oct 19 08:44:17 localhost ntpd[1658]: Soliciting pool server 160.16.113.133
> Oct 19 08:44:17 localhost ntpd[1658]: 160.16.113.133 local addr <null> -> 192.168.10.119
> Oct 19 08:44:18 localhost ntpd[1658]: Soliciting pool server 133.243.238.163
> Oct 19 08:44:18 localhost ntpd[1658]: bind(25) AF_INET6 [2405:MASKED:af2b]:123 flags 0x11 failed: Cannot assign requested address
> Oct 19 08:44:18 localhost vmunix: [ 44.506604] ntpd[1658]: segfault at 24 ip 000055d88235029b sp 00007fffdeb60e50 error 4 in ntpd[7f29b,55d8822e3000+86000] likely on CPU 0 (core 0, socket 0)
> Oct 19 08:44:18 localhost vmunix: [ 44.506614] Code: 8b 04 25 28 00 00 00 48 89 44 24 08 31 c0 e8 3c 2e f9 ff 44 8b 28 48 89 c5 e8 61 9e ff ff 49 89 c4 48 85 db 0f 84 e5 00 00 00 <44> 0f b7 0b 66 41 83 f9 02 0f 84 f6 00 00 00 66 41 83 f
> 9 0a 74 57
> Oct 19 08:44:18 localhost ntpd[1658]: unable to create socket on eno1 (6) for [2405:MASKED:af2b]:123
> Oct 19 08:44:18 localhost shepherd[1]: Service ntpd (PID 1658) terminated with signal 11.
> Oct 19 08:44:18 localhost shepherd[1]: Service ntpd has been disabled.
> Oct 19 08:44:18 localhost shepherd[1]: (Respawning too fast.)

While it'd be nice to understand why ntpd segfaults when the server
doesn't support IPv6, this is now mitigated by using an IPv6-enabled
pool address by default (see: commit 503919fcf0 ("services: ntp: Default
to an address that supports IPv6.")).

Closing for now.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73873@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73873
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch