Cannot start EXWM without a display manager

  • Open
  • quality assurance status badge
Details
2 participants
  • Oleander
  • Rutherther
Owner
unassigned
Submitted by
Oleander
Severity
normal
O
O
Oleander wrote on 18 Oct 21:21 +0200
(name . bug-guix)(address . bug-guix@gnu.org)
F0Ek3ksBruusR-07HujUjxeyM2_nauYosNfRLHIdt_eZHPF5dp07ERGkrcaOQdIsSVLB5T3euk-ctsQ9sh8C6_lM6PAS4OZ1pr9y3aDnrSk=@protonmail.com
Hello,
do we have a way to start an X window manager (EXWM in my case) without installing
a display manager? The manual does not cover this subject and so far all
my attempts with the suggestions I collected from the mailing list [1]
[2] have failed. I tried xinit, startx or sx but nothing starts exwm
properly without GDM. I was only able to start exwm with xinit but it
takes longer compared to GDM and when the WM is initialized, it does not
receive any input, it is impossible to move the mouse pointer or type
anything.



My .xinitrc contains:

```
xrdb -merge ~/.Xresources
xsetroot -cursor_name left_ptr
xhost +SI:localuser:$USER
udiskie --tray &
exec dbus-launch --exit-with-session emacs
```

Thanks in advance!
Attachment: file
R
R
Rutherther wrote on 18 Oct 22:30 +0200
(address . 73869@debbugs.gnu.org)(name . Oleander)(address . 7059548@protonmail.com)
87wmi5nogu.fsf@ditigal.xyz
Hello Oleander,

so have you used the `startx-command-service-type` to
get the proper startx command?

Regards,
Rutherther
O
O
Oleander wrote on 18 Oct 23:19 +0200
oqeO8WWFy_q7dPCw2o3VUWm5l7qqmdPXTpvjY697qJBQbB6fJCpiahoLl7DT6LQKQ2pzTEkIcIlvuZbXu2CH4jAvu9oPNxTQ-Qx7JSNwopk=@protonmail.com
Hi Rutherther,
no, I haven't. Do I only need to add `(service startx-command-service-type)` to my services?

Thank you!

-------- Original Message --------
On Oct 18, 2024, 22:30, Rutherther wrote:

Toggle quote (1 lines)
> Hello Oleander, so have you used the `startx-command-service-type` to get the proper startx command? Regards, Rutherther
Attachment: file
R
R
Rutherther wrote on 19 Oct 09:15 +0200
87o73g7edm.fsf@ditigal.xyz
That should be the minimal config, yes. You can pass
the configuration to configure your keyboard layout and such.
The config is very similar to gdm-service-type, but instead
of giving out a display manager it gives out startx command
that should be used, because it has proper paths to xorg
modules, config...

Oleander <7059548@protonmail.com> writes:

Toggle quote (9 lines)
> Hi Rutherther,
> no, I haven't. Do I only need to add `(service startx-command-service-type)` to my services?
>
> Thank you!
>
> -------- Original Message --------
> On Oct 18, 2024, 22:30, Rutherther wrote:
>
>> Hello Oleander, so have you used the `startx-command-service-type` to get the proper startx command? Regards, Rutherther
O
O
Oleander wrote on 19 Oct 13:14 +0200
MWIW_jM1bI0vnxe1iadfUU_N1rG-QDgQwe9xuWH2O9Fv9bQxcVQaj5uVAEc2cf1wXZmHUiJvsv9uwLUc_2VP4mtzifLKbXIj0mv5PzIyMN4=@protonmail.com
If I add the startx service, the window manager is initialized but it does not react to any keyboard or touchpad input.

I'm using this config for xorg:

(service xorg-server-service-type)
(set-xorg-configuration
(xorg-configuration
(keyboard-layout keyboard-layout)
(extra-config
'("Section \"InputClass\"\n"
" Identifier \"libinput touchpad catchall\"\n"
" Driver \"libinput\"\n"
" MatchIsTouchpad \"on\"\n"
" MatchDevicePath \"/dev/input/event*\"\n"
" Option \"Tapping\" \"on\"\n"
" Option \"TappingDrag\" \"on\"\n"
" Option \"DisableWhileTyping\" \"on\"\n"
"EndSection\n"
"\n"
"Section \"InputClass\"\n"
" Identifier \"USB Mouse Pad USB Mouse Pad Mouse\"\n"
" Driver \"libinput\"\n"
" Option \"Middle Emulation\" \"on\"\n"
" Option \"AccelSpeed\" \"1.0\""
"EndSection\n"
"\n"
"Section \"Device\"\n"
" Identifier \"Intel Graphics\"\n"
" Driver \"intel\"\n"
" Option \"TearFree\" \"True\"\n"
" Option \"DRI\" \"2\"\n"
" Option \"AccelMethod\" \"sna\"\n"
"EndSection"
"\n"))))

-------- Original Message --------
On Oct 19, 2024, 09:15, Rutherther wrote:

Toggle quote (1 lines)
> That should be the minimal config, yes. You can pass the configuration to configure your keyboard layout and such. The config is very similar to gdm-service-type, but instead of giving out a display manager it gives out startx command that should be used, because it has proper paths to xorg modules, config... Oleander writes: > Hi Rutherther, > no, I haven't. Do I only need to add `(service startx-command-service-type)` to my services? > > Thank you! > > -------- Original Message -------- > On Oct 18, 2024, 22:30, Rutherther wrote: > >> Hello Oleander, so have you used the `startx-command-service-type` to get the proper startx command? Regards, Rutherther
Attachment: file
R
R
Rutherther wrote on 19 Oct 18:18 +0200
87h69883s9.fsf@ditigal.xyz
Toggle quote (3 lines)
> If I add the startx service, the window manager is initialized but it does not react to any keyboard or touchpad input.
>

Double check the startx you are starting is coming
from the service, and is not shadowed by another startx that
would come from other package like xinit. You can check that by
looking at the realpath of the executable you are executing
when you start startx. It should be under path with name
startx-wrapper, not under something else like xinit.


Toggle quote (5 lines)
> I'm using this config for xorg:
>
> (service xorg-server-service-type)
> (set-xorg-configuration

Do not use set-xorg-configuration when using
startx-command-service-type. Instead, put the config
you had in set-xorg-configuration to startx-command-service-type.
set-xorg-configuration is specifically for a display manager
that comes with it.

Toggle quote (33 lines)
> (xorg-configuration
> (keyboard-layout keyboard-layout)
> (extra-config
> '("Section \"InputClass\"\n"
> " Identifier \"libinput touchpad catchall\"\n"
> " Driver \"libinput\"\n"
> " MatchIsTouchpad \"on\"\n"
> " MatchDevicePath \"/dev/input/event*\"\n"
> " Option \"Tapping\" \"on\"\n"
> " Option \"TappingDrag\" \"on\"\n"
> " Option \"DisableWhileTyping\" \"on\"\n"
> "EndSection\n"
> "\n"
> "Section \"InputClass\"\n"
> " Identifier \"USB Mouse Pad USB Mouse Pad Mouse\"\n"
> " Driver \"libinput\"\n"
> " Option \"Middle Emulation\" \"on\"\n"
> " Option \"AccelSpeed\" \"1.0\""
> "EndSection\n"
> "\n"
> "Section \"Device\"\n"
> " Identifier \"Intel Graphics\"\n"
> " Driver \"intel\"\n"
> " Option \"TearFree\" \"True\"\n"
> " Option \"DRI\" \"2\"\n"
> " Option \"AccelMethod\" \"sna\"\n"
> "EndSection"
> "\n"))))
>
> -------- Original Message --------
> On Oct 19, 2024, 09:15, Rutherther wrote:
>
>> That should be the minimal config, yes. You can pass the configuration to configure your keyboard layout and such. The config is very similar to gdm-service-type, but instead of giving out a display manager it gives out startx command that should be used, because it has proper paths to xorg modules, config... Oleander writes: > Hi Rutherther, > no, I haven't. Do I only need to add `(service startx-command-service-type)` to my services? > > Thank you! > > -------- Original Message -------- > On Oct 18, 2024, 22:30, Rutherther wrote: > >> Hello Oleander, so have you used the `startx-command-service-type` to get the proper startx command? Regards, Rutherther
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73869@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73869
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch