lightdm-service-type is almost unusable

  • Open
  • quality assurance status badge
Details
3 participants
  • Dariqq
  • Maxim Cournoyer
  • Feng Shu
Owner
unassigned
Submitted by
Dariqq
Severity
normal
D
D
Dariqq wrote on 18 Oct 11:23 +0200
(address . bug-guix@gnu.org)
8fe9bf90-158c-4e03-a257-6ebf9da5ad54@posteo.net
Hi Guix,

This is to report some of the issues and workarounds when trying to
setup lightdm-service-type.


1. Unable to choose a session (https://issues.guix.gnu.org/68055)

This appearently never worked: https://issues.guix.gnu.org/57168#0

This means one currently has to specify the default session with
something like

(service lightdm-service-type
(lightdm-configuration
(seats
(list
(lightdm-seat-configuration
(name "*")
(user-session "xfce"))))))

2. gtkgreeter chooses the wrong default session

This is related to 1. If one already had set the default user session
(i.e. from using default configuration => default.xsession) or one wants
to use a different session, lightdm gtkgreeter still requests the old one.

After a lot of searching I found this

I.e. lightdm asks the accountsservice for the default-session rather
than lightm which still has cashed the old/wrong one. Thus with no
option to select a different session one is unable to login.

The workaorund here is to delete/modify /var/lib/AccountService/users to
make sure accountsservice recreates/updates the configurration.


3. After the lightdms users .Xauthority file is created it has wrong
permissions on subsequent boots.

this can be "fixed" by manually setting less restrictive permissions on
/var/lib/lightdm/.Xauthority

This might be fixed by making the lightdm-activiation snippet actually
useful: It currently searches for a file named "directory" to fix
permissions rather than the content of the variable 'directory'.

(find-files "directory" #:directories? #t) vs
(find-files directory #:directories? #t)

here

4. tigervnnc

default tigervnc is (file-append tigervnc-server "bin/Xvnc") rather than
(file-append tigervnc-server "/bin/Xvnc")
M
M
Maxim Cournoyer wrote on 23 Oct 16:48 +0200
(name . Dariqq)(address . dariqq@posteo.net)(address . 73859@debbugs.gnu.org)
87ldyezxgm.fsf@gmail.com
Hi Dariqq,

Dariqq <dariqq@posteo.net> writes:

Toggle quote (5 lines)
> Hi Guix,
>
> This is to report some of the issues and workarounds when trying to
> setup lightdm-service-type.

Thank you for taking the time to report these detailed findings!

Toggle quote (5 lines)
>
> 1. Unable to choose a session (https://issues.guix.gnu.org/68055)
>
> This appearently never worked: https://issues.guix.gnu.org/57168#0

Indeed. This definitely makes the session manager much less useful.
I'd really like to find a solution to that; I think the issue is
reported upstream here:

Just a hunch: perhaps something in the environment the greeter
runs is missing to have d-bus communication properly working?

Toggle quote (12 lines)
> This means one currently has to specify the default session with
> something like
>
> (service lightdm-service-type
> (lightdm-configuration
> (seats
> (list
> (lightdm-seat-configuration
> (name "*")
> (user-session "xfce"))))))
>

[...]

Toggle quote (10 lines)
> This might be fixed by making the lightdm-activiation snippet actually
> useful: It currently searches for a file named "directory" to fix
> permissions rather than the content of the variable 'directory'.
>
> (find-files "directory" #:directories? #t) vs
> (find-files directory #:directories? #t)
>
> here
> https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/services/lightdm.scm#n527

Fixed.

Toggle quote (5 lines)
> 4. tigervnnc
>
> default tigervnc is (file-append tigervnc-server "bin/Xvnc") rather
> than (file-append tigervnc-server "/bin/Xvnc")

Also fixed (see commit e4e1e16bc1).

--
Thanks,
Maxim
D
D
Dariqq wrote on 23 Oct 20:15 +0200
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 73859@debbugs.gnu.org)
7f748427-5276-40e9-b44a-56e9bc445ec3@posteo.net
Hi Maxim

On 23.10.24 16:48, Maxim Cournoyer wrote:
Toggle quote (24 lines)
> Hi Dariqq,
>
> Dariqq <dariqq@posteo.net> writes:
>
>> Hi Guix,
>>
>> This is to report some of the issues and workarounds when trying to
>> setup lightdm-service-type.
>
> Thank you for taking the time to report these detailed findings!
>
>>
>> 1. Unable to choose a session (https://issues.guix.gnu.org/68055)
>>
>> This appearently never worked: https://issues.guix.gnu.org/57168#0
>
> Indeed. This definitely makes the session manager much less useful.
> I'd really like to find a solution to that; I think the issue is
> reported upstream here:
> https://github.com/Xubuntu/lightdm-gtk-greeter/issues/105.
>
> Just a hunch: perhaps something in the environment the greeter
> runs is missing to have d-bus communication properly working?
>
Found all these while trying to switch from xfce to mate on a 32 bit
machine (plus skipping some tests in mates dependency tree to get it to
build) and spent way to much time trying to understand how to change the
default session.

Remotivated by your response I looked into how the greeter actually
finds the session:

1. The menu just calls out to lightdm_get_sessions

2. This eventually reaches update_sessions

Could it just be that it is using the "wrong" values for the session dir
and not the ones we specified in the lightdm config?
From what config files (if any) are we reading here?


If this is indeed the issue can we set sysconfdir to /etc and let it
read the lightdm config file from /etc/lightdm/lightdm.conf (via
config_load_from_standard_locations)?

I tried something like this (diff attached) and seems to work. I was
able to choose between xfce and mate and log into either of them.
(only slightly awkward thing is that wed need to overwrite sysconfdir
for 'make install' and should probably rename the
lightdm-configuration->greeters-config-dir function).



Toggle quote (34 lines)
>> This means one currently has to specify the default session with
>> something like
>>
>> (service lightdm-service-type
>> (lightdm-configuration
>> (seats
>> (list
>> (lightdm-seat-configuration
>> (name "*")
>> (user-session "xfce"))))))
>>
>
> [...]
>
>> This might be fixed by making the lightdm-activiation snippet actually
>> useful: It currently searches for a file named "directory" to fix
>> permissions rather than the content of the variable 'directory'.
>>
>> (find-files "directory" #:directories? #t) vs
>> (find-files directory #:directories? #t)
>>
>> here
>> https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/services/lightdm.scm#n527
>
> Fixed.
>
>> 4. tigervnnc
>>
>> default tigervnc is (file-append tigervnc-server "bin/Xvnc") rather
>> than (file-append tigervnc-server "/bin/Xvnc")
>
> Also fixed (see commit e4e1e16bc1).
>

Thanks :)
Toggle diff (45 lines)
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 5152eb6479..b210b11bc6 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -385,6 +385,7 @@ (define-public lightdm
#:parallel-tests? #f ; fails when run in parallel
#:configure-flags
#~(list "--localstatedir=/var"
+ "--sysconfdir=/etc"
"--enable-gtk-doc"
;; Otherwise the test suite fails on such a warning.
"CFLAGS=-Wno-error=missing-prototypes")
@@ -412,7 +413,11 @@ (define-public lightdm
`("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH"))))
;; Avoid printing locale warnings, which trip up the text
;; matching tests.
- (unsetenv "LC_ALL"))))))
+ (unsetenv "LC_ALL")))
+ (replace 'install
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "install" (string-append "sysconfdir=" #$output "/etc")
+ make-flags))))))
(inputs
(list audit
bash-minimal ;for cross-compilation
diff --git a/gnu/services/lightdm.scm b/gnu/services/lightdm.scm
index 798c106563..9dff263854 100644
--- a/gnu/services/lightdm.scm
+++ b/gnu/services/lightdm.scm
@@ -401,10 +401,11 @@ (define (lightdm-configuration->greeters-config-dir config)
"Return a directory containing all the serialized greeter configurations
from CONFIG, a <lightdm-configuration> object."
(file-union "etc-lightdm"
- (append-map (lambda (g)
- `((,(greeter-configuration->conf-name g)
- ,(greeter-configuration->file g))))
- (lightdm-configuration-greeters config))))
+ (cons `("lightdm.conf" ,(lightdm-configuration-file config))
+ (append-map (lambda (g)
+ `((,(greeter-configuration->conf-name g)
+ ,(greeter-configuration->file g))))
+ (lightdm-configuration-greeters config)))))
(define (lightdm-configuration->packages config)
"Return all the greeter packages and their assets defined in CONFIG, a
F
F
Feng Shu wrote on 24 Oct 02:51 +0200
lightdm
(address . 73859@debbugs.gnu.org)
8734km1fxb.fsf@163.com
Wow, good news.

Some month ago, I have spend many times to find why session can not be
found, but not success


--
F
F
Feng Shu wrote on 25 Oct 10:41 +0200
(address . 73859@debbugs.gnu.org)
87y12c60bw.fsf@163.com
I have tested and found that:


In lightdm-gtk-greeter, the following line run success and return no session.

items = lightdm_get_sessions ();


But, in lightdm, the following function in liblightdm-gobject/session.c is not called:

/**
* lightdm_get_sessions:
*
* Get the available sessions.
*
* Return value: (element-type LightDMSession) (transfer none): A list of #LightDMSession
**/
GList *
lightdm_get_sessions (void)
{
g_debug ("Run lightdm_get_sessions");
update_sessions ();
return local_sessions;
}


I do not know why, seem to very confuse.


--
D
D
Dariqq wrote on 2 Nov 11:18 +0100
[PATCH 1/2] gnu: lightdm: Use global sysconfdir.
(address . 73859@debbugs.gnu.org)
0e5a2bdf3e072e21c3ddd9a815baa8c032619028.1730541249.git.dariqq@posteo.net
* gnu/packages/display-managers.scm (lightm)
[#:configure-flags]: Set sysconfdir to /etc.
[#:phases]: Overwrite sysconfdir in 'installE. for installing sample config files

Change-Id: If9c6ce810c726551bd3bf568d50cad8680829262
---
gnu/packages/display-managers.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 5152eb6479..b210b11bc6 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -385,6 +385,7 @@ (define-public lightdm
#:parallel-tests? #f ; fails when run in parallel
#:configure-flags
#~(list "--localstatedir=/var"
+ "--sysconfdir=/etc"
"--enable-gtk-doc"
;; Otherwise the test suite fails on such a warning.
"CFLAGS=-Wno-error=missing-prototypes")
@@ -412,7 +413,11 @@ (define-public lightdm
`("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH"))))
;; Avoid printing locale warnings, which trip up the text
;; matching tests.
- (unsetenv "LC_ALL"))))))
+ (unsetenv "LC_ALL")))
+ (replace 'install
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "install" (string-append "sysconfdir=" #$output "/etc")
+ make-flags))))))
(inputs
(list audit
bash-minimal ;for cross-compilation
--
2.46.0
D
D
Dariqq wrote on 2 Nov 11:18 +0100
[PATCH 0/2] lightdm: Fix empty session list.
(address . 73859@debbugs.gnu.org)
cover.1730541249.git.dariqq@posteo.net
This changes lightdm and the service to use the config file from a well-known location in /etc/lightdm/lightdm.conf s.t. the gtk-greeter knows about our custom "sessions-directory".

I then removed the custom config file from the lightdm servcice and removed passing XDG_CONFIG_DIRS which are no longer neccesary.

Renamed lightdm-configuration->greeters-config-dir to just lightdm-configuration-directory (inspired by how the dbus-service names its directory) and also moved the etc-extension into a seperate procedure for consistency with other services.


I tested this on my i686 pc and ran 'make check-system TESTS=lightdm' successfully


This is also the approach done on NixOS, see




Dariqq (2):
gnu: lightdm: Use global sysconfdir.
gnu: lightdm-service-type: Add lightdm.conf to /etc/lightdm.

gnu/packages/display-managers.scm | 7 ++++-
gnu/services/lightdm.scm | 48 ++++++++++++++-----------------
2 files changed, 27 insertions(+), 28 deletions(-)


base-commit: ea11d3608566174c4bae70faa4f9d0c67748d2db
--
2.46.0
D
D
Dariqq wrote on 2 Nov 11:18 +0100
[PATCH 2/2] gnu: lightdm-service-type: Add lightdm.conf to /etc/lightdm.
(address . 73859@debbugs.gnu.org)
073c63896dcec5eae8e81df5fc1b6131f33add78.1730541249.git.dariqq@posteo.net
* gnu/services/lightdm.scm
(lightdm-configuration->greeters-config-dir): Rename to
lightdm-configuration-directory and add the lightdm-configuration-file.
(lightdm-shepherd-service): Don't pass the configuration file, don't set
XDG_CONFIG_DIRS
(lightdm-etc-service): New procedure.
(lightdm-service-type): Use lightdm-etc-service as the etc-extension.

Change-Id: I982ec1f7bdfd085621f45a8a1e4b175ab481202f
---
gnu/services/lightdm.scm | 48 ++++++++++++++++++----------------------
1 file changed, 21 insertions(+), 27 deletions(-)

Toggle diff (103 lines)
diff --git a/gnu/services/lightdm.scm b/gnu/services/lightdm.scm
index 798c106563..191cb5635b 100644
--- a/gnu/services/lightdm.scm
+++ b/gnu/services/lightdm.scm
@@ -397,15 +397,6 @@ (define-configuration/no-serialization lightdm-configuration
(list-of-strings '())
"Extra configuration values to append to the LightDM configuration file."))
-(define (lightdm-configuration->greeters-config-dir config)
- "Return a directory containing all the serialized greeter configurations
-from CONFIG, a <lightdm-configuration> object."
- (file-union "etc-lightdm"
- (append-map (lambda (g)
- `((,(greeter-configuration->conf-name g)
- ,(greeter-configuration->file g))))
- (lightdm-configuration-greeters config))))
-
(define (lightdm-configuration->packages config)
"Return all the greeter packages and their assets defined in CONFIG, a
<lightdm-configuration> object, as well as the lightdm package itself."
@@ -496,6 +487,16 @@ (define (lightdm-configuration-file config)
lightdm-seat-configuration-fields)))
seats))))
+(define (lightdm-configuration-directory config)
+ "Return a directory containing the serialized lightdm configuration
+and all the serialized greeter configurations from CONFIG."
+ (file-union "etc-lightdm"
+ (cons `("lightdm.conf" ,(lightdm-configuration-file config))
+ (map (lambda (g)
+ `(,(greeter-configuration->conf-name g)
+ ,(greeter-configuration->file g)))
+ (lightdm-configuration-greeters config)))))
+
(define %lightdm-accounts
(list (user-group (name "lightdm") (system? #t))
(user-account
@@ -589,9 +590,7 @@ (define (lightdm-shepherd-service config)
"/sbin/lightdm")
#$@(if (lightdm-configuration-debug? config)
#~("--debug")
- #~())
- "--config"
- #$(lightdm-configuration-file config)))
+ #~())))
(define lightdm-paths
(let ((lightdm (lightdm-configuration-lightdm config)))
@@ -601,9 +600,6 @@ (define (lightdm-shepherd-service config)
'("/bin" "/sbin" "/libexec"))
":")))
- (define greeters-config-dir
- (lightdm-configuration->greeters-config-dir config))
-
(define data-dirs
;; LightDM itself needs to be in XDG_DATA_DIRS for the accountsservice
;; interface it provides to be picked up. The greeters must also be in
@@ -626,11 +622,7 @@ (define (lightdm-shepherd-service config)
;; Lightdm needs itself in its PATH.
#:environment-variables
(list
- ;; It knows to look for greeter
- ;; configurations in XDG_CONFIG_DIRS...
- (string-append "XDG_CONFIG_DIRS="
- #$greeters-config-dir)
- ;; ... and for greeter .desktop files as
+ ;; It looks for greeter .desktop files as
;; well as lightdm accountsservice
;; interface in XDG_DATA_DIRS.
(string-append "XDG_DATA_DIRS="
@@ -638,6 +630,11 @@ (define (lightdm-shepherd-service config)
(string-append "PATH=" #$lightdm-paths))))
(stop #~(make-kill-destructor)))))
+(define (lightdm-etc-service config)
+ "Return a list of FILES for @var{etc-service-type} to build the
+/etc/lightdm directory using CONFIG"
+ (list `("lightdm" ,(lightdm-configuration-directory config))))
+
(define lightdm-service-type
(handle-xorg-configuration
lightdm-configuration
@@ -666,13 +663,10 @@ (define lightdm-service-type
;; https://github.com/NixOS/nixpkgs/issues/45059.
(service-extension profile-service-type
lightdm-configuration->packages)
- ;; This is needed for the greeter itself to find its configuration,
- ;; because XDG_CONF_DIRS gets overridden by /etc/profile.
- (service-extension
- etc-service-type
- (lambda (config)
- `(("lightdm"
- ,(lightdm-configuration->greeters-config-dir config)))))))
+ ;; This is needed for lightdm and greeter
+ ;; to find their configuration
+ (service-extension etc-service-type
+ lightdm-etc-service)))
(description "Run @code{lightdm}, the LightDM graphical login manager."))))
--
2.46.0
D
D
Dariqq wrote on 2 Nov 11:24 +0100
control message for bug #73859
(address . control@debbugs.gnu.org)
e65b8cab-e477-46c5-a4b5-51272df77a63@posteo.net
tags 73859 + patch
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73859@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73859
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch