[PATCH] gnu: dwl: Update to 0.6.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Ludovic Courtès
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
Merged with

Debbugs page

kiasoc5 wrote 5 months ago
(address . guix-patches@gnu.org)
acca1f41a620cbc60734dbc0e9dbc340@disroot.org
dwl 0.7 requires wlroots 0.18 so this is just an intermediate version
bump.
From ae898598995ad39169cb16276771c7e48d95096e Mon Sep 17 00:00:00 2001
Message-Id: <ae898598995ad39169cb16276771c7e48d95096e.1729128197.git.kiasoc5@disroot.org>
From: kiasoc5 <kiasoc5@disroot.org>
Date: Sun, 13 Oct 2024 19:03:54 -0400
Subject: [PATCH] gnu: dwl: Update to 0.6.

* gnu/packages/wm.scm (dwl): Update to 0.6.
[origin]<url>: Update repository url.
[homepage]: Update homepage.
[arguments]: Convert to G-exps, use #$output instead of assoc-ref.
[inputs]: Remove wlroots-0.16; add wlroots.

Change-Id: I567a99e88a899953049a9ce00d699ea73ee08c14
---
gnu/packages/wm.scm | 26 +++++++++++++-------------
1 file changed, 13 insertions(+), 13 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 38cb8cc717..750e9fa0ed 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1597,31 +1597,31 @@ (define-public dunst
(define-public dwl
(package
(name "dwl")
- (version "0.4")
+ (version "0.6")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/djpohly/dwl")
+ (url "https://codeberg.org/dwl/dwl")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0pj0h3zd2f60hxpavpmgzid1sj7hf9m5cgclbackljqq4gpwlvir"))))
+ "1j7lmp6k80g54hrsmwixh8ahpnbax4khgiybg8lhlvmq93618a3z"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list
- (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure
+ (list #:tests? #f ; no tests
+ #:make-flags
+ #~(list
+ #$(string-append "CC=" (cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure
(native-inputs
(list pkg-config))
(inputs
- (list wlroots-0.16))
- (home-page "https://github.com/djpohly/dwl")
+ (list wlroots))
+ (home-page "https://codeberg/dwl/dwl")
(synopsis "Dynamic window manager for Wayland")
(description
"@command{dwl} is a compact, hackable compositor for Wayland based on

base-commit: 8f0d76152a4496960f4c2ec219839c5a48b0568e
--
2.39.5
kiasoc5 wrote 5 months ago
(no subject)
(name . Control)(address . control@debbugs.gnu.org)
e09ed31f24fbe24430be4d072649e101@disroot.org
merge 73845 73843
thanks
Ludovic Courtès wrote 5 months ago
Re: [bug#73843] [PATCH v2] gnu: dwl: Update to 0.6.
(name . Noé Lopez)(address . noelopez@free.fr)
87o73dcgt4.fsf@gnu.org
Hi Noé & kiasoc5,

Noé Lopez <noelopez@free.fr> skribis:

Toggle quote (11 lines)
> From: kiasoc5 <kiasoc5@disroot.org>
>
> * gnu/packages/wm.scm (dwl): Update to 0.6.
> [origin]<url>: Update repository url.
> [homepage]: Update homepage.
> [arguments]: Convert to G-exps, use #$output instead of assoc-ref.
> [inputs]: Remove wlroots-0.16; add wlroots.
>
> Change-Id: I567a99e88a899953049a9ce00d699ea73ee08c14
> Signed-off-by: Noé Lopez <noelopez@free.fr>

Applied, thanks!

Ludo’.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73845@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73845
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help