[PATCH] gnu: kcolorpicker: Build with -fPIC

  • Done
  • quality assurance status badge
Details
2 participants
  • Doğan Çeçen
  • Z572
Owner
unassigned
Submitted by
Doğan Çeçen
Severity
normal

Debbugs page

Doğan Çeçen wrote 5 months ago
(address . guix-patches@gnu.org)(name . Doğan Çeçen)(address . sepeth@fastmail.com)
9ed0e0e450132f629dd220188251ae858cb8d570.1729069965.git.sepeth@fastmail.com
It fixes linking errors when building kimageannotator:

...
ld:
/gnu/store/...-kcolorpicker-0.3.1/lib/libkColorPicker.a(AbstractPopupMenuButton.cpp.o):
relocation R_AARCH64_ADR_PREL_PG_HI21 against symbol
`_ZN15QAbstractButton7clickedEb@@Qt_6' which may bind externally can
not be used when making a shared object; recompile with -fPIC
...

* gnu/packages/kde-frameworks.scm (kcolorpicker)[arguments]: Adjust
configure-flags to add -fPIC to CMAKE_CXX_FLAGS.

Change-Id: I38c77cc641e48b3e992e8f49fd861d9ada818240
---
gnu/packages/kde-frameworks.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 07b861c672..13d4e24726 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -660,7 +660,8 @@ (define-public kcolorpicker
(build-system qt-build-system)
(arguments
(list #:qtbase qtbase
- #:configure-flags #~(list "-DBUILD_TESTS=ON"
+ #:configure-flags #~(list "-DCMAKE_CXX_FLAGS=-fPIC"
+ "-DBUILD_TESTS=ON"
"-DBUILD_WITH_QT6=ON")))
(home-page "https://github.com/ksnip/kColorPicker")
(synopsis "Color Picker with popup menu")

base-commit: 8ffb0c14b8abdbb471788f993a7835add147e3a8
--
2.46.0
Z572 wrote 5 months ago
(name . Doğan Çeçen)(address . sepeth@fastmail.com)(address . 73836-done@debbugs.gnu.org)
87frow47pi.fsf@iscas.ac.cn
Doğan Çeçen <sepeth@fastmail.com> writes:

Toggle quote (34 lines)
> It fixes linking errors when building kimageannotator:
>
> ...
> ld:
> /gnu/store/...-kcolorpicker-0.3.1/lib/libkColorPicker.a(AbstractPopupMenuButton.cpp.o):
> relocation R_AARCH64_ADR_PREL_PG_HI21 against symbol
> `_ZN15QAbstractButton7clickedEb@@Qt_6' which may bind externally can
> not be used when making a shared object; recompile with -fPIC
> ...
>
> * gnu/packages/kde-frameworks.scm (kcolorpicker)[arguments]: Adjust
> configure-flags to add -fPIC to CMAKE_CXX_FLAGS.
>
> Change-Id: I38c77cc641e48b3e992e8f49fd861d9ada818240
> ---
> gnu/packages/kde-frameworks.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
> index 07b861c672..13d4e24726 100644
> --- a/gnu/packages/kde-frameworks.scm
> +++ b/gnu/packages/kde-frameworks.scm
> @@ -660,7 +660,8 @@ (define-public kcolorpicker
> (build-system qt-build-system)
> (arguments
> (list #:qtbase qtbase
> - #:configure-flags #~(list "-DBUILD_TESTS=ON"
> + #:configure-flags #~(list "-DCMAKE_CXX_FLAGS=-fPIC"
> + "-DBUILD_TESTS=ON"
> "-DBUILD_WITH_QT6=ON")))
> (home-page "https://github.com/ksnip/kColorPicker")
> (synopsis "Color Picker with popup menu")
>
> base-commit: 8ffb0c14b8abdbb471788f993a7835add147e3a8
Thanks, push and close.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmcPoPkACgkQO1qpk+Gi
3/AtJA/+LGbqHa81Z6fAQtRCVf8AAkG+v6tX30h7eNo4Ki6JfuyNNuscApM+P9tb
MODF0K8ZDtOqihBKzvkktGg71dGcLB0fM0cbBnCdiT4kgO2GkSW+7s2V/gro31+k
p6guLQJR7LG+bKmawx9FqRazY+pfXQqAAF6bSnt8iWzxdk653OqJRbAkI8D3IRiE
iQlT6n4SZIOzSraSAzFEVckS1iSdja1xkSVKnsJAAJ3AxPfOUqCT08/1fWWJEFLz
yPXwLYYqrCDOac2Vi+jpjCEqAVz2RIN4UcFE/i0nCFmzDrsaM6P4ZRvQCzdWhii9
2Ga9jU3x+/kY84V5tn6RPAmZeLY/xL1uzJBK99H2paZFqwuNvKehJyYY9zehMqwS
7/5Q1Cjda96po0w1lMhoCmgKO9Rj+G3usMFXfuEpa+GrZ4naMjxTg11LX7PitN6E
oZ0AB6f+i4sgXtox4+h0uH4Cb/hpe7HrvE2GtpknmlBFy5byNIcWSN50M645aKIR
zadCFjtWgKVo6C/AgLpOEqKoicvakGky8bV8Ap02nskcm9xxUec5dEqLTGpome+F
3dmcvbDnlLEuvI1Pi4GeOkC7UHdDF7XSsPaHKVht9k7DRy/zdmcl9chT2nKqSRxS
YZ9GnoC0QXQE1PH94jzZ5Z23ylhNlYbOZfmLXQItE7WJW+YPjMk=
=Bttm
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73836@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73836
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help