Hi,
On Wed, 11 Dec 2024 at 12:48, Gabriel Wicki <gabriel@erlikon.ch> wrote:
Toggle quote (3 lines)
> If you have any idea on how to patch that and could point me in that
> direction, I'll gladly send in a patch or two!
It needs to replace the phases something like:
Toggle snippet (29 lines)
1 file changed, 16 insertions(+)
gnu/packages/django.scm | 16 ++++++++++++++++
modified gnu/packages/django.scm
@@ -99,6 +99,22 @@ (define-public python-django-4.2
(setenv "PYTHONPATH" "..")
(apply invoke "python" "runtests.py" test-flags))
(format #t "test suite not run~%"))))
+ (replace 'patch-source-shebangs
+ (lambda _
+ (for-each patch-shebang
+ (find-files "."
+ (lambda (file stat)
+ (and (eq? 'regular (stat:type stat))
+ (not (string-suffix? "py-tpl" file))))
+ #:stat lstat))))
+ (replace 'patch-generated-file-shebangs
+ (lambda _
+ (for-each patch-shebang
+ (find-files "."
+ (lambda (file stat)
+ (and (eq? 'regular (stat:type stat))
+ (not (string-suffix? "py-tpl" file))))
+ #:stat lstat))))
;; XXX: The 'wrap' phase adds native inputs as runtime dependencies,
;; see <https://bugs.gnu.org/25235>. The django-admin script typically
;; runs in an environment that has Django and its dependencies on
Feel free to submit a patch. :-)
Cheers,
simon