[PATCH 0/2] gnu: Add go-github-com-kpango-glg.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote 28 hours ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1728939750.git.poptsov.artyom@gmail.com
This patch series adds go-github-com-kpango-glg[1] and its dependencies. I
took the responsibility and removed all the "blazing fast" prefixes from the
upstream package descriptions in READMEs so it may run slower now. ;-)

avp.

References:

Artyom V. Poptsov (2):
gnu: Add go-github-com-kpango-fastime.
gnu: Add go-github-com-kpango-glg.

gnu/packages/golang-xyz.scm | 50 +++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)


base-commit: 6d0a86d22d75f8f4bb602a35218513ae0aef71f1
--
2.46.0
A
A
Artyom V. Poptsov wrote 28 hours ago
[PATCH 1/2] gnu: Add go-github-com-kpango-fastime.
(address . 73809@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
c396de2a857de5e5f4e381b218360ffe0d579cc9.1728939750.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-kpango-fastime): New variable.

Change-Id: I79bf2cd7d0a3a29d2718788184560c0cfe406e4f
---
gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 942c5f5138..d238eedc40 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4061,6 +4061,30 @@ (define-public go-github-com-klauspost-cpuid-v2
(list
#:import-path "github.com/klauspost/cpuid/v2"))))
+(define-public go-github-com-kpango-fastime
+ (package
+ (name "go-github-com-kpango-fastime")
+ (version "1.1.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kpango/fastime")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18f1p5wf0zf73ky0h2hqfa6b6zryf7pq7k2r02if673x7bjlbp9h"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kpango/fastime"))
+ (home-page "https://github.com/kpango/fastime")
+ (synopsis "Fast time function library for Go")
+ (description
+ "@code{fastime} is a time function library for Go with zero memory
+allocation. @code{fastime} returns the approximate time.")
+ (license license:expat)))
+
(define-public go-github-com-kr-pretty
(package
(name "go-github-com-kr-pretty")
--
2.46.0
A
A
Artyom V. Poptsov wrote 28 hours ago
[PATCH 2/2] gnu: Add go-github-com-kpango-glg.
(address . 73809@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
df79d6e3660df1db78f77aacbe439725e0a45bf7.1728939750.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-kpango-glg): New variable.

Change-Id: Iaa457f5a53000713df0a7fad3f772e57143c9d1c
---
gnu/packages/golang-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d238eedc40..98389ec0ae 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4061,6 +4061,32 @@ (define-public go-github-com-klauspost-cpuid-v2
(list
#:import-path "github.com/klauspost/cpuid/v2"))))
+(define-public go-github-com-kpango-glg
+ (package
+ (name "go-github-com-kpango-glg")
+ (version "1.6.15")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kpango/glg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0k6y8nvj0q8mz362490cmcx15rhcpyx4sf4rv153dgh46acd1phh"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kpango/glg"))
+ (propagated-inputs (list go-github-com-goccy-go-json
+ go-github-com-kpango-fastime
+ go-github-com-sirupsen-logrus
+ go-go-uber-org-zap))
+ (home-page "https://github.com/kpango/glg")
+ (synopsis "Lock-free logging library for Go")
+ (description "@code{glg} is simple lock-free logging library for Go.")
+ (license license:expat)))
+
(define-public go-github-com-kpango-fastime
(package
(name "go-github-com-kpango-fastime")
--
2.46.0
S
S
Sharlatan Hellseher wrote 10 hours ago
[PATCH 0/2] gnu: Add go-github-com-kpango-glg.
(address . 73809@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
87wmi9pg97.fsf@gmail.com
Hi,

QA is blazing fast for that patches, and it's green!

One neat pick:
- new lines for descriptions:
Toggle snippet (4 lines)
(description
"@code{glg} is simple lock-free logging library for Go.")

- maybe, place list of inputs on a new line as well, and sort it, e.g.
Toggle snippet (7 lines)
(propagated-inputs
(list go-github-com-goccy-go-json
go-github-com-kpango-fastime
go-github-com-sirupsen-logrus
go-go-uber-org-zap))

- some small style suggestion on this:
Toggle snippet (4 lines)
+ (description
+ "@code{fastime} is a time function library for Go with zero memory
+allocation. @code{fastime} returns the approximate time.")
Toggle quote (2 lines)
> ... returning the approximate time.

You may apply styling adjustment before push, LGFM, feel free to push it.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmcOgnQACgkQdtcnv/Ys
0rUfLxAAiDC5qfCLJOKM0N19+j4NNnCFdOZMYlJAxVGnzeiVtQvXtWJ8dfN3YSAb
L87PSGWxZRi0cTtNA6xPRYZAhHOtVEPi2HoaLXA2uLmEzHPGKAg3ELFeLchy/ZT8
ril5ivRJYJ2KKzwU8ml8qe/iaUyhjxkBmR5VhZ7heAuMZCBmDS0BHv5zANDGxaYQ
7kV5PsN2veRUng2UXuQB+dR9dsW3zL2Mte+1FF14C2RLSpXrhb/cH0BMUlDdWjc9
Wukhr8Bq8d/q5HeumfSKtTjLbZpglkb1vKgIi+4jDN8PS3rqK9mhptzWFxJddOBB
FicFQe6+VNPcSPyYO37RoLMK9U+RZO8USY16cw6soQW8NYBWccfqWpQQqDpgJwBs
HGW0grNfN70gVs0dRmZyGUr3bV/0uFpJ5HjLjRkNUwcV6v9uhS14NrNCUvuBmWkU
ZmGJGd7BQzLTFc8GAMJGVNr9ApWFC+i/aPbVTB4WFxPvpZHHHlRcT7i7R2yOdYdT
vcMTG1ZaKjs73k6QvFptxhm07cAbV9CKnyuw4VAjiUka005xTIWo+vgceo31Q+cl
fOpmVKSLV8JYv+f6FBlo6CFQVVsmjatOLdwZT4Msgk47Y0kQrKtjZWHws5ilLUtN
86VWtPNDCDspXEV30Kwtk3by+hiEhMdSAStivcypEQPbDi097mw=
=H1qX
-----END PGP SIGNATURE-----

A
A
Artyom V. Poptsov wrote 5 hours ago
Re: [PATCH 2/2] gnu: Add go-github-com-kpango-glg.
(address . 73809-done@debbugs.gnu.org)
87v7xtrv5c.fsf@gmail.com
Reviewed by Sharlatan Hellseher <sharlatanus@gmail.com>.

Pushed to the "master" branch as:
- f5ae687319852ed3eca6bb83a139a2a9e71cbfe9
- 8ffb0c14b8abdbb471788f993a7835add147e3a8

Thanks,
- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmcOypEZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfm+yD/wKiEj+PPXKNQLuFa0zU5UT
0bqHZl/6xlWZt1PYu23V2e+4X2luKGcKf8H/EDJesFoPhcuZH4hQiF/Ism+SEyMp
eHZbMqBk+SxdNNMiCjeppHKMyuEcqbjarVzOqo0wzwE03x96VgeeKcXNIE6CGgVn
1uUQDU06dIqI8R7n8qmRomNkEGY7oGVB8yUwRiCb/xEQgR9CSGOzJFmm+I/QUu60
BHBoPnD/aCpGgyDa+1Oz+EsGLk0N9KFuFe4gysa1cUSCMb9pQI4HPd8QDxlUCBEz
mJHwc8/jXi4ILf8lPKVFwmRaxO0+0I2u7zVrTOCUgrUZ8fyNhoOM9q1e0xFCZF0G
mk2iWZ0PnapITu4imjmWIBkX1cLP7z4nvRTUjtdRSVCq4qNropkz4OvK4Lg1hpdz
uLx3NNLWLHR3cr7NF2RKwGXacsHRoAQMM7wE5s80FGaXbKB5MCwYYc8T5ASN/z6y
n9YOhfD9iUjTUS4i+DhiX87H7BbAbTEAP3lq3b+07XvyoNUnEgkTNEnTXLEafQrb
y+MhB5S+CI4GfVal/CitBKHV8IYZX+CEffAdhnxKan1lWKak4AczebwrRM2zUXsU
7THbbPbPCw3oJErAJCzXgwbPy/PahaY0VDRu+YdOF8kONr9wtbQYAvjbYYgSQ+CF
S+wNH1HmeCIMJloVnVakbA==
=/9Fn
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73809@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73809
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch