[PATCH staging 0/2] Upgrade json-c to v0.18

  • Open
  • quality assurance status badge
Details
One participant
  • Aaron Covrig
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal

Debbugs page

Aaron Covrig wrote 5 months ago
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241013153842.284364-1-aaron.covrig.us@ieee.org
This upgrades json-c to v0.18 and adds json-c-0.15 incase someone needs
to depend on the older version. I have not built all the json-c
dependent packages (`guix refresh --list-dependent json-c`); but had no
issues building the packages found within the repo using `rg ' json-c
'`. Additionally, this upgrades the json-c dependency for hubbub to the
latest version (build succeeded with json-c v0.18). I believe this
removes all the json-c@0.12 dependents so that this library can now be
removed as was mentioned in the web.scm file.

Hubbub README on json-c inclusion can be found here:

I have not attempted to replace json-c@v0.13; doing so looks like it
will require several other packages to be upgraded first.

Aaron Covrig (2):
gnu: json-c: Update to v0.18
gnu: hubbub: Remove dependency on json-c v0.12

gnu/packages/web.scm | 38 +++++++++++++++++++++++++++-----------
1 file changed, 27 insertions(+), 11 deletions(-)


base-commit: e032a0f38ff3394816fdc29554933ce77c545eff
--
2.46.0
Aaron Covrig wrote 5 months ago
[PATCH staging 1/2] gnu: json-c: Update to v0.18
(address . 73794@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241013154344.330506-1-aaron.covrig.us@ieee.org
* gnu/packages/web.scm (json-c): Update to v0.18
* gnu/packages/web.scm (json-c-0.15): New variable
---
gnu/packages/web.scm | 36 ++++++++++++++++++++++++++----------
1 file changed, 26 insertions(+), 10 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f1938d7b11..53238e7f16 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1269,16 +1269,17 @@ (define-public jansson
(define-public json-c
(package
(name "json-c")
- (version "0.15")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
- version ".tar.gz"))
- (sha256
- (base32
- "1im484iz08j3gmzpw07v16brwq46pxxj65i996kkp2vivcfhmn5q"))))
+ (version "0.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "090pn7gyicvpqq01451zhkjw1fw3h4l6v2f6mxlvhrli8x3b0sl7"))))
(build-system cmake-build-system)
+ (native-inputs (list doxygen))
(home-page "https://github.com/json-c/json-c/wiki")
(synopsis "JSON implementation in C")
(description
@@ -1288,10 +1289,25 @@ (define-public json-c
It aims to conform to RFC 7159.")
(license license:x11)))
+(define-public json-c-0.15
+ (package
+ (inherit json-c)
+ (name "json-c")
+ (version "0.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1im484iz08j3gmzpw07v16brwq46pxxj65i996kkp2vivcfhmn5q"))))
+ (build-system cmake-build-system)))
+
;; TODO: Remove these old versions when all dependents have been updated.
(define-public json-c-0.13
(package
- (inherit json-c)
+ (inherit json-c-0.15)
(version "0.13.1")
(source (origin
(method url-fetch)
--
2.46.0
Aaron Covrig wrote 5 months ago
[PATCH staging 2/2] gnu: hubbub: Remove dependency on json-c v0.12
(address . 73794@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241013154344.330506-2-aaron.covrig.us@ieee.org
* gnu/packages/web.scm (hubbub): Update json-c dependency
---
gnu/packages/web.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 53238e7f16..cf15e9328a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5797,7 +5797,7 @@ (define-public hubbub
pkg-config
doxygen
gperf
- json-c-0.12 ; check whether json-c-0.12 can be removed
+ json-c
perl))
(propagated-inputs
(list libparserutils)) ;for libhubbub.pc
--
2.46.0
Aaron Covrig wrote 4 months ago
[PATCH 2/2] gnu: hubbub: Remove dependency on json-c v0.12
(address . 73794@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241027221542.51629-2-aaron.covrig.us@ieee.org
* gnu/packages/web.scm (hubbub): Update json-c dependency
---
gnu/packages/web.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0d21306e6e..01b256a424 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5823,7 +5823,7 @@ (define-public hubbub
pkg-config
doxygen
gperf
- json-c-0.12 ; check whether json-c-0.12 can be removed
+ json-c
perl))
(propagated-inputs
(list libparserutils)) ;for libhubbub.pc
--
2.46.0
Aaron Covrig wrote 4 months ago
[PATCH 1/2] gnu: json-c: Update to v0.18
(address . 73794@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241027221542.51629-1-aaron.covrig.us@ieee.org
* gnu/packages/web.scm (json-c): Update to v0.18
* gnu/packages/web.scm (json-c-0.15): New variable
* gnu/packages/web.scm: Deprecate json-c < 0.18
---
gnu/packages/web.scm | 82 +++++++++++++++++++++++++++-----------------
1 file changed, 50 insertions(+), 32 deletions(-)

Toggle diff (124 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 34739bf088..0d21306e6e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -87,6 +87,7 @@ (define-module (gnu packages web)
#:use-module (ice-9 match)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix deprecation)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix cvs-download)
@@ -1269,16 +1270,17 @@ (define-public jansson
(define-public json-c
(package
(name "json-c")
- (version "0.15")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
- version ".tar.gz"))
- (sha256
- (base32
- "1im484iz08j3gmzpw07v16brwq46pxxj65i996kkp2vivcfhmn5q"))))
+ (version "0.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "090pn7gyicvpqq01451zhkjw1fw3h4l6v2f6mxlvhrli8x3b0sl7"))))
(build-system cmake-build-system)
+ (native-inputs (list doxygen))
(home-page "https://github.com/json-c/json-c/wiki")
(synopsis "JSON implementation in C")
(description
@@ -1289,9 +1291,24 @@ (define-public json-c
(license license:x11)))
;; TODO: Remove these old versions when all dependents have been updated.
-(define-public json-c-0.13
+(define-deprecated/public json-c-0.15 #f
(package
(inherit json-c)
+ (name "json-c")
+ (version "0.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1im484iz08j3gmzpw07v16brwq46pxxj65i996kkp2vivcfhmn5q"))))
+ (build-system cmake-build-system)))
+
+(define-deprecated/public json-c-0.13 #f
+ (package
+ (inherit json-c-0.15)
(version "0.13.1")
(source (origin
(method url-fetch)
@@ -1312,31 +1329,32 @@ (define-public json-c-0.13
#t))))
(build-system gnu-build-system)))
-(define-public json-c-0.12
+(define-deprecated/public json-c-0.12 #f
(package
(inherit json-c-0.13)
(version "0.12.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
- version ".tar.gz"))
- (sha256
- (base32 "08qibrq29a5v7g23wi5icy6l4fbfw90h9ccps6vq0bcklx8n84ra"))
- (patches (search-patches "json-c-0.12-CVE-2020-12762.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Somehow 'config.h.in' is older than
- ;; 'aclocal.m4', which would trigger a rule to
- ;; run 'autoheader'.
- (set-file-time "config.h.in"
- (stat "aclocal.m4"))
-
- ;; Don't try to build with -Werror.
- (substitute* (find-files "." "Makefile\\.in")
- (("-Werror") ""))
- #t))))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "08qibrq29a5v7g23wi5icy6l4fbfw90h9ccps6vq0bcklx8n84ra"))
+ (patches (search-patches "json-c-0.12-CVE-2020-12762.patch"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ ;; Somehow 'config.h.in' is older than
+ ;; 'aclocal.m4', which would trigger a rule to
+ ;; run 'autoheader'.
+ (set-file-time "config.h.in"
+ (stat "aclocal.m4"))
+
+ ;; Don't try to build with -Werror.
+ (substitute* (find-files "." "Makefile\\.in")
+ (("-Werror")
+ ""))
+ #t))))))
(define-public json-parser
(package

base-commit: 091131af64fd4e4e925fff829fa19097cfcdfcc5
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73794@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73794
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help