[PATCH] gnu: doxygen: Update to v1.12.0

  • Open
  • quality assurance status badge
Details
One participant
  • Aaron Covrig
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal
A
A
Aaron Covrig wrote on 13 Oct 15:42 +0200
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241013134243.77527-1-aaron.covrig.us@ieee.org
* gnu/packages/documentation.scm (doxygen): Update to 1.12.0
---
gnu/packages/documentation.scm | 89 ++++++++++++++++------------------
1 file changed, 42 insertions(+), 47 deletions(-)

Toggle diff (112 lines)
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 47cdc9668b..76be32244e 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -186,61 +186,56 @@ (define-deprecated asciidoc-py3 asciidoc)
(define-public doxygen
(package
(name "doxygen")
- (version "1.9.8")
+ (version "1.12.0")
(home-page "https://www.doxygen.nl/")
- (source (origin
- (method url-fetch)
- (uri (list (string-append home-page "files/doxygen-"
- version ".src.tar.gz")
- (string-append "mirror://sourceforge/doxygen/rel-"
- version "/doxygen-" version
- ".src.tar.gz")))
- (sha256
- (base32
- "0qjgw7bnx668hpi4r8m366vsq118s9365zf8z4x5yjrqx0ld5qq5"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (list (string-append home-page "files/doxygen-" version
+ ".src.tar.gz")
+ (string-append "mirror://sourceforge/doxygen/rel-" version
+ "/doxygen-" version ".src.tar.gz")))
+ (sha256
+ (base32 "0d0nn2w52jr1px1g6bi5hzhdp6yil11gr8l17pc0kx4f06idp8x3"))))
(build-system cmake-build-system)
- (native-inputs
- (list bison
- flex
- libxml2 ;provides xmllint for the tests
- python)) ;for creating the documentation
- (inputs
- (list bash-minimal))
+ (native-inputs (list bison flex libxml2 python))
+ (inputs (list bash-minimal))
(arguments
;; Force cmake to use iconv header from cross-libc instead of the one
;; from native libc.
(list
- #:configure-flags
- (if (%current-target-system)
- #~(list (string-append "-DICONV_INCLUDE_DIR="
- (assoc-ref %build-inputs "cross-libc")
- "/include"))
- #~'())
+ #:configure-flags (if (%current-target-system)
+ #~(list (string-append "-DICONV_INCLUDE_DIR="
+ (assoc-ref %build-inputs
+ "cross-libc")
+ "/include"))
+ #~'())
#:test-target "tests"
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'disable-bibtex-test
- (lambda _
- ;; Disable test that requires bibtex to avoid a
- ;; circular dependency.
- (for-each delete-file-recursively
- '("testing/012" "testing/012_cite.dox"))))
- (add-before 'configure 'patch-sh
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((/bin/sh (search-input-file inputs "/bin/sh")))
- (substitute* "src/portable.cpp"
- (("/bin/sh")
- /bin/sh)))))
- #$@(if (target-hurd?)
- #~((add-after 'unpack 'apply-patch
- (lambda _
- (let ((patch-file
- #$(local-file
- (search-patch "doxygen-hurd.patch"))))
- (invoke "patch" "--force" "-p1" "-i" patch-file)))))
- #~()))))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-bibtex-test
+ (lambda _
+ ;; Disable test that requires bibtex to avoid a
+ ;; circular dependency.
+ (for-each delete-file-recursively
+ '("testing/012" "testing/012_cite.dox"))))
+ (add-before 'configure 'patch-sh
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((/bin/sh (search-input-file inputs "/bin/sh")))
+ (substitute* "src/portable.cpp"
+ (("/bin/sh")
+ /bin/sh)))))
+ #$@(if (target-hurd?)
+ #~((add-after 'unpack
+ 'apply-patch
+ (lambda _
+ (let ((patch-file #$(local-file (search-patch
+ "doxygen-hurd.patch"))))
+ (invoke "patch" "--force" "-p1"
+ "-i" patch-file)))))
+ #~()))))
(synopsis "Generate documentation from annotated sources")
- (description "Doxygen is the de facto standard tool for generating
+ (description
+ "Doxygen is the de facto standard tool for generating
documentation from annotated C++ sources, but it also supports other popular
programming languages such as C, Objective-C, C#, PHP, Java, Python,
IDL (Corba, Microsoft, and UNO/OpenOffice flavors), Fortran, VHDL, Tcl,

base-commit: e032a0f38ff3394816fdc29554933ce77c545eff
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73790@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73790
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch