(address . guix-patches@gnu.org)(name . Rutherther)(address . rutherther@ditigal.xyz)
Apart from the update itself there seems to have been
a regression in lib_foundation. The package seems to
only look into absolute paths for libunistring library,
or falls back to static one found by cmake find_library.
There are numerous ways to solve that, but I think it should
be fine to use the static output. The resulting lib_foundation
is also a statically linked library.
The out output canont be
only replaced, as then headers are not found. Another
solution could be to patch the Depends.cmake under lib_foundation
to look into proper paths.
* gnu/packages/web-browsers.scm (lagrange): Update to 1.18.1
* gnu/packages/web-browsers.scm (lagrange) [inputs]: Add libunistring static output
Change-Id: I64fde81b2e653cc510a22c81c79815cc51f35ea3
---
gnu/packages/web-browsers.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
Toggle diff (34 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 7f04af981a..bc2709c3d0 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -732,7 +732,7 @@ (define-public nyxt
(define-public lagrange
(package
(name "lagrange")
- (version "1.17.6")
+ (version "1.18.1")
(source
(origin
(method url-fetch)
@@ -740,7 +740,7 @@ (define-public lagrange
(string-append "https://git.skyjake.fi/skyjake/lagrange/releases/"
"download/v" version "/lagrange-" version ".tar.gz"))
(sha256
- (base32 "0fsjn74cmrchqgnj88yzdxyj1gm0i2vrzh69b9b9bi7y2wk9il5r"))
+ (base32 "0l6wcjbz2z7vx82411nldp43rcq2s6nhphhwp85ca21bm3zc87ai"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -758,6 +758,7 @@ (define-public lagrange
(list freetype
fribidi
harfbuzz
+ `(,libunistring "static")
libunistring
libwebp
mpg123
base-commit: 7a89bbffd081129da8c2c5b58b4e12133bf210c5
--
2.46.0