[PATCH] gnu: Upgrade googlebenchmark

  • Open
  • quality assurance status badge
Details
One participant
  • Aaron Covrig
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal

Debbugs page

Aaron Covrig wrote 5 months ago
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241012014207.130885-1-aaron.covrig.us@ieee.org
* gnu/packages/check.scm (googlebenchmark): Upgrade to 1.9.0
---
gnu/packages/check.scm | 30 ++++++++++++++++--------------
1 file changed, 16 insertions(+), 14 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 8d41996c71..e0bd71e6d3 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -105,6 +105,7 @@ (define-module (gnu packages check)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages time)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages version-control)
#:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -1098,24 +1099,25 @@ (define-public googletest-1.8
(define-public googlebenchmark
(package
(name "googlebenchmark")
- (version "1.8.3")
+ (version "1.9.0")
(home-page "https://github.com/google/benchmark")
- (source (origin
- (method git-fetch)
- (uri (git-reference (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name "google-benchmark" version))
- (sha256
- (base32
- "1hf8xrdd9k57kw3mpdi68a78fd96vzdqv3179v2yy5dxx336ffw3"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "google-benchmark" version))
+ (sha256
+ (base32 "0pvv6vww5qgkl821rn6jhh2bmfjqs6amkcj4ybws4pg1i0y7bjg5"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
- (string-append
- "-DGOOGLETEST_PATH="
- (assoc-ref %build-inputs "googletest")))))
- (inputs
- `(("googletest" ,(package-source googletest))))
+ (string-append "-DGOOGLETEST_PATH="
+ (assoc-ref %build-inputs
+ "googletest")))))
+ (inputs `(("git" ,git)
+ ("googletest" ,(package-source googletest))))
(synopsis "C++ library to support the benchmarking of functions")
(description
"The googlebenchmark C++ library support the benchmarking of functions,

base-commit: b8fd792ea267cb920da0651074a533d8abf00488
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73760@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73760
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help