[PATCH] gnu: Upgrade googletest

  • Open
  • quality assurance status badge
Details
One participant
  • Aaron Covrig
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal
A
A
Aaron Covrig wrote on 12 Oct 03:16 +0200
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241012011637.120015-1-aaron.covrig.us@ieee.org
* gnu/packages/check.scm (googletest): Upgrade to 1.15.2
---
gnu/packages/check.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 8d41996c71..a74052fa35 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1059,16 +1059,16 @@ (define-public python-gixy
(define-public googletest
(package
(name "googletest")
- (version "1.12.1")
+ (version "1.15.2")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/google/googletest")
- (commit (string-append "release-" version))))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1cv55x3amwrvfan9pr8dfnicwr8r6ar3yf6cg9v6nykd6m2v3qsv"))))
+ (base32 "0wvivz9hxxs8gdmqx0v4g012lqi43fpzvndwmx6i0wdcwi4pdqnl"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))

base-commit: b8fd792ea267cb920da0651074a533d8abf00488
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73759@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73759
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch