[PATCH] gnu: cutecom: Add cutecom v0.51.0

  • Open
  • quality assurance status badge
Details
One participant
  • Aaron Covrig
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal
A
A
Aaron Covrig wrote on 12 Oct 2024 01:50
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241011235040.98501-1-aaron.covrig.us@ieee.org
* gnu/packages/terminals.scm (cutecom): New variable
---
gnu/packages/terminals.scm | 37 ++++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 701686258d..936d66a654 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022, 2023 jgart <jgart@dismail.de>
-;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
+;;; Copyright © 2023, 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
@@ -846,6 +846,41 @@ (define-public cool-retro-term
license:x11
license:bsd-3))))
+(define-public cutecom
+ (package
+ (name "cutecom")
+ (version "0.51.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/cutecom/cutecom")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zprabjs4z26hsb64fc3k790aiiqiz9d88j666xrzi4983m1bfv8"))))
+ (build-system cmake-build-system)
+ (inputs (list qtbase-5 qtserialport-5))
+ (arguments
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ ;; Patch in missing QT 5.15 required include
+ (add-after 'unpack 'patch-includes
+ (lambda _
+ (substitute* "ctrlcharacterspopup.cpp"
+ (("#include <QPainter>" all)
+ (string-append all "\n" "#include <QPainterPath>"))))))))
+ (home-page "https://gitlab.com/cutecom/cutecom")
+ (synopsis "Graphical serial terminal")
+ (description
+ "CuteCom is a graphical serial terminal, like minicom. Currently it runs
+on Linux (tested) and should run on FreeBSD, Mac OS X and maybe other systems as
+well (untested). It is aimed mainly at hardware developers or other people who
+need a terminal to talk to their devices. It is free software and distributed
+under the GNU General Public License Version 3. It is written using the Qt
+library originally created by Trolltech.")
+ (license license:gpl3)))
+
(define-public foot
(package
(name "foot")

base-commit: b8fd792ea267cb920da0651074a533d8abf00488
--
2.46.0
A
A
Aaron Covrig wrote on 24 Oct 2024 22:58
[PATCH v1] gnu: cutecom: Add cutecom v0.51.0
(address . 73757@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241024205913.986276-1-aaron.covrig.us@ieee.org
* gnu/packages/terminals.scm (cutecom): New variable
---
gnu/packages/terminals.scm | 37 ++++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index fbfc4439db..6ae9489eca 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022, 2023 jgart <jgart@dismail.de>
-;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
+;;; Copyright © 2023, 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
@@ -846,6 +846,41 @@ (define-public cool-retro-term
license:x11
license:bsd-3))))
+(define-public cutecom
+ (package
+ (name "cutecom")
+ (version "0.51.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/cutecom/cutecom")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zprabjs4z26hsb64fc3k790aiiqiz9d88j666xrzi4983m1bfv8"))))
+ (build-system cmake-build-system)
+ (inputs (list qtbase-5 qtserialport-5))
+ (arguments
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ ;; Patch in missing QT 5.15 required include
+ (add-after 'unpack 'patch-includes
+ (lambda _
+ (substitute* "ctrlcharacterspopup.cpp"
+ (("#include <QPainter>" all)
+ (string-append all "\n" "#include <QPainterPath>"))))))))
+ (home-page "https://gitlab.com/cutecom/cutecom")
+ (synopsis "Graphical serial terminal")
+ (description
+ "CuteCom is a graphical serial terminal, like minicom. Currently it runs
+on Linux (tested) and should run on FreeBSD, Mac OS X and maybe other systems as
+well (untested). It is aimed mainly at hardware developers or other people who
+need a terminal to talk to their devices. It is free software and distributed
+under the GNU General Public License Version 3. It is written using the Qt
+library originally created by Trolltech.")
+ (license license:gpl3)))
+
(define-public foot
(package
(name "foot")

base-commit: 573a07b689fedcf3f36fa46a4625153fda273344
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73757@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73757
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch